Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Zombie Mod

[ROZWIĄZANE] AUTO BH BIOHAZARDproblem

zombie mod auto bh biohazard

Najlepsza odpowiedź Aemiksowy , 30.03.2014 17:40

Czy Ty jesteś jakiś pomylony? 

 

  1. stock bool:alive_zombie(index){
  2. if(is_user_alive(index) && is_user_zombie(index)){
  3. return true;
  4. }
  5. return false;
  6. }

masz tu ewidentnie funkcję sprawdzającą... Potem w prethinku:

  1. if( !alive_zombie(id) )
  2. return PLUGIN_HANDLED_MAIN;

 

U Ciebie niczego nie ma o tym. Więc czego mnie minusujesz? Jak tylko zdobędę power usera, to się odwdzięczę. 

 

Właśnie się znam i to bardzo dobrze na biohazard w przeciwieństwie do Ciebie. Jak widać, w sygnaturze masz serwer i stawiam, że jest on Twój. Jeżeli tak, to gratuluję Ci w kwestii rozwoju... - właśnie widać Twoje umiejętności konfiguracji.

 

Tu jest Twój plugin, który mu dałeś: http://wklej.org/id/1317121/ - gdzie Ty masz bibliotekę biohazard???

 

Pozdrawiam

Przejdź do postu


  • Zamknięty Temat jest zamknięty
18 odpowiedzi w tym temacie

#1 Jelen.

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 02:00

Witam , mam duzy problem z biohazard i nie znalazlem go w googlach.

 

Chodzi o auto bh po wgraniu bylo wszystko okej po chwili bh stracilo sie tylko zombie co najlepsze bh dzialalo tylko w wodzie .Zostało mi reinstal serwera zrobic i znow wszystko chodzilo do czasu zmiany mapy 2 rundy mineły i znow brak bh u zombie .Jeszcze raz zrobilem i po restarcie servera znow zniklo.

 

Jesli zrobie reinstal servera i dadam stare cvary i inne ustawienia bh jest do czasu .Bh dzialalo nawet przez 5 dni .

 

 

hosting : pukawka.pl

 

Bardzo proszę o pomoc i jakie pliki mam wrzucic .

 

Pozdro : Jeleń


  • +
  • -
  • 0

#2 Drago36

    Profesjonalista - if you know what i mean

  • Power User

Reputacja: 560
Wszechwiedzący

  • Postów:707
  • GG:
  • Imię:Mów mi D.ave
  • Lokalizacja:Polska
Offline

Napisano 29.03.2014 07:08

Wrzuć plugin "nazwapluginu.sma", który odpowiada za BH.
  • +
  • -
  • 0

#3 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 11:19

Wrzuć plugin "nazwapluginu.sma", który odpowiada za BH.

 

Załączone pliki


  • +
  • -
  • 0

#4 Drago36

    Profesjonalista - if you know what i mean

  • Power User

Reputacja: 560
Wszechwiedzący

  • Postów:707
  • GG:
  • Imię:Mów mi D.ave
  • Lokalizacja:Polska
Offline

Napisano 29.03.2014 11:50

Czyli chcesz, aby bh działało wszystkim (nawet zombiakom) i zawsze?


  • +
  • -
  • 0

#5 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 11:52

Tak.


  • +
  • -
  • 0

#6 Drago36

    Profesjonalista - if you know what i mean

  • Power User

Reputacja: 560
Wszechwiedzący

  • Postów:707
  • GG:
  • Imię:Mów mi D.ave
  • Lokalizacja:Polska
Offline

Napisano 29.03.2014 11:59

Wgraj ten plugin i sprawdź.

Załączone pliki


  • +
  • -
  • 0

#7 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 12:12

Zombie dalej nie maja .


  • +
  • -
  • 0

#8 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 15:39

Powie mi ktos przynajmniej gdzie szukac przyczyny ?


  • +
  • -
  • 0

#9 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 29.03.2014 15:46

Nie słuchaj się Drago, bo on jak zwykle nie wie o czym pisze. Proszę bardzo, sprawdź: 

#include <amxmodx>
#include <engine>
#include <biohazard>

#define	FL_WATERJUMP	(1<<11)	// popping out of the water
#define	FL_ONGROUND	(1<<9)	// not moving on the ground

public client_PreThink(id){
	if( !alive_zombie(id) )
		return PLUGIN_HANDLED_MAIN;
	
	entity_set_float(id, EV_FL_fuser2, 0.0)
	
	if (entity_get_int(id, EV_INT_button) & 2) { 
		new flags = entity_get_int(id, EV_INT_flags)
		
		if (flags & FL_WATERJUMP)
			return PLUGIN_CONTINUE
		if ( entity_get_int(id, EV_INT_waterlevel) >= 2 )
			return PLUGIN_CONTINUE
		if ( !(flags & FL_ONGROUND) )
			return PLUGIN_CONTINUE
		
		new Float:velocity[3]
		entity_get_vector(id, EV_VEC_velocity, velocity)
		velocity[2] += 250.0
		entity_set_vector(id, EV_VEC_velocity, velocity)
		
		entity_set_int(id, EV_INT_gaitsequence, 6) 
	}
	return PLUGIN_CONTINUE;
}

stock bool:alive_zombie(index){
	if(is_user_alive(index) && is_user_zombie(index)){
		return true;
	}
	return false; 
}

Jeżeli nadal nie będzie działać, daj plugins.ini lub plugins-bio.ini :)


Użytkownik Aemiksowy edytował ten post 29.03.2014 15:48


#10 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 16:05

Niestety dalej to samo :( Ale czy to mozliwe ze po jakims czasie sie bh wylancza ?

 

 

Załączone pliki


Użytkownik Jelen. edytował ten post 29.03.2014 16:07

  • +
  • -
  • 0

#11 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 29.03.2014 16:08

W plugins-bio.ini dodaj autobh na końcu. Plugin, który dałem w 100% działa, a problem może leżeć w kolejności wczytywania.


Użytkownik Aemiksowy edytował ten post 29.03.2014 16:09


#12 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 16:16

Bład przy kompilacji . Dodam ze mam 2 serwer testowy i tam aktualnie działa bh moze to cos nam pomoze ?


Użytkownik Jelen. edytował ten post 29.03.2014 16:26

  • +
  • -
  • 0

#13 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 29.03.2014 16:25

Spróbuj wyłączyć pluginy, zostawiając sam biohazard i sprawdź co się gryzie.



#14 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 29.03.2014 16:29

A kampilacjie zrobic w tym sma ?

 

 

 

edit

usunolem wszystkie pluginy i co teraz mam robic ?

 

zaintalowalem tylko bh i bio i dalej nic ;/


Użytkownik Jelen. edytował ten post 29.03.2014 16:37

  • +
  • -
  • 0

#15 Drago36

    Profesjonalista - if you know what i mean

  • Power User

Reputacja: 560
Wszechwiedzący

  • Postów:707
  • GG:
  • Imię:Mów mi D.ave
  • Lokalizacja:Polska
Offline

Napisano 30.03.2014 08:21

Aemiksowy skopiował mój plugin co ci podałem, dodał jedynie warunek czy zombie żyje - więc nic nie zrobił. :__:

Chętnie po patrze jak ci kolega pomaga.


  • +
  • -
  • 0

#16 Jelen.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:10
  • Imię:Mateusz
  • Lokalizacja:Mikołów
Offline

Napisano 30.03.2014 12:17

Niech kazdy da cos od siebie , wspolnie dojdziemy do problemu wiec d.ave smiało mazesz pisac :)


  • +
  • -
  • 0

#17 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 30.03.2014 13:21

Aemiksowy skopiował mój plugin co ci podałem, dodał jedynie warunek czy zombie żyje - więc nic nie zrobił. :__:

Chętnie po patrze jak ci kolega pomaga.

 

Przestań bredzić głupoty. Jaki Twój plugin? Ty nawet człowieku nie dodałeś warunku sprawdzającego czy zombie ma posiadać autobh... Kompletnie się nie znasz, a wciskasz swoje 3 grosze i próbujesz jeszcze innym wmówić, że oni nic nie robią. 

 

Kod wziąłem od swojego autobh, być może w pewnych momentach się niczym nie różni od podanego przez Drago36.

 

@Jelen.

Skontaktuj się ze mną na PW.



#18 Drago36

    Profesjonalista - if you know what i mean

  • Power User

Reputacja: 560
Wszechwiedzący

  • Postów:707
  • GG:
  • Imię:Mów mi D.ave
  • Lokalizacja:Polska
Offline

Napisano 30.03.2014 13:32

Nie w tym sensie, że to mój plugin, tylko że ja go tu wrzuciłem.

Haha a gdzie ty niby dodałeś warunek sprawdzający czy zombie ma posiadać autobh?

Nikomu nie wmawiam, że nic nie robią.. z tym to już przesadziłeś.

Tak, tak. Perwidnie skopiowałeś odemnie dodając warunek czy zombie ŻYJE. Nawet nie wiesz co dodajesz. A to jest ten niby warunek co sprawdza czy zombie ma autobh? Nieźle..
A teraz kto tu się nie zna.
  • +
  • -
  • 0

#19 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 30.03.2014 17:40   Najlepsza odpowiedź

Czy Ty jesteś jakiś pomylony? 

 

  1. stock bool:alive_zombie(index){
  2. if(is_user_alive(index) && is_user_zombie(index)){
  3. return true;
  4. }
  5. return false;
  6. }

masz tu ewidentnie funkcję sprawdzającą... Potem w prethinku:

  1. if( !alive_zombie(id) )
  2. return PLUGIN_HANDLED_MAIN;

 

U Ciebie niczego nie ma o tym. Więc czego mnie minusujesz? Jak tylko zdobędę power usera, to się odwdzięczę. 

 

Właśnie się znam i to bardzo dobrze na biohazard w przeciwieństwie do Ciebie. Jak widać, w sygnaturze masz serwer i stawiam, że jest on Twój. Jeżeli tak, to gratuluję Ci w kwestii rozwoju... - właśnie widać Twoje umiejętności konfiguracji.

 

Tu jest Twój plugin, który mu dałeś: http://wklej.org/id/1317121/ - gdzie Ty masz bibliotekę biohazard???

 

Pozdrawiam


Użytkownik Aemiksowy edytował ten post 30.03.2014 17:44






Również z jednym lub większą ilością słów kluczowych: zombie mod, auto bh biohazard

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych