Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
AMXBans 6.x

Brak możliwości banowania

amxbans 6.x

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
11 odpowiedzi w tym temacie

#1 Guxinimod

    Pomocny

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 16.03.2014 17:42

Wgrałem dzisiaj amxbans. Wszystko zrobione chyba dobrze, dodałem pliki na stronę www (oczywiście zainstalowałem amxbansa), zmieniłem dane w sql.cfg na odpowiednie itd... Dopisałem wszystko do plugins.ini i wstawiłem srednik przed admin.amxx

Wszystko działa, serwer jest podpięty bo pokazuje mi ilu graczy itd w zakładce serwer tylko nie mogę banować... wchodzę w amxmodmenu i wybieram zbanuj gracza. I co? Pojawiają się szare nicki. To samo pod komendą amx_banmenu.
Gdy zrobiłem ssy komendą amx_ssbanmenu to nie zbanowało gracza tylko zrobiło ssy, a z tego co kojarzę na ostatnim serwerze na którym administrowałem banowało od razu z automatycznym powodem "Wstaw SS na xxx". Gdy wszedłem do menu bana to w nawiasie obok osoby której zrobiłem ss'y pisze banning.

Jak to naprawić?
Załączyć jakieś pliki?

#2 Fire Blader

    Początkujący

  • Użytkownik

Reputacja: 6
Nowy

  • Postów:19
  • GG:
  • Steam:steam
  • Lokalizacja:Internet
Offline

Napisano 16.03.2014 17:49

Podaj Logi serwera.

 

//Edit: Wpisałeś HOSTA w menadżerze zdalnego połączenia MySQL?


Użytkownik Fire Blader edytował ten post 16.03.2014 17:54

  • +
  • -
  • 0

#3 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 16.03.2014 21:31

Tak. Dodałem IP serwera bez portu.

Chodzi o logi z cstrike-->logs?

I czemu taki błąd wyskakuje na forum? - http://cstornado.xaa.pl/
A amxbans normalnie działa - http://cstornado.xaa...ny/ban_list.php

Użytkownik Guxinimod edytował ten post 16.03.2014 21:57


#4 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 18.03.2014 15:06

Może amxbans ma być zrobiony na nowej bazie MySQL?
Bo mam możliwość zrobienia jeszcze jednej.

#5 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 20.03.2014 20:50

Podbijam. Nikt nie wie o co chodzi?

#6 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 22.03.2014 20:53

F5

#7 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 26.03.2014 15:35

Wgrywałem od nowa amxbans. Nie czyta adminów ze strony www.

Co to za error? sql.cfg odpowiednio uzupełniłem.

 

[AMXBans] SQL error: can't connect: 'Access denied for user 'cstornad_userban'@'178.19.106.66' (using password: YES)


#8 master522

    Wszechwidzący

  • Użytkownik

Reputacja: 100
Zaawansowany

  • Postów:237
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Mikołów
Offline

Napisano 26.03.2014 16:03

Dodaj to ip
178.19.106.66
Dla cPanel -> menedżera zdalnego połączenie MySQL
Dla DirectAdmin -> Kliknij uzywana baze danych i nizej dodaj do zezwoleń
  • +
  • -
  • 0

#9 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 26.03.2014 16:18

Dodaj to ip

178.19.106.66
Dla cPanel -> menedżera zdalnego połączenie MySQL
Dla DirectAdmin -> Kliknij uzywana baze danych i nizej dodaj do zezwoleń

Dodałem już wcześniej przez Cpanel i do zdalnego połączenia wkleiłem IP

#10 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 26.03.2014 20:41

W modules.ini odblokowałem mysql a zablokowane jest ;sqlite
W plugins.ini wszystko dopisane, jest średnik przed admin.amxx

No nie wiem co jeszcze robić?

#11 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 28.03.2014 06:48

Jest jakiś błąd łączenia serwera z bazą. Zacznę od tego, że serwer dodawałem ręcznie, bo sam się nie dodał. Nie czyta adminów, a gdy włączę czytanie adminów z users.ini to wszystko pięknie działa tylko nie banuje... :P Szare nicki są w menu bana, pewnie dlatego, że serwer nie łączy się z bansem. Sql.cfg uzupełnione, adres IP dodany do menadżera zdalnego połączenia bazy MySql... amxbans.cfg odpowiednio skonfigurowałem. A jakie moduły w modules.ini zablokować? Mysql czy sqlita ? Bo nie wiem czy dobrze zrobiłem.

Piszcie co mogłem zrobić źle.

Tak wygląda plik sql.cfg u mnie:

amx_sql_host	"cstornado.xaa.pl"
amx_sql_user	"user"
amx_sql_pass	"hasło"
amx_sql_db		"baza"
amx_sql_table	"admins"
amx_sql_type	"mysql"

Użytkownik Guxinimod edytował ten post 28.03.2014 07:00


#12 Guxinimod

    Pomocny

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:53
  • Imię:Paweł
  • Lokalizacja:Polska :)
Offline

Napisano 28.03.2014 21:41

sql.cfg mam dobrze?





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych