Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

RPG Mod


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 Adrenaline

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:109
  • Lokalizacja:Fox ;-)
Offline

Napisano 01.08.2009 07:46

Witam !

Mój problem dotyczy tego samego co w poprzednim temacie, kompilacji tak występuje mianowicie taki problem podczas kompilowania w amx studio

Nazwa Pluginu : RPGx Beta 1.1
Plugin:http://forums.alliedmods.net/showthread.php?t=95350
Download:http://forums.alliedmods.net/showthread.php?t=95350
Znajduje się tam 5 linków, te pliki sma znajdują się w RPGx BETA 1.1.zip

Error: Cannot read from file: "rpgx" on line 3
Compilation aborted.
Could not locate output file C:UsersdfdfDesktopRPGx BETA 1.1addons/amxmodx/scriptingrpgx_upgrade_bouncybullets.amx (compile failed).

To ta linijka:#include <rpgx>


Prosiłbym o pomoc w rozwiązaniu problemu z kompilacją : )
Liczę na pomoc R3X


To jeden z plików SMA

#include <amxmodx>
#include <fakemeta_util>
#include <rpgx>

new upgrade_id;

public plugin_init()
register_plugin("BouncyBullets RPGx Upgrade", "1.1", "roflmao456");

public RPGx_OnPluginReady(){
upgrade_id = RPGx_MakeUpgrade("BouncyBullets", 5, 15, 20);
}

public RPGx_OnPlayerHurt(victim, attacker, damage){
new level = RPGx_GetUpgradeLevel(attacker, upgrade_id);
if(level){
static Float:velocity[3];
fm_get_user_velocity(victim, velocity);
velocity[0] *= float(level * 125);
velocity[1] *= float(level * 125);
velocity[2] *= float(level * 125);
RPGx_SetVelocity(victim, velocity);
}
}


Plik rpgx.inc znajduje się w linku download
  • +
  • -
  • 0

#2 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 01.08.2009 09:59

To samo co poprzednio - rpgx.inc skopiuj do amxmodx/scripting/include/

Pliki dołączane przez <> np.
#include <amxmodx>

są wyszukiwane przez kompilator pod adresem

include/

sam kompilator masz w amxmodx/scripting/, plik rpgx.inc musi znaleźć się właśnie w tym include poniżej kompilatora.

Pliki dołączane przez ""
#include "moj_plik.inl"
są wyszukiwane w folderze, w którym umiejscowiony jest kompilowany plik .sma.
  • +
  • -
  • 0

#3 Adrenaline

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:109
  • Lokalizacja:Fox ;-)
Offline

Napisano 01.08.2009 10:18

Tyle , że ja mam ten plik tam .. , i nadal to samo :mur:

@ Sory

Jednak nie, coś zrobiłem i nagle zaczęło iść ^^ , narazię jest ok

Daje pomógł ^D^
  • +
  • -
  • 0

#4 R3X

    Godlike

  • Przyjaciel

Reputacja: 2960
Godlike

  • Postów:4247
  • Lokalizacja:Nie
Offline

Napisano 01.08.2009 10:35

Jak chcesz nowe rozszerzenie to pisz :D widzę, że fajnie daje się to modyfikować, musisz tylko opisać jak ma działać nowa moc
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych