Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Klasa

[ROZWIĄZANE] Nie działa 1/1 z HE w klasie

klasa

Najlepsza odpowiedź Aemiksowy , 10.03.2014 12:44

To jest odpowiedzialne za to: get_user_weapon(idattacker) == CSW_HEGRENADE.

 

Jeszcze ten bezsensowny warunek:

random_num(1, 1) == 1 - toż to śmierć dla serwera... Zawsze zwróci wartość 1, więc po cholerę to???

 

W ogóle ten kod mi się nie podoba. Tu masz lepiej to napisane:

public TakeDamage(this, idinflictor, idattacker, Float:damage, damagebits){
	if(!is_user_connected(idattacker))
		return HAM_IGNORED;
	
	if(!ma_klase[idattacker])
		return HAM_IGNORED;
	
	if(get_user_team(this) == get_user_team(idattacker) && damagebits & DMG_HEGRENADE)
		cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
	
	if(get_user_weapon(idattacker) == CSW_GALIL && damagebits & DMG_BULLET)
		cod_inflict_damage(idattacker, this, 5.0, 0.5, idinflictor, damagebits);
	
	return HAM_IGNORED;
}
Przejdź do postu


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 shajba.

    Zaawansowany

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:130
  • Lokalizacja:Małopolska
Offline

Napisano 09.03.2014 22:29

Witam

 

Nie działa mi w klasie 1/1 z HE. Jakby mógł ktoś zerknąć na sma co mam tam źle to byłbym wdzięczny.

 

Dzięki

Załączone pliki


  • +
  • -
  • 0

#2 Aemiksowy

    Banned

  • Zbanowany

Reputacja: 34
Życzliwy

  • Postów:222
  • Lokalizacja::)
Offline

Napisano 10.03.2014 12:44   Najlepsza odpowiedź

To jest odpowiedzialne za to: get_user_weapon(idattacker) == CSW_HEGRENADE.

 

Jeszcze ten bezsensowny warunek:

random_num(1, 1) == 1 - toż to śmierć dla serwera... Zawsze zwróci wartość 1, więc po cholerę to???

 

W ogóle ten kod mi się nie podoba. Tu masz lepiej to napisane:

public TakeDamage(this, idinflictor, idattacker, Float:damage, damagebits){
	if(!is_user_connected(idattacker))
		return HAM_IGNORED;
	
	if(!ma_klase[idattacker])
		return HAM_IGNORED;
	
	if(get_user_team(this) == get_user_team(idattacker) && damagebits & DMG_HEGRENADE)
		cod_inflict_damage(idattacker, this, float(get_user_health(this))-damage+1.0, 0.0, idinflictor, damagebits);
	
	if(get_user_weapon(idattacker) == CSW_GALIL && damagebits & DMG_BULLET)
		cod_inflict_damage(idattacker, this, 5.0, 0.5, idinflictor, damagebits);
	
	return HAM_IGNORED;
}

Użytkownik Aemiksowy edytował ten post 10.03.2014 12:47


#3 shajba.

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:130
  • Lokalizacja:Małopolska
Offline

Napisano 14.03.2014 15:05

Działa, dzięki wielkie!


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: klasa

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych