Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
- - - - -

Alternative End Round Sounds


  • Zamknięty Temat jest zamknięty
183 odpowiedzi w tym temacie

#101 zEnDeR

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:21
Offline

Napisano 23.10.2008 19:43

Jest jeszcze 1 problem, HLDS cos tam szwankuje ze update i restart HLDSa wiesz o co moze chodzic? Wszystko dziala ale w trakcie grania na HLDs wyskakuje tego cos i mam do wybory OK Cancel i w ogóle nie wiem o co chodzi?

Sorry za offtopic :/ ale nie wiem co jest !
  • +
  • -
  • 0

#102 kemez

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:36
Offline

Napisano 25.10.2008 23:10

pisze tutaj poniewaz poprzedni temat zostal zamkniety
zrobilem fast download z ftp na yoyo.pl

postanowilem rowniez uzyc tego pluginu http://amxx.pl/viewtopic.php?t=187, opis mowi o zmianach w roundsound.ini jest tam rowniez plik *.sma ktory mowi o zawartosci pliku *.amxx
jak powinien wygladac moj roundsound.ini i roundsound.sma (do kompilacji) jezeli moj sound folder wyglada tak :

http://img530.images...beztytuucb1.jpg


tak wyglada roundsound.sma
Cytat:

#include <amxmodx>

public plugin_init()
{
register_plugin("RoundSound","1.0","PaintLancer")
register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
new rand = random_num(0,9)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/conniew")
case 1: client_cmd(0,"spk misc/placestogo")
case 2: client_cmd(0,"spk misc/fastfood")
}

return PLUGIN_HANDLED
}

public ct_win()
{
new rand = random_num(0,10)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/ayo")
case 1: client_cmd(0,"spk misc/rocky1")
case 2: client_cmd(0,"spk misc/kpows")
}

return PLUGIN_HANDLED
}

public plugin_precache()
{
precache_sound("misc/ayo.mp3")
precache_sound("misc/rocky1.mp3")
precache_sound("misc/kpows.mp3")
precache_sound("misc/conniew.mp3")
precache_sound("misc/placestogo.mp3")
precache_sound("misc/fastfood.mp3")

return PLUGIN_CONTINUE
} 

[ Dodano: 26-10-2008, 00:27 ]
a no i jeszcze nie wiem gdzie wrzucic ten pliczek roundsound.ini

//Jeśli dajesz kod jakiegoś pluginu, to daj go pomiędzy znacznikami code. Łatwiej się czyta.
//wizu
  • +
  • -
  • 0

#103 MafiaDL

    Naj-Najstarszy Moderator

  • Przyjaciel

Reputacja: 554
Wszechwiedzący

  • Postów:3492
  • GG:
  • Imię:Łukasz
  • Lokalizacja:Warsaw
Offline

Napisano 26.10.2008 04:27

a no i jeszcze nie wiem gdzie wrzucic ten pliczek roundsound.ini


amxmodx/configs/TU

p.s nie pisz juz tu bo zrobiles temat
  • +
  • -
  • 0

#104 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 27.10.2008 17:18

Jest jeszcze 1 problem, HLDS cos tam szwankuje ze update i restart HLDSa wiesz o co moze chodzic? Wszystko dziala ale w trakcie grania na HLDs wyskakuje tego cos i mam do wybory OK Cancel i w ogóle nie wiem o co chodzi?

Sorry za offtopic :/ ale nie wiem co jest !

Mam to samo, proszę o pomoc...
  • +
  • -
  • 0

#105 BartekMAJSTEr =D

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:35
  • GG:
  • Lokalizacja:Rypin
Offline

Napisano 06.11.2008 16:45

też mi nie działa :/ Szkoda :/
  • +
  • -
  • 0

#106 zer0.

    Godlike

  • Przyjaciel

Reputacja: 428
Wszechobecny

  • Postów:2116
  • Steam:steam
  • Lokalizacja:Kw
Offline

Napisano 06.11.2008 18:32

też mi nie działa :/ Szkoda :/

Prosta zasada. Nie działa Ci plugin, wgraj inną wersje. Zobacz czy ten plugin zadziała:

http://forums.allied... ... 1097767191

Takiemu jednemu też nie działało, ale jak wgrał to co jest wyżej to działało :)


  • +
  • -
  • 0

#107 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 06.11.2008 18:37

Jak nie działa to ścieżka musi być koniecznie /sound/misc/ np.: /sound/misc/Muza/
  • +
  • -
  • 0

#108 Ska7pel

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:2
Offline

Napisano 09.11.2008 16:37

Zrobiłem wsio, na servie pokazuja sie napisy, reaguje na komende /roundsound, ale dzwięki si enie sciagaja czemu ?
  • +
  • -
  • 0

#109 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 09.11.2008 17:08

Zrobiłem wsio, na servie pokazuja sie napisy, reaguje na komende /roundsound, ale dzwięki si enie sciagaja czemu ?

daj mi paczkę muzyczek to ci zrobię.
  • +
  • -
  • 0

#110 Ska7pel

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:2
Offline

Napisano 09.11.2008 17:13

KLIK
Proszę
  • +
  • -
  • 0

#111 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 09.11.2008 17:45

http://uploader.pl/?d=10D6A0AB1
Muzyczki wrzuć do sound/misc/
roundsound wrzuć do folderu configs
Nie zapomnij dopisać do addons/amxx.cfg :
erc_random_precache "3"
Spradzałem u sibie na HLDS i działa opisz szybko, będę czekał.
  • +
  • -
  • 0

#112 Nikke94

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:32
Offline

Napisano 09.11.2008 17:55

Mi działa wszystko ale nie wyświetla się komunikat jeśli chcesz wyłączyć muzykę na koniec rundy wpisz /roundsound czemu??
  • +
  • -
  • 0

#113 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 09.11.2008 17:56

Mi działa wszystko ale nie wyświetla się komunikat jeśli chcesz wyłączyć muzykę na koniec rundy wpisz /roundsound czemu??

Dodaj do amxx.cfg
ers_enabled 1
ers_player_toggle 1
erc_time_ads 300 - tutaj twój czas, co ile ma się wyświetlać ten komunikat
erc_random_precache "3"
  • +
  • -
  • 0

#114 BartekMAJSTEr =D

    Życzliwy

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:35
  • GG:
  • Lokalizacja:Rypin
Offline

Napisano 09.11.2008 17:57

To taka rzecz w pluginie, że gracz jak niechce słuchać może sobie wyłączyć muzyke:)
  • +
  • -
  • 0

#115 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 09.11.2008 18:07

To taka rzecz w pluginie, że gracz jak niechce słuchać może sobie wyłączyć muzyke:)

Wiemy...
  • +
  • -
  • 0

#116 Nikke94

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:32
Offline

Napisano 09.11.2008 19:26

Dzięki już działa
  • +
  • -
  • 0

#117 Klycior

    Wszechpomocny

  • Użytkownik

Reputacja: 43
Pomocny

  • Postów:370
  • GG:
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 09.11.2008 23:06

Zrobiłem wsio, na servie pokazuja sie napisy, reaguje na komende /roundsound, ale dzwięki si enie sciagaja czemu ?


Mam ten sam problem.

0 błędów w logach wykyrwa wszystkie piosenki.

Cvary dałem.

Mój serwer.cfg
[code=auto:0]
sv_lan 1 // Domy
  • +
  • -
  • 0

#118 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 10.11.2008 15:49

[quote name="Klycior"][quote name="Ska7pel"]Zrobiłem wsio, na servie pokazuja sie napisy, reaguje na komende /roundsound, ale dzwięki si enie sciagaja czemu ?[/quote]

Mam ten sam problem.

0 błędów w logach wykyrwa wszystkie piosenki.

Cvary dałem.

Mój serwer.cfg
[code=auto:0]
sv_lan 1 // Domy
  • +
  • -
  • 0

#119 Klycior

    Wszechpomocny

  • Użytkownik

Reputacja: 43
Pomocny

  • Postów:370
  • GG:
  • Lokalizacja:Tarnowskie Góry
Offline

Napisano 10.11.2008 21:33

Pomyłka co do cvaru miałem zrobić osobne code :)

Cvary dodałem do amxx.cfg

Muzyczkę dodałem.

pawlik,najpierw naucz się czytać !

Piszesz "po1 daj muzyczki" a nie zauważyłeś tego w moim poście ? wykyrwa wszystkie piosenki.
  • +
  • -
  • 0

#120 pawlik

    Wszechwiedzący

  • Użytkownik

Reputacja: 86
Zaawansowany

  • Postów:579
  • Steam:steam
  • Lokalizacja:Podkarpacie
Offline

Napisano 11.11.2008 10:32

pawlik,najpierw naucz się czytać !
Piszesz "po1 daj muzyczki" a nie zauważyłeś tego w moim poście ? wykyrwa wszystkie piosenki.

Jeżeli wykrywa, to przenieś muzyczki do swojego folderu na kompie [np. sound/misc/], uruchom cs'a i w konsoli wpisz
mp3 play sound/misc/ tu_twoja_nazwa_mp3 - to dla utworów .mp3
np
mp3 play sound/misc/ctwinnar
spk misc/ tu_twoja_nazwa_wav - to dla utworów .wav
np
spk misc/ctwinnar - to dla utworów .wav
Jeżeli się odtworzą, tzn, że muzyczkki są w porządku i błąd popełniłeś gdze indziej, a jeżeli nie, to podaj link do twoich utworków, to spróbuję pomóc ;) .
PS. Spróbuj wszystkie.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych