Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z modulamifailed to load: Module/Library


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
17 odpowiedzi w tym temacie

#1 sq69i

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 07.02.2014 23:21

Witam, chciałem odpalić u siebie na serwerze takie pluginy jak:

 

statsx.amxx ; stats on death or round end (CSX Module required!)
miscstats.amxx ; bunch of events announcement for Counter-Strike
stats_logging.amxx ; weapons stats logging (CSX Module required!)

 

pod psychostats

 
usunełem średniki z wyżej wymienionych, włączyłem następujące moduły:
mysql
;sqlite
fun
;engine
fakemeta
;geoip
;sockets
;regex
;nvault
cstrike
csx
;hamsandwich

 

 

a efekt jest taki

L 02/07/2014 - 23:12:07: [GEOIP] Database info: GEO-106FREE 20080801 Build 1 Copyright © 2007 MaxMind LLC All Rights Reserved
L 02/07/2014 - 23:12:07: [AMXX] Plugin "statsx.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.
L 02/07/2014 - 23:12:07: [AMXX] Plugin "miscstats.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.
L 02/07/2014 - 23:12:07: [AMXX] Plugin "stats_logging.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.

 

 

próbowałem nadpisać pliki amxx pobranymi z amxmodx.org niestety dalej to samo, już sam nie wiem co robić...

rozwiązania szukam już od dłuższego czasu.

Ma ktoś jakieś pomysły?


  • +
  • -
  • 0

#2 TheMarkerxD

    Profesjonalista

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:184
  • Imię:Mateusz
  • Lokalizacja:None
Offline

Napisano 07.02.2014 23:27

odblokowuj pojedyńczo modóly i odpal server :)

metoda prób i błendów zawsze dobra :)


Użytkownik TheMarkerxD edytował ten post 07.02.2014 23:27

  • +
  • -
  • 0

#3 sNH.

    Czy MisieQ ukradł ciasteczko?

  • Power User

Reputacja: 297
Wszechwidzący

  • Postów:1070
  • Steam:steam
  • Imię:Bartek
  • Lokalizacja:Ełk
Offline

Napisano 07.02.2014 23:27

Usuń wszystkie średniki i sprawdź.


  • +
  • -
  • 0

#4 TheMarkerxD

    Profesjonalista

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:184
  • Imię:Mateusz
  • Lokalizacja:None
Offline

Napisano 07.02.2014 23:29

Usuń wszystkie średniki i sprawdź.

 

ja preferuje pojedyńczo po co ma mieć modóly all właczone bezsens :)


  • +
  • -
  • 0

#5 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 08.02.2014 09:09

nawet po włączeniu wszystkich modułów efekt jest taki sam

L 02/08/2014 - 09:05:54: -------- Mapchange to crossfire --------
L 02/08/2014 - 09:05:54: [AMXX] Plugin "statsx.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.
L 02/08/2014 - 09:05:54: [AMXX] Plugin "miscstats.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.
L 02/08/2014 - 09:05:54: [AMXX] Plugin "stats_logging.amxx" failed to load: Module/Library Class "xstats" required for plugin.  Check modules.ini.

 

 

btw. z tymi modułami zrobiłem dobrze?

pobrałem pliki z http://www.amxmodx.org/downloads.php 

AMX Mod X Base

wersje pod linux (bo takowy używam) następnie usunęłem te z serwera i wgrałem na nowo folder modules

 

 

 


  • +
  • -
  • 0

#6 1337

    Wszechpomocny

  • Zbanowany

Reputacja: 26
Życzliwy

  • Postów:310
  • GG:
  • Imię:Adrian
  • Lokalizacja:Bystrzyca Kłodzka
Offline

Napisano 08.02.2014 09:18

Spróbuj serwer odpalić z tymi

KLIKNIJ

 

Ps. nie dałem w załączniku bo wyskakuje błąd (413 Request Entity Too Large)


Użytkownik opalejro edytował ten post 08.02.2014 09:18

Nie pomagam na GG/PW ew. odpłatnie. (Pamiętaj że za 20zł nie otwieram nawet notatnika)

Spam o pomoc przy serwerze/pluginach/skryptach równoznaczne jest z automatycznym dodaniem Cię do listy osób ignorowanych.

 

Ps. DarkGL idę po Ciebie.


#7 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 08.02.2014 10:12

no niestety bez zmian :( cały czas te same logi...


  • +
  • -
  • 0

#8 Sosna

    Życzliwy

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:33
  • Imię:Piotr
  • Lokalizacja:Sokołów Podlaski
Offline

Napisano 08.02.2014 19:58

A masz odpowiednie* pliki w cstrike/addons/amxmodx/modules ?



*odpowiednie - dla fakemeta np. fakemeta_amxx_i386.so itd 


  • +
  • -
  • 1

b_350_20_692108_381007_FFFFFF_000000.png

 

CoD 4K Zapraszam!


#9 1337

    Wszechpomocny

  • Zbanowany

Reputacja: 26
Życzliwy

  • Postów:310
  • GG:
  • Imię:Adrian
  • Lokalizacja:Bystrzyca Kłodzka
Offline

Napisano 08.02.2014 20:59

Niemożliwe, skoro wgrałeś paczkę która CI dałem masz zle ustawiony plik modules.ini

Odnosząc się do twojej odpowiedzi wyżej usunełeś moduły z pliku zamiast samych średników, tak bynajmniej to zrozumiałem.

cstrike>addons>amxmodx>configs>modules.ini

 

Powinien wyglądać mniej więcej tak( sprawdz czy na nim także wywali)

mysql
sqlite
fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
hamsandwich
//orpheu
noroundend

Jeżeli nie zadziała w co wątpie, masz wadliwe pluginy.


Użytkownik opalejro edytował ten post 08.02.2014 21:02

Nie pomagam na GG/PW ew. odpłatnie. (Pamiętaj że za 20zł nie otwieram nawet notatnika)

Spam o pomoc przy serwerze/pluginach/skryptach równoznaczne jest z automatycznym dodaniem Cię do listy osób ignorowanych.

 

Ps. DarkGL idę po Ciebie.


#10 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 08.02.2014 21:58

modules.ini dałem tak

mysql
sqlite
fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
hamsandwich

 

 

pliki jakie mam w folderze modules wszystkie wyżej wymienione z końcówkami _amxx_i386.so

właśnie sam nie mam pojęcia dlaczego to nie działa... szukałem już na różnych forum i zazwyczaj reinstall plików pomaga, niestety u mnie nie ma żadnej reakcji (dodam że chodzi o grę half-life 1)

 

Oczywiście po wszystkim był restart serwera. Logi te same :/


  • +
  • -
  • 0

#11 IceBaRa

    Zaawansowany

  • Zbanowany

Reputacja: 13
Początkujący

  • Postów:113
  • Lokalizacja:Gdańsk
Offline

Napisano 08.02.2014 22:53

Wgraj moduł xstats -.-

Module/Library Class "xstats" required for plugin

Wpisz w google xstats i bedziesz mial dowload i juz :)


ZAPRASZAM NA MOJE SERWERY:

b_350_20_FFAD41_E98100_000000_591F11.png

b_350_20_FFAD41_E98100_000000_591F11.png


#12 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 09.02.2014 07:51

skoro to takie proste to proszę o link

Wgraj moduł xstats -.-

Module/Library Class "xstats" required for plugin

Wpisz w google xstats i bedziesz mial dowload i juz :)

 


  • +
  • -
  • 0

#13 TibacK

    Diler pod gimnazjum dla niepełnosprawnych dzieci

  • Power User

Reputacja: 466
Wszechobecny

  • Postów:2448
Offline

Napisano 09.02.2014 09:07

pobierz couner strike addon pod linux (na amxx.pl jest) i wgraj pliki .so do modules
  • +
  • -
  • 0

Sprzedam Paczkę CoD pod CS 1.6 (JEST WIELE WERSJI DO WYBORU TEJ PACZKI) na lvl od 201 - 601

Silnik (8 nowych statystyk, poprawiony zapis, dodatkowy exp, pozbyto się CurWeapon). Ponad 100 perków (do wyboru do koloru). Sklep, NOWE MISJE (QUESTY), premium i super premium, AUKCJE, KLANY, zapis nVault, 4 zestawy modeli bronii do wyboru!

JESTEŚ ZAINTERESOWANY KUPNEM? NAPISZ WIADOMOŚĆ DO MNIE!


#14 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 09.02.2014 09:20

jak na amxx.pl/pobierz to strona nie działa, zresztą wątpię aby to pomogło skoro z oficjalnej strony pobrane pliki nie działały to te raczej też nie zatrybią.


  • +
  • -
  • 0

#15 TibacK

    Diler pod gimnazjum dla niepełnosprawnych dzieci

  • Power User

Reputacja: 466
Wszechobecny

  • Postów:2448
Offline

Napisano 09.02.2014 09:26

pobierz z amxmodx.org

tylko pod swoja wersje amx'a
  • +
  • -
  • 0

Sprzedam Paczkę CoD pod CS 1.6 (JEST WIELE WERSJI DO WYBORU TEJ PACZKI) na lvl od 201 - 601

Silnik (8 nowych statystyk, poprawiony zapis, dodatkowy exp, pozbyto się CurWeapon). Ponad 100 perków (do wyboru do koloru). Sklep, NOWE MISJE (QUESTY), premium i super premium, AUKCJE, KLANY, zapis nVault, 4 zestawy modeli bronii do wyboru!

JESTEŚ ZAINTERESOWANY KUPNEM? NAPISZ WIADOMOŚĆ DO MNIE!


#16 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 09.02.2014 09:50

Pisałem post wyżej, że pobierałem już pliki z tej strony

moja wersja to AMXMODX v1.8.2 (tak wskazuje HLSW)

pobrałem AMX Mod X Base w wersji v1.8.2 Linux nadpisałem pliki z serwera i problem nie znika

 

Próbowałem po raz kolejny

usunełem cały folder amxmodx i wgrałem wszystkie pliki na nowo

następnie pobrałem Mod Addon Packs - Counter-Strike Addon w wersji pod 1.8.2 Linux z skopiowałem pliki z folderu plugins bo w tym pierwszym ich brakowało


Użytkownik sq69i edytował ten post 09.02.2014 10:11

  • +
  • -
  • 0

#17 TibacK

    Diler pod gimnazjum dla niepełnosprawnych dzieci

  • Power User

Reputacja: 466
Wszechobecny

  • Postów:2448
Offline

Napisano 09.02.2014 10:08

to pobierz jeszcze counter strike addon pod 1.8.2 i wgraj. Tam jest modul csx!!!
  • +
  • -
  • 0

Sprzedam Paczkę CoD pod CS 1.6 (JEST WIELE WERSJI DO WYBORU TEJ PACZKI) na lvl od 201 - 601

Silnik (8 nowych statystyk, poprawiony zapis, dodatkowy exp, pozbyto się CurWeapon). Ponad 100 perków (do wyboru do koloru). Sklep, NOWE MISJE (QUESTY), premium i super premium, AUKCJE, KLANY, zapis nVault, 4 zestawy modeli bronii do wyboru!

JESTEŚ ZAINTERESOWANY KUPNEM? NAPISZ WIADOMOŚĆ DO MNIE!


#18 sq69i

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Polska
Offline

Napisano 09.02.2014 10:20

moduł csx miałem cały czas i nawet aktualizacja paczki z counter strike addon nie pomaga... 

poddaje się... próbowałem już chyba wszystkiego i nic nie pomaga :(


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych