Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z przekierowaniem !


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Davidek

    Początkujący

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:15
  • Lokalizacja:Siedlce
Offline

Napisano 21.07.2009 17:58

Siemka jest taki jeden problem . Ściągnąłem sobie plugin który przekierowuje na inny serwer jest to plugin Knopersa&Emblaze. Gdy wrzucę sobie plugin na mój lan serwer to plugin działa , ale gdy wrzucę na serwer dedykowany z ftp wiecie o co chodzi to mi ten plugin nie wchodzi !! wyskakuje błąd w konsoli
Server tried to send invalid command:" connect 77.79.241.200:27099"

Daje .sma
/* By emblaze and Knopers. */

#include <amxmodx> 
#include <amxmisc> 

#define PLUGIN "Przekierowanie" 
#define VERSION "1.5" 
#define AUTHOR "emblaze & Knopers" 


public plugin_init() { 
    register_plugin(PLUGIN, VERSION, AUTHOR) 
    register_clcmd("say /serwer","Serwer")
} 

public Serwer(id) { 
	
	new menu = menu_create("Na jaki serwer mam cię przeniesc ?", "menu_handler") 
	menu_additem(menu, "Live4Game [FFA]", "1", 0) 
	menu_additem(menu, "Live4Game [Aim/Avp]", "2", 0) 
	menu_additem(menu, "Live4Game [BF2]", "3", 0) 
	menu_additem(menu, "Live4Game [War3FT]", "4", 0) 
	menu_setprop(menu, MPROP_EXIT, MEXIT_ALL) 
	menu_display(id, menu, 0) 
} 

public menu_handler(id, menu, item) { 
	if (item == MENU_EXIT) { 
		menu_destroy(menu)
		return PLUGIN_HANDLED 
	} 
	new data[1], iName[64] 
	new access, callback 
	menu_item_getinfo(menu, item, access, data,1, iName, 63, callback) 
	new key = str_to_num(data) 
	switch(key){
		case 1:{
			client_cmd(id, " connect 77.79.241.200:27099") 
			menu_destroy(menu)
		}
		case 2:{ 
			client_cmd(id, " connect 94.40.59.21:27075") 
			menu_destroy(menu)
		} 
		case 3:{ 
			client_cmd(id, " password ode")
			client_cmd(id, " connect 91.203.134.159:27086") 
			menu_destroy(menu)
		} 
		case 4:{
			client_cmd(id, " password ode")
			client_cmd(id, " connect 193.143.121.253:27090") 
			menu_destroy(menu)
		} 
	}  
	return PLUGIN_HANDLED 
} 
Proszę o pomoc będzie pomógł ;>.
  • +
  • -
  • 0

#2 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 21.07.2009 18:02

client_cmd(id, " connect 91.203.134.159:27086")

Popraw na
client_cmd(id, " Connect 91.203.134.159:27086")
Duże c musi być ;)

#3 Davidek

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:15
  • Lokalizacja:Siedlce
Offline

Napisano 21.07.2009 18:18

Kur3k podziękował Ci !! :> leci pomógł DZIAŁA!
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych