Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z przenoszeniem bazy na inny hosting


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 bartu233

    Zaawansowany

  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:87
  • Lokalizacja:Słupsk
Offline

Napisano 20.07.2009 17:03

Mam problem przy przenoszeniu bazy poprzez phpMyAdmina. Wyrzuca różne błędy przy importowaniu bazy. Moze mi ktoś powiedziec co mam zaznaczyć zeby pomyślnie przenieść baze ??
  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 20.07.2009 17:14

a może ktoś powiedzieć w jaki sposób baza została wyeksportowana jakie błędy wyrzuca ? ;>
  • +
  • -
  • 0

#3 bartu233

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:87
  • Lokalizacja:Słupsk
Offline

Napisano 21.07.2009 00:05

Eksport bazy zrobilem tak jak z baza od forum (phpbb by przemo)

http://img223.images...90/31038921.jpg

Import wykonuje używając znaków "binary" i tryb zgodności "MYSQL40" i wyrzuca:

Błąd
Istnieje szansa, że właśnie znaleziono błąd w analizatorze składni SQL. Proszę zbadać bliżej swoje zapytanie i sprawdzić, czy cudzysłowy są poprawne i dobrze sparowane. Inną możliwą przyczyną niepowodzenia może być wysyłanie pliku ze znakami binarnymi poza obszarem tekstu ujętego w cudzysłowy. Można również sprawdzić zapytanie SQL poprzez linię poleceń MySQL-a. W znalezieniu przyczyny problemu może pomóc także - jeśli się pojawi - poniższy opis błędu serwera MySQL. Jeśli nadal występują z problemy lub analizator składni zgłasza usterkę a linia poleceń - nie, ogranicz sekwencję zapytań SQL do pojedynczego, które powoduje problemy i zgłoś błąd, dołączając fragment danych zawarty w poniższej sekcji TNIJ:
----TNIJ STĄD----
eNoBeAKH/UVSUk9SOiBDMSBDMiBMRU46IDIgMyAyNDgKU1RSOiADCgpTVk46ICRJZDogc3FscGFy
c2VyLmxpYi5waHAgMTE1MTMgMjAwOC0wOC0yOCAxNjoxNzo1M1ogbGVtOSAkCk15U1FMOiA1LjAu
ODEtY29tbXVuaXR5ClVTUiBPUywgQUdFTlQsIFZFUjogV2luIElFIDguMApQTUE6IDIuMTEuOS41
ClBIUCBWRVIsT1M6IDUuMi42IExpbnV4CkxBTkc6IHBsLXV0Zi04ClNRTDogUEsDBBQAAAAIAJWT
9DoaxXflCZYAAJu5BQATAAAAYmFydHUyMzNfZGlhYmxvLnNxbOydbVcUx9b33+dTtOtkrUSX9Omq
fubEHFEwEnlQQGPiUmygAx2GaTIziHB55bPfXV3Vw0DPv9m7eq5391kaJmx0O+r+OUz/Z1fVrv2w
tOScn5xvXq0cnRVDZ/fNhrN6cXb+3dKS8yUfjYty6PiucEP1GyeTyfnyv/99eXnpViZhbXA7Z1eZ
MnGH+aT6Q/XnL8vxZNkZlIfZ4KT6pfqt59fZ2Lm8Os6H+ai8zIZFtuxIz9kozqsvXvrYEcmyTNTf
/K361/7KnHEmZ3Q7usxH1d8KXc+N4pk/ef3ytfpd6abffbe7tuesvN3bfr69ubm+98T7z3e7eys7
e87ezsrW7srzvfXtrf989913/370IPCEJxz1959ub6zuP3+5slP9+drOfvVb+8831te29p4mbHQ7
fTrvt51H//7PvYSdtd23G3u7LYT5fcTY3thYUS+y+tXW1lr9ehVizm+3CVsrm2u7zsXkz6T+M/Pe
P8uuM+coG14dniw7dJcnug==
----TNIJ DOTĄD----
----SUROWE DANE STĄD----

ERROR: C1 C2 LEN: 2 3 248
STR: 

SVN: $Id: sqlparser.lib.php 11513 2008-08-28 16:17:53Z lem9 $
MySQL: 5.0.81-community
USR OS, AGENT, VER: Win IE 8.0
PMA: 2.11.9.5
PHP VER,OS: 5.2.6 Linux
LANG: pl-utf-8
SQL: PK���:�w� ���bartu233_diablo.sql��mW�����S��d�D����~��Q0yP@c�Rl��i23�py���]]��@Ͽٻz�w�Y<��9L�gWծ���䜟�o^��Cg�͆�zqv��Ғ�%��r���pC�'������}yy�V&gW�2q����C��/��d�������������ع�:&#903;���̆E��H��(Ϋ/^��ɲL�������ʜq>��G��
]ύ��?y����]���}���笼��~���������w�{+;{�������������|��w�~� ��'���no��?��S����~�[��7�׶��<}:�G��Ͻ���ݷ{�-��}����XQ/�����Z�zb�o� [+�k����Ϥ�3��?ˮ3�(^�,;----SUROWE DANE DOTĄD----


zapytanie SQL:

PK���:�w� ���bartu233_diablo.sql��mW�����S��d�D����~��Q0yP@c�Rl��i23�py���]]��@Ͽٻz�w�Y<��9L�gWծ���䜟�o^��Cg�͆�zqv��Ғ�%��r���pC�'������}yy�V&gW�2q����C��/��d�������������ع�:&#903;���̆E��H��(Ϋ/^��ɲL�������ʜq>��G�� ]ύ��?y����]���}���笼��~���������w�{+;{�������������|��w�~� ��'���no��?��S����~�[��7�׶��<}:�G��Ͻ���ݷ{�-��}����XQ/�����Z�zb�o� [+�k����Ϥ�3��?ˮ3�(^�,;

MySQL zwrócił komunikat:

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'PK' at line 1


  • +
  • -
  • 0

#4 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 21.07.2009 08:19

Zrób zrzut w jak najprostszy sposób, nie zaznaczaj żadnych dodatkowych opcji w phpmyadminie, tak samo postępuj przy imporcie, nie zaznaczaj dodatkowych opcji, poprostu wgrywaj "tak jak jest". Baza danych diablomoda nie zawiera polskich znaków diakrytycznych i nie ma prawa się krzaczyć.
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#5 bartu233

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: -3
Mniej niż zer0.

  • Postów:87
  • Lokalizacja:Słupsk
Offline

Napisano 21.07.2009 14:11

Zrób zrzut w jak najprostszy sposób, nie zaznaczaj żadnych dodatkowych opcji w phpmyadminie, tak samo postępuj przy imporcie, nie zaznaczaj dodatkowych opcji, poprostu wgrywaj "tak jak jest". Baza danych diablomoda nie zawiera polskich znaków diakrytycznych i nie ma prawa się krzaczyć.


Zrobilem tak, nie zaznaczalem nic dodatkowego tylko to co standardowo bylo, przy imporcie to samo i jeszcze wiecej "krzakow" wyrzuca ;//

[ Dodano: 27-07-2009, 16:42 ]
Dobra udało mi sie przezucic baze. Temat do zamkniecia.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych