Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AmxBans nie łączy się z serwerem


Najlepsza odpowiedź Cisiu, 31.12.2013 18:54

Tak wszystko jest zrobione poprawnie, robię kolejną próbę, wszystko od nowa jak zadziała dam informacje.

 

@edit zrobiłem od nowa bazę danych wgrałem od nowa pliki i nadal to samo już nie wiem naprawdę co może być grane ....

 

@edit#2 zauważyłem coś dziwnego jak dla mnie, chciałem ustawić prawa dla pliku czyli 777, ale wywala błąd "550 db.config.inc.php: Permission denied" w FTP wydaje mi się to trochę chore, bo w innych plikach mogę normalnie zmieniać prawa pliku.

Przejdź do postu


  • Zamknięty Temat jest zamknięty
14 odpowiedzi w tym temacie

#1 Cisiu

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 30.12.2013 00:50

Witam, chciałem dzisiaj zainstalować i wgrać AmxBans, no to zacząłem to robić wszystko ładnie przebiegło aż do momętu po instalacji gdzie nie mogłem wejść na stronę główną, a na stronie głównej był taki komunikat:

 

amxbans Access denied for user 'aron_bany'@'127.0.0.1' (using password: YES)

 

Nie wiem co jest grane i o co chodzi, hosting mam bardzo dobry nie ma limitów 200gb dysku więc chyba to nie jest wina hostingu chociaż kij wie, czekam na waszą pomoc.


  • +
  • -
  • 0

#2 adif11

    Wszechpomocny

  • Zbanowany

Reputacja: 19
Początkujący

  • Postów:357
  • Imię:adrian
  • Lokalizacja:szczecin
Offline

Napisano 30.12.2013 01:05

Złe hasło do bazy danych :)


Zapraszam Serdecznie Na Cod Mod'a [401 lvl]

b_350_20_FFFFFF_FFFFFF_000000_000000.png


#3 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 30.12.2013 01:30

No właśnie w tym sęk, że hasło jest dobre, nawet 3 razy zmieniałem na inne ale to samo wyskakiwało, spróbuje jeszcze raz ale nie wieże, że to pomoże.

 

@Edit:

 

Tak jak myślałem po raz 4 zmieniłem na inne hasło ale to nic nie daje, nadal to samo wyskakuje. Jakieś inne pomysły jak to naprawić?


Użytkownik Cisiu edytował ten post 30.12.2013 01:38

  • +
  • -
  • 0

#4 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 30.12.2013 09:56

nie wpisuj 127.0.0.1 oraz localhost jako hosta :)

pokaż sql.cfg

i przypisałeś użytkownika do bazy ??
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#5 Marvelous

    Pomocny

  • Zbanowany

Reputacja: 9
Nowy

  • Postów:51
  • Lokalizacja:Łódź
Offline

Napisano 30.12.2013 10:24

amx_sql_host "TWÓJ HOST"
amx_sql_user "NAZWA USERA W BAZIE"
amx_sql_pass "HASŁO" 
amx_sql_db "NAZWA BAZY"
amx_sql_table "NAZWA TABELI"
amx_sql_type "mysql"
 


#6 Slawo

    Początkujący

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:18
  • Imię:Sławek
  • Lokalizacja:Górka
Offline

Napisano 30.12.2013 10:29

jeżeli www masz na xaa to w amx_sql_host "TWÓJ HOST" wpisz tak amx_sql_host "twoja-strona.xaa.pl"

 miałem taki sam problem i to pomogło ;)
 

  • +
  • -
  • 0

#7 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 30.12.2013 10:57

sql z serwera cs:

// SQL configuration file
// File location: $moddir/addons/amxmodx/configs/sql.cfg

// *NOTE* Linux users may encounter problems if they specify "localhost" instead of "127.0.0.1"
// We recommend using your server IP address instead of its name

// *NOTE* amx_sql_type specifies the DEFAULT database type which admin.sma will use.

amx_sql_host    "localhost"
amx_sql_user    "aron_bany"
amx_sql_pass    "hasło"
amx_sql_db        "aron_bany"
amx_sql_table    "admins"
amx_sql_type    "mysql"

Ale nie chodzi mi tu o stronę serwera tylko o stronę web czyli strony bo to na niej mam ten komunikat, a i co do tego localhost to jak inaczej mam tam wpisać ? bo jeżeli nie mam wpisywać 127.0.0.1 ani localhost to co podać przy instalacji aby połączył się z bazą danych.

 

@edit a co do hostingu to mam go w hoting.ca-team.pl


Użytkownik Cisiu edytował ten post 30.12.2013 10:58

  • +
  • -
  • 0

#8 Carbon

    Profesjonalista

  • Użytkownik

Reputacja: 33
Życzliwy

  • Postów:170
  • Imię:Kuba
  • Lokalizacja:Warsaw
Offline

Napisano 31.12.2013 16:15

sql z serwera cs:

// SQL configuration file
// File location: $moddir/addons/amxmodx/configs/sql.cfg

// *NOTE* Linux users may encounter problems if they specify "localhost" instead of "127.0.0.1"
// We recommend using your server IP address instead of its name

// *NOTE* amx_sql_type specifies the DEFAULT database type which admin.sma will use.

amx_sql_host    "localhost"
amx_sql_user    "aron_bany"
amx_sql_pass    "hasło"
amx_sql_db        "aron_bany"
amx_sql_table    "admins"
amx_sql_type    "mysql"

Ale nie chodzi mi tu o stronę serwera tylko o stronę web czyli strony bo to na niej mam ten komunikat, a i co do tego localhost to jak inaczej mam tam wpisać ? bo jeżeli nie mam wpisywać 127.0.0.1 ani localhost to co podać przy instalacji aby połączył się z bazą danych.

 

@edit a co do hostingu to mam go w hoting.ca-team.pl

amx_sql_host    "localhost" 

W miejsce localhost wpisz "nazwa-twojego-forum.xaa.pl"


  • +
  • -
  • 0

Jeżeli Ci pomogłem, nie wahaj się i naciśnij  repup.jpg

 

 

Nie kłóć się z debilem.

Najpierw sprowadzi Cię do swojego poziomu, a następnie pokona doświadczeniem.


#9 TheDarkDevil

    Pomocny

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:45
  • Lokalizacja:Głowno
Offline

Napisano 31.12.2013 16:21

Jaki masz Hosting?

Jeśli ProSerwer skorzystaj z tego poradnika : http://amxx.pl/topic...xaapl/?p=599362

Mi pomógł.


Użytkownik TheDarkDevil edytował ten post 31.12.2013 16:23


#10 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 31.12.2013 17:04

Tak jak pisałem mam hosting w Hosting.ca-team.pl i jak tam wpisuje w nazwie hosta bany.mojadomena.pl to mi nadal nie działa, musi być inna przyczyna.


  • +
  • -
  • 0

#11 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 31.12.2013 18:27

Dodam iż nie chodzi mi o serwer cs lecz o amx na stronie, bo z tego co widzę to wy nic nie czytacie w moim temacie napisane jak byk jest że mam taki błąd na stronie www... i chciałbym to naprawić.

 

@Edit nie mogłem wcisnąć edytuj ostatniego postu więc musiałem napisać duble z góry przepraszam za to.


Użytkownik Cisiu edytował ten post 31.12.2013 18:28

  • +
  • -
  • 0

#12 master522

    Wszechwidzący

  • Użytkownik

Reputacja: 100
Zaawansowany

  • Postów:237
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Mikołów
Offline

Napisano 31.12.2013 18:34

Zobacz w include/db.config.inc.php czy dane się zgadzają.
Sprawdz na hostingu czy MySQL rzeczywiście jest na localu (127.0.0.1).

Co do serwera i sql.cfg
amx_sql_host "twojadomena.pl".

//edit
No i na początku wypadałoby napisać o jaką wersje amxbans chodzi...

Użytkownik master522 edytował ten post 31.12.2013 18:38

  • +
  • -
  • 0

#13 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 31.12.2013 18:44

Trudno mi powiedzieć co to za wersja amx, bo miałem już ją na PC ale wiem że jest świeża nazwa paczki pobranej zwie się "AMXBans MIX (AMXX.PL).zip"

 

CO do danych czy się zgadzają, to się zgadzają w 100%

MySQL musi mieć raczej localhost bo jak robiłem forum to zadziałało i forum działa ładnie pięknie.

 

Z serwerem to ja wiem jak mam to ustawić, tylko nic nie mogę zrobić z tego względu, iż strona web wywala właśnie taki błąd:

Access denied for user 'baza_amx'@'127.0.0.1' (using password: YES)

  • +
  • -
  • 0

#14 master522

    Wszechwidzący

  • Użytkownik

Reputacja: 100
Zaawansowany

  • Postów:237
  • Steam:steam
  • Imię:Łukasz
  • Lokalizacja:Mikołów
Offline

Napisano 31.12.2013 18:52

i przypisałeś użytkownika do bazy ??


  • +
  • -
  • 0

#15 Cisiu

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:35
  • Lokalizacja:dychów
Offline

Napisano 31.12.2013 18:54   Najlepsza odpowiedź

Tak wszystko jest zrobione poprawnie, robię kolejną próbę, wszystko od nowa jak zadziała dam informacje.

 

@edit zrobiłem od nowa bazę danych wgrałem od nowa pliki i nadal to samo już nie wiem naprawdę co może być grane ....

 

@edit#2 zauważyłem coś dziwnego jak dla mnie, chciałem ustawić prawa dla pliku czyli 777, ale wywala błąd "550 db.config.inc.php: Permission denied" w FTP wydaje mi się to trochę chore, bo w innych plikach mogę normalnie zmieniać prawa pliku.


Użytkownik Cisiu edytował ten post 31.12.2013 19:18

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych