Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z Vip Pulgin 3.4


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Kokalovsky.

    Początkujący

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:19
  • Imię:Kamil
  • Lokalizacja:Rybnik
Offline

Napisano 21.12.2013 14:09

Witam, mam wgrany na serwerze ten oto pulgin: http://amxx.pl/topic...-vip-plugin-34/


Problem polega na tym, że gdy dodaje vipa w users.ini danej o sobie pozmienie mapy tego vipa nie ma.


Ps: Ja sobie dodałem vipa i działa ale innym nie, tak samo osoba mająca admina ma vipa.


Tak Wygląda moje Users.ini

 

; Users configuration file
; File location: $moddir/addons/amxmodx/configs/users.ini

; Line starting with ; is a comment

; Access flags:
; a - immunity (can't be kicked/baned/slayed/slaped and affected by other commmands)
; b - reservation (can join on reserved slots)
; c - amx_kick command
; d - amx_ban and amx_unban commands
; e - amx_slay and amx_slap commands
; f - amx_map command
; g - amx_cvar command (not all cvars will be available)
; h - amx_cfg command
; i - amx_chat and other chat commands
; j - amx_vote and other vote commands
; k - access to sv_password cvar (by amx_cvar command)
; l - access to amx_rcon command and rcon_password cvar (by amx_cvar command)
; m - custom level A (for additional plugins)
; n - custom level B
; o - custom level C
; p - custom level D
; q - custom level E
; r - custom level F
; s - custom level G
; t - custom level H
; u - menu access
; z - user (no admin)
; t - Flaga dostępu do przywilejów VIP'a
; Account flags:
; a - disconnect player on invalid password
; b - clan tag
; c - this is steamid/wonid
; d - this is ip
; e - password is not checked (only name/ip/steamid needed)
; k - name or tag is case sensitive.  eg: if you set it so the name "Ham"
;     is protected and case sensitive (flags "k" only), then anybody
;     can use the names "haM", "HAM", "ham", etc, but not "Ham"

; Password:
; Add to your autoexec.cfg: setinfo _pw "<password>"
; Change _pw to the value of amx_password_field

; Format of admin account:
; <name|ip|steamid> <password> <access flags> <account flags>

; Examples of admin accounts:

"STEAM_0:1:28705390" "" "it" "de"
"STEAM_0:0:34049978" "" "it" "de"
"MRdiablol" "dziwnehasło" "it" "ab"
"RastA." "12345" "it" "ab"

Tak jak pisze w instrucji dodałem vipa koledze zgodnie ze wzorem:

Tak dodasz Vip na Nick i Hasło
"Nick" "Hasło" "it" "ab"



Następny problem to taki, że po wpisaniu na say /vips pisze "Brak Vip'ów online"


Prosiłbym o pomoc nie wiem co z tym zrobić, a siedziałem nad tym długo



Pozdrówki ;)


  • +
  • -
  • 0

#2 Szymon035

    Wszechwiedzący

  • Power User

Reputacja: 79
Zaawansowany

  • Postów:570
  • Steam:steam
  • Imię:Szymon
  • Lokalizacja:Katowice / Żory
Offline

Napisano 21.12.2013 14:19

Jak dajesz na nick+hasło to musisz ustawić flage autoryzacji b

; Flagi autoryzacji
; a - kickuje gracza gdy poda zle haslo
; a - dostep na haslo
; b - klanowy tag
; b - dostep poprzez tag klanowy
; c - po przez steamid/wonid
; c - poprzez steamid/id gracza
; d - po przez IP
; d - poprzez ip
; e - haslo nie bedzie wymagana (tylko name/ip/steamid bedzie potrzebne)
; e - bez hasla
; =======================================================
; Przyklad autoryzacji:
; de - gracz autoryzowany za pomoca wpsianego IP bez sprawdzania hasla (pole z haslem nie wymagane!)
; ce - gracz autoryzowany za pomoca wpsianego STEAMID bez sprawdzania hasla (pole z haslem nie wymagane!)
; b - gracz autoryzowany za pomoca wpsianego loginu oraz wymaganego hasla (pole z haslem wymagane!)


  • +
  • -
  • 1
Dołączona grafika

#3 Kokalovsky.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:19
  • Imię:Kamil
  • Lokalizacja:Rybnik
Offline

Napisano 21.12.2013 14:25

Możesz mi przerobić to i wkleić w kodzie ? bo znając mnie coś zrobie źle ;) i leci plus ;)


  • +
  • -
  • 0

#4 Szymon035

    Wszechwiedzący

  • Power User

Reputacja: 79
Zaawansowany

  • Postów:570
  • Steam:steam
  • Imię:Szymon
  • Lokalizacja:Katowice / Żory
Offline

Napisano 21.12.2013 14:39

"STEAM_0:1:28705390" "" "it" "ce"
"STEAM_0:0:34049978" "" "it" "ce"
"MRdiablol" "dziwnehasło" "it" "b"
"RastA." "12345" "it" "b"


Sprawdź czy działa :)


Użytkownik Szymon035 edytował ten post 21.12.2013 14:40

  • +
  • -
  • 0
Dołączona grafika

#5 Kokalovsky.

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:19
  • Imię:Kamil
  • Lokalizacja:Rybnik
Offline

Napisano 21.12.2013 14:47

Dlej nie działa

Brak Vipów Online
A admin ma automatycznie vipa.
Po odebraniu sobie admina nie mam vipa.


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych