Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Pomocy plugin nie działa


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Zibi17k

    Zaawansowany

  • Zbanowany

Reputacja: 0
zer0.

  • Postów:125
  • Lokalizacja:Kalisz
Offline

Napisano 05.07.2009 14:21

Witam mam problem z tym pluginem dzwieki.amxx nie działa

#include <amxmodx>
#include <amxmisc>

new const PLUGIN[] = "Menu Dzwiekow"
new const VERSION[] = "1.0"
new const AUTHOR[] = "byQQ"


public plugin_init()
{
register_plugin(PLUGIN, VERSION, AUTHOR)
//Komendy by wlaczyc menu
register_clcmd("say /dzwieki", "weaponsmenu")
register_clcmd("say_team /dzwieki", "weaponsmenu")
// Koniec
register_clcmd("bialoczerw", "say_bialoczerw")
register_clcmd("spartans", "say_spartans")
register_clcmd("40to1", "say_40to1")
set_task(60.0, "reklama", _, _, _, "b")
}


public plugin_precache()
{
precache_sound("sound/dzwieki/bialoczerw.mp3")
precache_sound("sound/dzwieki/spartans.mp3")
precache_sound("sound/dzwieki/40to1.mp3")

}

public say_bialoczerw(id)
{
client_cmd(0,"mp3 play sound/dzwieki/bialoczerw")
}

public say_spartans(id)
{
client_cmd(0,"mp3 play sound/dzwieki/spartans")
}

public say_40to1(id)
{
client_cmd(0,"mp3 play sound/dzwieki/40to1")
}


public reklama(id)
{
client_print(id, print_chat, "^x04 c*******.**^x04 Wpisz /dzwieki by zobaczyc menu!")
}

public weaponsmenu(id)
{
new menu = menu_create("Dzwieki!:", "menu_handler")
menu_additem(menu, "Bialoczerw", "1", 0)
menu_additem(menu, "Spartans", "2", 0)
menu_additem(menu, "40to1", "3", 0)

menu_setprop(menu, MPROP_EXIT, MEXIT_ALL)
menu_display(id, menu, 0)
}

public menu_handler(id, menu, item)
{
if (item == MENU_EXIT)
{
return PLUGIN_HANDLED
}
new data[6], iName[64]
new access, callback
menu_item_getinfo(menu, item, access, data,5, iName, 63, callback)
new key = str_to_num(data)
switch(key)
{
case 1:{
client_cmd(id, "bialoczerw")
menu_destroy(menu)
return PLUGIN_HANDLED
}
case 2:{
client_cmd(id, "spartans")
menu_destroy(menu)
return PLUGIN_HANDLED
}
case 3:{
client_cmd(id, "40to1")
menu_destroy(menu)
return PLUGIN_HANDLED
}

}
menu_destroy(menu)
return PLUGIN_HANDLED
}

Oto logi

L 07/05/2009 - 15:17:24: Start of error session.
L 07/05/2009 - 15:17:24: Info (map "cs_1337_assault") (file "addons/amxmodx/logs/error_20090705.log")
L 07/05/2009 - 15:17:24: [AMXX] Plugin file open error (plugin "amx_haconc.amxx")
L 07/05/2009 - 15:17:24: [AMXX] Unknown error (plugin "dzwieki.amxx")
L 07/05/2009 - 15:17:26: Start of error session.
L 07/05/2009 - 15:17:26: Info (map "cs_1337_assault") (file "addons/amxmodx/logs/error_20090705.log")
L 07/05/2009 - 15:17:26: [AMXX] Plugin file open error (plugin "amx_haconc.amxx")
L 07/05/2009 - 15:17:26: [AMXX] Unknown error (plugin "dzwieki.amxx")
L 07/05/2009 - 15:17:26: Client CVAR querying is not enabled - check MM version!
L 07/05/2009 - 15:17:26: [AMXX] Run time error 10 (plugin "interp_kick.amxx") (native "query_client_cvar") - debug not enabled!
L 07/05/2009 - 15:17:26: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Plugin przrestał działać gdy dodałem 3 utwór co zrobić by dodać 3 utwór pomocy (plugin jest dobrze skomplitowany!!!)

#2 Gość__*

  • Gość

Reputacja: 0

Offline

Napisano 05.07.2009 19:24

L 07/05/2009 - 15:17:24: [AMXX] Plugin file open error (plugin "amx_haconc.amxx")

Brak pliku amx_hancoc w katalogu /plugins

L 07/05/2009 - 15:17:26: [AMXX] Unknown error (plugin "dzwieki.amxx")
L 07/05/2009 - 15:17:26: Client CVAR querying is not enabled - check MM version!

Jaką masz wersje MetaMod`a, AMXX`a?

L 07/05/2009 - 15:17:26: [AMXX] Run time error 10 (plugin "interp_kick.amxx") (native "query_client_cvar") - debug not enabled!
L 07/05/2009 - 15:17:26: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).

Popraw wpis w plugins.ini na interp_kick.amxx

#3 Zibi17k

    Zaawansowany

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:125
  • Lokalizacja:Kalisz
Offline

Napisano 06.07.2009 09:45

AMX'a mam wersje najnoszą a metamoda 1.19 ale jak wgram plugin z dwiema piosenkami to chodzi. A mam jeszcze 2 pytanie czy do plugin w metamodzie też mam wpisywać pluginy?
Działający plugin podmieniłem tym samym pluginem i przestał również działać (te same pliki) i taki log

L 07/06/2009 - 11:13:50: Start of error session.
L 07/06/2009 - 11:13:50: Info (map "de_cbble") (file "addons/amxmodx/logs/error_20090706.log")
L 07/06/2009 - 11:13:50: [AMXX] Unknown error (plugin "dzwieki.amxx")
L 07/06/2009 - 11:13:52: Start of error session.
L 07/06/2009 - 11:13:52: Info (map "de_cbble") (file "addons/amxmodx/logs/error_20090706.log")
L 07/06/2009 - 11:13:52: [AMXX] Unknown error (plugin "dzwieki.amxx")

Teraz na drugim cs'e gdzie wszystko chodziło dzwieki też przestały chodzić nic nie zmieniałem tylko właczyłem gre -.- log wygląda identycznie

#4 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1996
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 06.07.2009 10:28

czy do plugin w metamodzie też mam wpisywać pluginy?


Nie
  • +
  • -
  • 0

#5 Zibi17k

    Zaawansowany

  • Autor tematu
  • Zbanowany

Reputacja: 0
zer0.

  • Postów:125
  • Lokalizacja:Kalisz
Offline

Napisano 06.07.2009 10:52

Zrobiłem nie pytajcie jak bo sam nie wiem komplilowałem z 5 razy i w końcu załapało bez zmian w pliku .sma




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych