Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Błąd z kompilatorem


  • Zamknięty Temat jest zamknięty
4 odpowiedzi w tym temacie

#1 Diabelek1108

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:Wołomin
Offline

Napisano 30.06.2009 07:52

wyskakuje mi taki błąd :

"Nie udało się skompilować pluginu.
Przeczytaj poniższy bład:

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright © 1997-2006 ITB CompuPhase, AMX Mod X Team

/home/groups/amxmodx/tmp3/textibPCSh.sma(1) : error 010: invalid function or declaration
/home/groups/amxmodx/tmp3/textibPCSh.sma(77) : warning 217: loose indentation

1 Error.
Could not locate output file /home/groups/amxmodx/public_html/websc3/textibPCSh.amx (compile failed)."

mój kod to:

RoundSound.amxx -by PaintLancer

#include <amxmodx>

public plugin_init()
{
register_plugin("RoundSound","1.0","PaintLancer")
register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
new rand = random_num(0,2)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/ctbs1")
case 1: client_cmd(0,"spk misc/tbs2")
case 3: client_cmd(0,"spk misc/lol2")
case 4: client_cmd(0,"spk misc/sorry")
case 5: client_cmd(0,"spk misc/wazup")
case 6: client_cmd(0,"spk misc/wiling")
case 7: client_cmd(0,"spk misc/s-ct10")
case 8: client_cmd(0,"spk misc/s-t30")
case 9: client_cmd(0,"spk misc/twinnar")
case 10: client_cmd(0,"spk misc/k")
}

return PLUGIN_HANDLED
}

public ct_win()
{
new rand = random_num(0,2)

client_cmd(0,"stopsound")

switch(rand)
{
case 0: client_cmd(0,"spk misc/ctbs2")
case 1: client_cmd(0,"spk misc/ctbs3") //
case 2: client_cmd(0,"spk misc/ctwinnar28")
case 3: client_cmd(0,"spk misc/twinnar")
case 4: client_cmd(0,"spk misc/cyls")
case 5: client_cmd(0,"spk misc/k")
case 6: client_cmd(0,"spk misc/tea")
case 7: client_cmd(0,"spk misc/benz")
case 8: client_cmd(0,"spk misc/wazup")
case 9: client_cmd(0,"spk misc/willing")
case 10: client_cmd(0,"spk misc/s-ct10")
}

return PLUGIN_HANDLED
}

public plugin_precache()
{
precache_sound("misc/ctbs1.wav")
precache_sound("misc/ctbs2.wav")
precache_sound("misc/ctbs3.wav")
precache_sound("misc/ctwinnar28.wav")
precache_sound("misc/twinnar.wav")
precache_sound("misc/cyls.wav")
precache_sound("misc/k.wav")
precache_sound("misc/lol2.wav")
precache_sound("misc/sorry.wav")
precache_sound("misc/tea.wav")
precache_sound("misc/wiling.wav")
precache_sound("misc/s-ct10.wav")
precache_sound("misc/s-t30.wav")
precache_sound("misc/wazup.wav")
precache_sound("misc/tbs2.wav")
precache_sound("misc/benz.wav")
return PLUGIN_CONTINUE
}



Co złe jest mógłby mi ktoś powiedzieć?
Sorry bo chyba nie ten dział jak coś to proszę o przeniesienie.
  • +
  • -
  • 0

#2 darkman

    Wszechwiedzący

  • Przyjaciel

Reputacja: 85
Zaawansowany

  • Postów:553
  • Lokalizacja:inactive
Offline

Napisano 30.06.2009 13:33

usuń albo zakomentuj linijkę
RoundSound.amxx -by PaintLancer

  • +
  • -
  • 0

#3 Diabelek1108

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:Wołomin
Offline

Napisano 30.06.2009 20:39

Dzięki Ci wielkie a mógłbyś mi jeszcze powiedzieć dlaczego nie wszystkie nuty się odtwarzają zamiast odtwarzanej nuty jest cisza. wszystkie dodane nuty są w wav i wszystkie je posiadam w odpowiednim folderze.
  • +
  • -
  • 0

#4 darkman

    Wszechwiedzący

  • Przyjaciel

Reputacja: 85
Zaawansowany

  • Postów:553
  • Lokalizacja:inactive
Offline

Napisano 30.06.2009 20:50

w obydwóch funkcjach zmień
new rand = random_num(0,2)

na

new rand = random_num(0,10)

  • +
  • -
  • 0

#5 Diabelek1108

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:4
  • Lokalizacja:Wołomin
Offline

Napisano 30.06.2009 21:09

dzięki all działa leci "pomógł" :)
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych