Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Losowy VIP - Błąd generatora


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 `Sernik

    `Profesjonalista !

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 13.09.2013 16:43

Witam,

na wstępie dodam, ze już kiedyś zakładałem tego typu temat:

http://amxx.pl/topic...-vip-generator/

Wtedy miałem ten sam problem jednak po usunięciu cześci kodu z pomocą ludzi udało się jakoś to naprawić, ale teraz problem jest znowu gdyż mam nowy serwer i nowego vip'a z nowu wygenerowanego.

 

Dodam, że nie wmówicie mi (autorzy), że problem jest z:

-amxbans

-innymi pluginami

 

Błąd jest w kodzie VIPa gdyż już wcześniej miałem ten problem i nie ja jeden. Jest wiele osób, które ten błąd miały nawet bez AMXBANS i innych pluginów.

 

Problem jest taki, że VIP co jakiś czas buguje się pod tym względem, że jakaś osoba na serwerze nagle jest VIPem. Po zmianie mapy to ustępuje. Jednak gdy dana osoba została nieumyślnie wylosowana jako VIP wtedy też wpisując /vips ujrzymy jej nick 2 razy zamiast razu co automatycznie nam mówi, ze coś jest nie tak. Osoba ta ma wszystkie przywileje VIP'a, ale jako że mam wgrane automatyczne reloadowanie adminów nie ma szans, żeby ta osoba miała tę flagę. Mimo wszystko błąd się pojawia, bo to nie jest zależne czy osoba jest na serwie nawet. Po prostu nagle wejdzie i ma vipa. Czasami nie ma tego 3 dni. a czasem co mape może być nawet 3 graczy z losowym vipem. 

 

 

Propozycje, sugestie wszystko co ma SENS proszę pisać i omówić. Plusy będę dawał jak leci jeżeli ktoś mi pomoże. Przy okazji jeżeli uda się to rozwiązać będzie można podpiąć temat w dziale z generatorem, albo wreszcie go naprawić!

 

Pozdrawiam


Użytkownik sernikkk edytował ten post 13.09.2013 16:44

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#2 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 13.09.2013 16:56

Zacznę tak.
 
Mam vipa już dłuższy czas. Jakieś 3 miesiące na serwerze jak nie dłużej i nie ma żadnego problemu. Flagi gracza są pobierane jeżeli się nie mylę to podczas autoryzacjii gracza. Więc na pewno problem leży po stronie amxbans'a lub jakiś plugin. Spróbuj wgrać tego vipa na czysty serwer i się przekonasz że nie ma żadnych problemów z kodem :)

Pozdrawiam glut.
  • +
  • -
  • 0

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#3 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 13.09.2013 16:59

To w takim razie jak wyjaśnisz, że jest tylko 1 plugin, który przydziela flage T i jest to vip. Żaden inny. A jak przeczytasz ten temat to jest osoba, która mówi, ze miała ten problem z plikiem users.ini. A poza tym jak mam wgrać na pusty serwer? To ja kto sprawdzę jak do tego potrzeba kilka dni i ludzi którzy będą grali żeby wyłapać taki błąd.


  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#4 Ravenek

    Zaawansowany

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:102
  • GG:
  • Steam:steam
  • Imię:Marcin
  • Lokalizacja:Rzeszów
Offline

Napisano 23.11.2014 18:41

Mam ten sam problem, proszę o pomoc.


  • +
  • -
  • 0

b_350_20_FFAD41_E98100_000000_591F11.png

IP: 80.72.37.10:27073





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych