Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Brak lvla po zmianie mapy


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 _Gagarin_

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:81
  • Lokalizacja:POLSKA
Offline

Napisano 19.08.2013 11:01

witam mam problem zalozylem nowa baze danych i mam taki problem lvl sie jednej osobie zapisze a drugiej jzu nie mam zapis na nick itp i jakis problem bo nie kazdemu sie zapisze lvl po zmianie mapy
  • +
  • -
  • 0

#2 .K3K

    Ja tu tylko sprzątam :s

  • Zbanowany

Reputacja: 46
Pomocny

  • Postów:263
  • Imię:Karol
  • Lokalizacja:Poznań
Offline

Napisano 19.08.2013 23:53

napisz jaką masz bazę danych, jakiego diablo moda. i podaj logi od ostatniej zmiany mapy.


b_350_20_18CE03_051005_FFFFFF_111111.png

#3 _Gagarin_

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:81
  • Lokalizacja:POLSKA
Offline

Napisano 20.08.2013 09:45

xaa diablo edytowane z forum
  • +
  • -
  • 0

#4 .K3K

    Ja tu tylko sprzątam :s

  • Zbanowany

Reputacja: 46
Pomocny

  • Postów:263
  • Imię:Karol
  • Lokalizacja:Poznań
Offline

Napisano 20.08.2013 12:25

na xaa takie problemy jeszcze się nie spotkałem :/ być może to wina silnika ale nie jestem pewien ja wyłączam się z tego tematu bo pomóc nie umiem :/ sorry


b_350_20_18CE03_051005_FFFFFF_111111.png

#5 Indoor

    Zaawansowany

  • Użytkownik

Reputacja: 19
Początkujący

  • Postów:114
  • Lokalizacja:Gorzów Wielkopolski City.
Offline

Napisano 20.08.2013 14:55

Najlepiej żebyś podał logi/.sma, możliwe że zrobiłeś literówkę gdzieś :)


  • +
  • -
  • 0

#6 Koksiu

    Pomocny

  • Użytkownik

Reputacja: 4
Nowy

  • Postów:42
  • Imię:Szymon
  • Lokalizacja:Poland
Offline

Napisano 20.08.2013 15:40

jzu nie mam zapis na nick
To na co masz zapis na IP ? Widocznie ktoś ma zmienne IP to mu nie zapisuje lvl.
  • +
  • -
  • 1
WYKONAM KLASY LUB PERKI, WIĘCEJ INFO NA PW. SPRZEDAM PERKI PREMIUM!!! SPRZEDAM 45 UNIKALNYCH KLAS!!!

#7 _Gagarin_

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:81
  • Lokalizacja:POLSKA
Offline

Napisano 20.08.2013 17:05

no mam na nick zapis wlaczony. daiblo dalem na test by one i by gorus - baze zmienilem na inna z xaa na hostingowa i tez nic zapisuje sie CZASAMI. a logow nie mam juz bo usunalem to diablo. na zwyklym klasycznym bylo wszystko OK
  • +
  • -
  • 0

#8 aVeQ

    Zaawansowany

  • Użytkownik

Reputacja: 25
Życzliwy

  • Postów:146
  • Imię:Przemek
  • Lokalizacja:WaWa
Offline

Napisano 25.08.2013 20:50

to możliwe że po prostu z silnikiem było coś nie tak.


  • +
  • -
  • 0

b_350_20_692108_381007_FFFFFF_000000.png

b_350_20_692108_381007_FFFFFF_000000.png

b_350_20_692108_381007_FFFFFF_000000.png

 


#9 BlackPerfum

    Pseudo interakcja??

  • Power User

Reputacja: 453
Wszechobecny

  • Postów:575
  • Lokalizacja:...
Offline

Napisano 25.08.2013 21:22

Jeśli exp


zapisuje sie CZASAMI
To są dwa sposoby aby tak było:

• Po stronie klienta - Graczu padł net lub bezpośrednio wyłączył proces cs'a a to prowadzi do nie wykonania na graczu forwardu disconect a brak wykonania go = brak zapisu

• Po stronie serwera - Crash serwera lub jakieś błędy w modzie / przestarzały amxx

 

No nie wiem co jeszcze może być :D


  • +
  • -
  • 0
Chcesz napisać do mnie na PW to:
Spoiler

Mój tok myślenia jest błędny? Wskaż mi błąd zmienie to!

Aktualnie bije limit 32 graczy (łącze serwery) ale nadal są lagi przy zbyt dużym przesyłu informacji Dołączona grafika
Gra się płynnie do 40~50 graczy potem łącze pada i zamiast biegać ludzie się teleportują Dołączona grafika

#10 Play4Fun

    Zaawansowany

  • Użytkownik

Reputacja: 15
Początkujący

  • Postów:86
  • GG:
  • Imię:Dawid
  • Lokalizacja:Lublin
Offline

Napisano 12.09.2013 12:30

Jeżeli zapis jest na nick poprzez SQL, to wina leży po stronie silnika dokładnie.

 

zapis amxx nie preferuje błędów przy odczycie SQL ;P dlatego też robi się speciajlny warunek return, dzięki któremu powracamy do zapisu gdy wystąpi błąd.

To też nie jest dobre bo definiuje to bugi ale nie ma innego wyjścia ;) ja się przynajmniej z innym nie spotkałem.

Zmień hosta bazy danych przede wszytskim na stałym IP ;) i zrestatruj serwer podpinając od nowa zasady bazy.

 

Wejdź w .sma pliku silnika Diablo i sprawdź warunki związane z SQL podaj je najlepiej to powiem ci co zmienić. ;)) Na przyszłość dla początkującego administratora serwera wybieraj mody z nVault nie bedziesz miał problemu z zapisem i odczytem jest to wąska baza ale idzie na niej podziałać ;)


  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych