Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Jak zrobić losowy pev_rendercolor?


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 Lacostii

    Profesjonalista

  • Użytkownik

Reputacja: 37
Życzliwy

  • Postów:172
  • Lokalizacja:Poland
Offline

Napisano 17.08.2013 00:22

Witam, potrzebuję pomocy w sprawie edycji pluginu co wypadają paczki za fraga.

Mam problem z ustaleniem losowego koloru poświaty dla danej paczki, próbowałem tak, ale kompilatorowi nie pasuje:

	set_pev(entit,pev_rendercolor,{random(256),random(256),random(256)})

Jakieś pomysły?


  • +
  • -
  • 0

Zapraszam na serwery Classic-Zone.pl . ;)

 

b_350_20_529B00_074900_FFFFFF_6DA500.png

b_350_20_B3390E_512015_FFFFFF_000000.png

 

http://1Polska.pl


#2 BlackPerfum

    Pseudo interakcja??

  • Power User

Reputacja: 453
Wszechobecny

  • Postów:575
  • Lokalizacja:...
Offline

Napisano 17.08.2013 06:41

Niestety trzeba robić nową tablicę:

	new Data[3]
	Data[0] = random(256)
	Data[1] = random(256)
	Data[2] = random(256)
	set_pev(id,pev_rendercolor,Data)

To jest jeden ze sposobów na wyjście z tej sytuacji.

 


  • +
  • -
  • 1
Chcesz napisać do mnie na PW to:
Spoiler

Mój tok myślenia jest błędny? Wskaż mi błąd zmienie to!

Aktualnie bije limit 32 graczy (łącze serwery) ale nadal są lagi przy zbyt dużym przesyłu informacji Dołączona grafika
Gra się płynnie do 40~50 graczy potem łącze pada i zamiast biegać ludzie się teleportują Dołączona grafika

#3 Lacostii

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 37
Życzliwy

  • Postów:172
  • Lokalizacja:Poland
Offline

Napisano 17.08.2013 16:34

Dzięki za odpowiedź, tak jak piszesz nie działało, ale po zrobieniu liczb na float już tak.

	new Float: Data[3]
	Data[0] = random_float(0.0,255.0)
	Data[1] = random_float(0.0,255.0)
	Data[2] = random_float(0.0,255.0)
	set_pev(entit,pev_rendercolor,Float:Data)

Można zamknąć.


  • +
  • -
  • 0

Zapraszam na serwery Classic-Zone.pl . ;)

 

b_350_20_529B00_074900_FFFFFF_6DA500.png

b_350_20_B3390E_512015_FFFFFF_000000.png

 

http://1Polska.pl


#4 CheQ

    Nie wiem, nie znam się, nie orientuję się, zarobiony jestem.

  • Junior Admin

Reputacja: 1984
Godlike

  • Postów:5534
  • Imię:Adaś
  • Lokalizacja:Glinianka
Offline

Napisano 17.08.2013 17:18

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, report.png raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0

b_560_95_1.png





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych