Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Problem z wgraniem nowej statystyki

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
28 odpowiedzi w tym temacie

#21 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 04.08.2013 19:26

Przykladowa klasa:
[sma]#include <amxmodx>
#include <amxmisc>
#include <codmod>
        
new const nazwa[]   = "TEST";
new const opis[]    = "";
new const bronie    = 1<<CSW_M4A1|1<<CSW_AK47|1<<CSW_AWP;
new const zdrowie   = 0;
new const kondycja  = 0;
new const inteligencja = 0;
new const wytrzymalosc = 0;
new const exp = 0;
new const obrazenia = 0;
new const grawitacja = 0;
new const leczenie = 0;
    
public plugin_init()
{
register_plugin(nazwa, "1.0", "amxx.pl");
 
cod_register_class(nazwa, opis, bronie, zdrowie, kondycja, inteligencja, wytrzymalosc, exp, obrazenia, grawitacja, leczenie);
}
include codmod tez zmodyfikowalem i zmiany w silniku zrobilem i dalej to samo :(
  • +
  • -
  • 0

#22 ka.linux

    Zaawansowany

  • Użytkownik

Reputacja: 46
Pomocny

  • Postów:78
  • GG:
  • Imię:Marek
  • Lokalizacja:Konin
Offline

Napisano 04.08.2013 19:35

Podaj error loga oczywiście, jeśli tylko masz debug koło silnik.amxx ; )


  • +
  • -
  • 0

POMAGAM PŁATNIE NA PROŚBĘ!


#23 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 05.08.2013 12:59

L 08/04/2013 - 21:24:27: Start of error session.

L 08/04/2013 - 21:24:27: Info (map "de_dust2_long") (file "addons/amxmodx/logs/error_20130804.log")
L 08/04/2013 - 21:24:27: Function "UstawBonusowyexp" was not found
L 08/04/2013 - 21:24:27: [AMXX] Run time error 19 (plugin "silnik2.amxx") - debug not enabled!
L 08/04/2013 - 21:24:27: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 08/04/2013 - 21:24:27: [AMXX] Run time error -1 (plugin "silnik2.amxx") - debug not enabled!
L 08/04/2013 - 21:24:27: Function "Damage_Wyrzucenie" was not found
L 08/04/2013 - 21:24:27: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:27: [AMXX] Run time error 19: function not found 
L 08/04/2013 - 21:24:27: [AMXX]    [0] silnik2.sma::plugin_init (line 169)
L 08/04/2013 - 21:24:28: Expected 0 parameters, got 2
L 08/04/2013 - 21:24:28: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:28: [AMXX] Run time error 10: native error (native "ExecuteForward")
L 08/04/2013 - 21:24:28: [AMXX]    [0] silnik2.sma::UstawNowaKlase (line 335)
L 08/04/2013 - 21:24:28: [AMXX]    [1] silnik2.sma::UsunUmiejetnosci (line 514)
L 08/04/2013 - 21:24:28: [AMXX]    [2] silnik2.sma::client_authorized (line 495)
L 08/04/2013 - 21:24:28: Expected 0 parameters, got 2
L 08/04/2013 - 21:24:28: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:28: [AMXX] Run time error 10: native error (native "ExecuteForward")
L 08/04/2013 - 21:24:28: [AMXX]    [0] silnik2.sma::UstawNowaKlase (line 335)
L 08/04/2013 - 21:24:28: [AMXX]    [1] silnik2.sma::UsunUmiejetnosci (line 514)
L 08/04/2013 - 21:24:28: [AMXX]    [2] silnik2.sma::client_authorized (line 495)
L 08/04/2013 - 21:24:28: Expected 0 parameters, got 2
L 08/04/2013 - 21:24:28: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:28: [AMXX] Run time error 10: native error (native "ExecuteForward")
L 08/04/2013 - 21:24:28: [AMXX]    [0] silnik2.sma::UstawNowaKlase (line 335)
L 08/04/2013 - 21:24:28: [AMXX]    [1] silnik2.sma::UsunUmiejetnosci (line 514)
L 08/04/2013 - 21:24:28: [AMXX]    [2] silnik2.sma::client_authorized (line 495)
L 08/04/2013 - 21:24:28: Expected 0 parameters, got 2
L 08/04/2013 - 21:24:28: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:28: [AMXX] Run time error 10: native error (native "ExecuteForward")
L 08/04/2013 - 21:24:28: [AMXX]    [0] silnik2.sma::UstawNowaKlase (line 335)
L 08/04/2013 - 21:24:28: [AMXX]    [1] silnik2.sma::UsunUmiejetnosci (line 514)
L 08/04/2013 - 21:24:28: [AMXX]    [2] silnik2.sma::client_authorized (line 495)
L 08/04/2013 - 21:24:30: [nVault] Invalid vault id: 0
 
L 08/04/2013 - 21:24:30: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:30: [AMXX] Run time error 10: native error (native "nvault_get")
L 08/04/2013 - 21:24:30: [AMXX]    [0] silnik2.sma::WczytajDane (line 1027)
L 08/04/2013 - 21:24:30: [AMXX]    [1] silnik2.sma::WybierzKlase (line 675)
L 08/04/2013 - 21:24:30: [AMXX]    [2] silnik2.sma::Odrodzenie (line 300)
L 08/04/2013 - 21:24:32: [nVault] Invalid vault id: 0
 
L 08/04/2013 - 21:24:32: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:32: [AMXX] Run time error 10: native error (native "nvault_get")
L 08/04/2013 - 21:24:32: [AMXX]    [0] silnik2.sma::WczytajDane (line 1027)
L 08/04/2013 - 21:24:32: [AMXX]    [1] silnik2.sma::WybierzKlase (line 675)
L 08/04/2013 - 21:24:32: [AMXX]    [2] silnik2.sma::Odrodzenie (line 300)
L 08/04/2013 - 21:24:32: HudSyncObject -1 is invalid
L 08/04/2013 - 21:24:32: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:32: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 08/04/2013 - 21:24:32: [AMXX]    [0] silnik2.sma::PobierzDoswiadczeniePoziomu (line 1427)
L 08/04/2013 - 21:24:32: [AMXX]    [1] silnik2.sma::PokazInformacje (line 1138)
L 08/04/2013 - 21:24:32: HudSyncObject -1 is invalid
L 08/04/2013 - 21:24:32: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:32: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 08/04/2013 - 21:24:32: [AMXX]    [0] silnik2.sma::PobierzDoswiadczeniePoziomu (line 1427)
L 08/04/2013 - 21:24:32: [AMXX]    [1] silnik2.sma::PokazInformacje (line 1138)
L 08/04/2013 - 21:24:32: HudSyncObject -1 is invalid
L 08/04/2013 - 21:24:32: [AMXX] Displaying debug trace (plugin "silnik2.amxx")
L 08/04/2013 - 21:24:32: [AMXX] Run time error 10: native error (native "ShowSyncHudMsg")
L 08/04/2013 - 21:24:32: [AMXX]    [0] silnik2.sma::PobierzDoswiadczeniePoziomu (line 1427)
L 08/04/2013 - 21:24:32: [AMXX]    [1] silnik2.sma::PokazInformacje (line 1138)
L 08/04/2013 - 21:24:32: HudSyncObject -1 is invalid
Damage_wyrzucenie to stare, zaraz sie wywali :) Ale nie wiem dlaczego wyswietlanie w HUDzie nawala, zwlaszcza, ze nie bylo modyfikowane...

  • +
  • -
  • 0

#24 ka.linux

    Zaawansowany

  • Użytkownik

Reputacja: 46
Pomocny

  • Postów:78
  • GG:
  • Imię:Marek
  • Lokalizacja:Konin
Offline

Napisano 05.08.2013 16:38

w plugin_init() masz do wyrzucenia :

  

register_event("Damage", "Damage_Wyrzucenie", "b", "2!=0");
    register_forward(FM_CmdStart, "fwCmdStart_exp");
Ponieważ nie są nigdzie używane.
 
Zamień:
        set_hudmessage(255, 255, 255, 0.6, -1.0, 0, 0.0, 0.3, 0.0, 0.0, 2);
Na, np:
        set_hudmessage(255, 255, 255, 0.02, 0.23, 0, 0.0, 0.3, 0.0, 0.0, 2);


Użytkownik Loe25 edytował ten post 05.08.2013 16:47

  • +
  • -
  • 0

POMAGAM PŁATNIE NA PROŚBĘ!


#25 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 13.08.2013 15:02

/perki, /klasy, /klasa nie dzialaja ;/


  • +
  • -
  • 0

#26 donaciak

    Godlike

  • Power User

Reputacja: 892
Czempion

  • Postów:2067
  • Steam:steam
  • Imię:Dawid
  • Lokalizacja:Kotlarka
Offline

Napisano 22.08.2013 08:19

Zamień:

        set_hudmessage(255, 255, 255, 0.6, -1.0, 0, 0.0, 0.3, 0.0, 0.0, 2);
Na, np:
        set_hudmessage(255, 255, 255, 0.02, 0.23, 0, 0.0, 0.3, 0.0, 0.0, 2);

I co to daje? NIC! Wystarczyć powinno wywalenie rejestrowanych eventów/forwardów w plugin_init których wyjściowa funkcja publiczna nie została dodana w kodzie


  • +
  • -
  • 0

#27 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 22.08.2013 09:14

Podmienialem biblioteke codmod, ale wyskakuje mi undefined symbol exp etc. -,-

Niech ktos mi sprawdzi include'a (klasa j.w.)

Załączone pliki


  • +
  • -
  • 0

#28 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 22.08.2013 14:01

Z RejetrujKlase wywalilem rejestarcje 4 statystyk i klasy/perki sie wlaczaja, ale:

1. w Menu PrzydzielPunkty nie ma notki o nauce ultra punktów, a powinno być

2. Moce nie działają


  • +
  • -
  • 0

#29 MAGNET

    SourceLearned ;)

  • Autor tematu
  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 01.09.2013 00:05

Można zamknąć


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych