Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
PHP

[ROZWIĄZANE] Zapisywanie kodu html do bazy sql

php

Najlepsza odpowiedź Leihto, 02.08.2013 23:18

@UP. :facepalm: Tak to jest jak PROgramista bierze sie do pomocy.. @topic. Skoro kodujesz stringa przez htmlspecialchars przed dodaniem do bazy, to może byś je zdekodował przed wyświetleniem? (htmlspecialchars_decode). Przejdź do postu


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 kijkol

    Profesjonalista

  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:173
  • Lokalizacja:Witów
Offline

Napisano 29.07.2013 17:46

Witam. 

Otóż mam taki problem gdy próbuję zapisać kod html do bazy sql to go nie chce odczytać prawidłowo pokazuje kod html, a nie jego wygląd.

SS:1s5yh9.jpg

 

Kod wysyłania do bazy:

Spoiler

 

Kod odczytywania:

Spoiler

Kodowanie w bazie utf8_polish_ci. Jak dam kod html wprost do bazy to go odczyta prawidło, ale nie czyta wtedy polskich znaków.

Z góry dzięki za pomoc.


Użytkownik kijkol edytował ten post 29.07.2013 17:48

  • +
  • -
  • 0

#2 PHP <3

    Banned

  • Zbanowany

Reputacja: 17
Początkujący

  • Postów:83
  • Imię:Piotrek
  • Lokalizacja:Lębork
Offline

Napisano 30.07.2013 07:44

Ustaw kodowanie uff-8 dla pliku .php + dla bazy latin2



#3 Leihto

    Wszechobecny

  • Użytkownik

Reputacja: 150
Profesjonalista

  • Postów:452
  • Lokalizacja:Rabka
Offline

Napisano 02.08.2013 23:18   Najlepsza odpowiedź

@UP. :facepalm: Tak to jest jak PROgramista bierze sie do pomocy.. @topic. Skoro kodujesz stringa przez htmlspecialchars przed dodaniem do bazy, to może byś je zdekodował przed wyświetleniem? (htmlspecialchars_decode).
  • +
  • -
  • 0
Portek: Za 20zł, to ja nawet notatnika nie otworze..

Nowe portfolio. Ciekawe artykuły, ciekawe przykłady: WojtusDEV.pl

#4 kijkol

    Profesjonalista

  • Autor tematu
  • Użytkownik

Reputacja: 31
Życzliwy

  • Postów:173
  • Lokalizacja:Witów
Offline

Napisano 03.08.2013 16:09

A usunąłem całkiem to specialchars i działa ;P


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: php

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych