Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AWP 1 ammo


Najlepsza odpowiedź Scorpion Flail , 14.07.2013 22:18

W Odrodzeniu próbowałem, ale nie do końca działało.

Teraz inaczej zrobiłem w curweapon: użyłem funkcji read_data, bo inaczej po przeładowaniu "zapominało" o poprzednim naboju i ładowało full.

Dodałem też taska i zmieniłem przeładowanie Cheq'a na to [zaczerpnięte z innego pluginu]:

if(weapon[id] == CSW_AWP && max_clip && awp_clip[id] >= max_clip)
    {
        set_uc(uc_handle,UC_Buttons,get_uc(uc_handle,UC_Buttons) & ~IN_RELOAD);
        return FMRES_HANDLED;
    }

Jak na razie wszystko działa, dzięki za naprowadzenie plusik :)

 

 

Przejdź do postu


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Scorpion Flail

    Wszechobecny

  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 13.07.2013 23:20

Witam.

Chciałbym się dowiedzieć jak poprawnie zrobić abym w AWP miał 1 ammo [i 0 w bp].

Chodzi mi o cos podobnego z gungame'a (potrzebne mi to do CoD Moda)

Robiłem w ten sposób:

if(klasa_gracza[id] == Nazwa && weapon == CSW_AWP)
    {
        cs_set_user_bpammo(id,CSW_AWP,0)
        set_user_clip(id, 1);

    }

Jednak to nie zdaje rezultatu.

Gdy wybieram klasę ma ona 10 ammo i 0 w bp, natomiast po oddaniu strzału ma 0 ammo, 0 w bp i nadal mogę strzelać.

 

Próbowałem również tego sposobu:

 

http://amxx.pl/topic...broni/?p=406146

Wydaje się być lepszy jednak ammo zerowane jest dopiero po przeładowaniu buttonem [na starcie jest standard: 10/30]

 

 

Liczę na pomoc...


Użytkownik scorpion flail edytował ten post 13.07.2013 23:20


#2 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 14.07.2013 12:16

Użyj cs_set_weapon_ammo.

 

Jeśli chwilę wcześniej dajesz graczowi broń, musisz odczekać aż faktycznie ją dostanie.


  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#3 Scorpion Flail

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 14.07.2013 14:00

Sprawdzanie czy gracz jest żywy załatwi sprawę?

 

Użyłem tego co podałeś, jednak nadal jest tak:

 

wchodzę, awp ma 10 kul i 0 w bp, jak strzele to robi się 0 i mogę ciągle strzelać na 0.

Gdy zmienie broń lub zrobię zoom to jest 1 ammo, ale jak go wystrzelę to on od razu się regeneruje bez przeładowania.

Kod wygląda tak:

if(is_user_alive(id) && klasa_gracza[id] == Nazwa && weapon == CSW_AWP)
	{
		new weapon_id = find_ent_by_owner(-1, "weapon_awp", id)
		if(weapon_id) //jeżeli znaleziono broń - byt ma inną wartość niż 0
		cs_set_user_bpammo(id,CSW_AWP,0)
		cs_set_weapon_ammo(weapon_id, 1) //ustaw broni ammo

	}


#4 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 14.07.2013 14:24

Ojj... nie chodzi tu o to, czy gracz jest żywy. Po pierwsze: gdzie dodajesz ten kod? Bo coś mi się wydaje, że sam właśnie odnawiasz graczowi amunicję, a powinieneś mu dawać amunicję tylko raz...

 

Po drugie, co do odczekania... chodziło mi o to, że między give_item, a pojawieniem się enta broni u gracza mija trochę czasu i musisz użyć set_task, aby w nim dopiero po ok 0.2s ustawić ilość amunicji.


  • +
  • -
  • 0
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#5 Scorpion Flail

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 14.07.2013 17:05

Kod ten dodaje w public CurWeapon(id)

Mogłbyś napisać mi tego taska?



#6 GwynBleidD

    Godlike

  • Administrator

Reputacja: 1849
Godlike

  • Postów:3066
  • Steam:steam
  • Lokalizacja:Przemyśl
Offline

Napisano 14.07.2013 17:55

I bardzo źle, że go tam dajesz. Przez to po każdym strzale gracz będzie dostawał ammo!


  • +
  • -
  • 1
NIE pomagam na PW. Nie trudź się, na zlecenia nie odpiszę... Od pomagania jest forum.
NIE zaglądam w tematy wysłane na PW. Jeśli są na forum to prędzej czy później je przeczytam. Jeśli mam co w nich odpisać, to odpiszę.
 
1988650.png?theme=dark

#7 Scorpion Flail

    Wszechobecny

  • Autor tematu
  • Zbanowany

Reputacja: 122
Zaawansowany

  • Postów:469
  • GG:
  • Imię:Krystian
  • Lokalizacja:Grudziądz
Offline

Napisano 14.07.2013 22:18   Najlepsza odpowiedź

W Odrodzeniu próbowałem, ale nie do końca działało.

Teraz inaczej zrobiłem w curweapon: użyłem funkcji read_data, bo inaczej po przeładowaniu "zapominało" o poprzednim naboju i ładowało full.

Dodałem też taska i zmieniłem przeładowanie Cheq'a na to [zaczerpnięte z innego pluginu]:

if(weapon[id] == CSW_AWP && max_clip && awp_clip[id] >= max_clip)
    {
        set_uc(uc_handle,UC_Buttons,get_uc(uc_handle,UC_Buttons) & ~IN_RELOAD);
        return FMRES_HANDLED;
    }

Jak na razie wszystko działa, dzięki za naprowadzenie plusik :)

 

 






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych