Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie tworzy tabeli


Najlepsza odpowiedź Indoor, 10.07.2013 19:19

ehh Znowu niemam "Edytuj",zmieniłem "new q_command[2000]" na "new q_command[3000]" i działa. Przejdź do postu


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 Indoor

    Zaawansowany

  • Użytkownik

Reputacja: 19
Początkujący

  • Postów:114
  • Lokalizacja:Gorzów Wielkopolski City.
Offline

Napisano 09.07.2013 18:45

Siemka,mam problem z DiabloModem niechce tworzyć Tabeli w konsoli pojawia się cały czas napisa "Table Query Failed" Kod tworzenia tabeli:
iLen += formatex(q_command,charsmax( q_command ),"CREATE TABLE IF NOT EXISTS `%s` (`nick` VARCHAR(48), `ip` VARCHAR(32), `sid` VARCHAR(32), `klasa` INT(2), `lvl` INT(3) DEFAULT 1, `exp` INT(9) DEFAULT 0", g_sqlTable)
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`str` INT(3) DEFAULT 0,`int` INT(3) DEFAULT 0,`dex` INT(3) DEFAULT 0,`agi` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`gra` INT(3) DEFAULT 0,`mon` INT(3) DEFAULT 0,`inv` INT(3) DEFAULT 0,`arm` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`reg` INT(3) DEFAULT 0,`man` INT(3) DEFAULT 0,`zlo` INT(3) DEFAULT 0,`mikp` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`mikpp` INT(3) DEFAULT 0,`orlice` INT(3) DEFAULT 0,`cain` INT(3) DEFAULT 0,`hrabina` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`m4` INT(3) DEFAULT 0,`andariele` INT(3) DEFAULT 0,`radament` INT(3) DEFAULT 0,`glock` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`bestie` INT(3) DEFAULT 0,`ak-47` INT(3) DEFAULT 0,`demonolog` INT(3) DEFAULT 0,`duriel` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`figurka` INT(3) DEFAULT 0,`gidbinn` INT(3) DEFAULT 0,`mp5` INT(3) DEFAULT 0,`ksiega` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`wyand` INT(3) DEFAULT 0,`mefisto` INT(3) DEFAULT 0,`izual` INT(3) DEFAULT 0,`kamien` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`diablo` INT(3) DEFAULT 0,`nadzorca` INT(3) DEFAULT 0,`pbestie` INT(3) DEFAULT 0,`nihlathak` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,",`talic` INT(3) DEFAULT 0,`hosty` INT(3) DEFAULT 0,`koniec` INT(3) DEFAULT 0,`ktoryq` INT(3) DEFAULT 0,`ileq` INT(3) DEFAULT 0")
	iLen += formatex(q_command[ iLen ],charsmax( q_command ) - iLen,") DEFAULT CHARSET `utf8` COLLATE `utf8_general_ci`")

  • +
  • -
  • 0

#2 BlackPerfum

    Pseudo interakcja??

  • Power User

Reputacja: 453
Wszechobecny

  • Postów:575
  • Lokalizacja:...
Offline

Napisano 10.07.2013 17:27

Z zapytaniem wszystko w porządku sprawdź także z jego zapisem. W czym błąd ? Jaką wielkość ma tablica q_command?? musi mieć co najmniej 1250+długość nazwy tabeli. Dla pewności wyzeruj zmienną iLen po jej stworzeniu. 


  • +
  • -
  • 1
Chcesz napisać do mnie na PW to:
Spoiler

Mój tok myślenia jest błędny? Wskaż mi błąd zmienie to!

Aktualnie bije limit 32 graczy (łącze serwery) ale nadal są lagi przy zbyt dużym przesyłu informacji Dołączona grafika
Gra się płynnie do 40~50 graczy potem łącze pada i zamiast biegać ludzie się teleportują Dołączona grafika

#3 Indoor

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 19
Początkujący

  • Postów:114
  • Lokalizacja:Gorzów Wielkopolski City.
Offline

Napisano 10.07.2013 18:46

Mam tak:
new q_command[2000],iLen = 0;
I nadal to samo :/
  • +
  • -
  • 0

#4 Indoor

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 19
Początkujący

  • Postów:114
  • Lokalizacja:Gorzów Wielkopolski City.
Offline

Napisano 10.07.2013 19:19   Najlepsza odpowiedź

ehh Znowu niemam "Edytuj",zmieniłem "new q_command[2000]" na "new q_command[3000]" i działa.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych