Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

GM AmxBans 1.6 :: Problem z wczytywaniem adminów z users.ini oraz sql


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
7 odpowiedzi w tym temacie

#1 Lichy12

    Początkujący

  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:15
  • Lokalizacja:Sucha Beskidzka
Offline

Napisano 05.04.2013 10:01

Witam, po zainstalowaniu na serwer gmamxbansa 1.6 z poprawkami na początku miałem problem gdyż nie chciał znaleść serwera, no ale już sobie poradziłem, następnym problemem było banowanie, niby ban był na stronie, ale użytkownik mógł wejść bez problemu - także sobie poradziłem, niestety, ale ostatnim problemem, który muszę opisać w tym temacie jest (jak w temacie) problem z czytaniem adminów ze strony www, mianowicie po ustawieniu adminowi uprawnień i flag na SID nie czyta go na serwerze, z users.ini też nie czyta, teraz powiem co dokładnie zrobiłem:

A więc, zainstalowałem gmamxbansa po stronie forum jak i serwera - > ustawiłem chmody na wymagane katalogi, odpaliłem instalacje gdzie wpisałem dane z wcześniej utworzonej bazy danych (na stronie podczas instalacji jedynie co hosta zostawiłem standardowego 127.... bo baza siedzi na proserwer strona też, instalacja przebiegła bez problemów możliwe było połączenie do bazy danych, następnym krokiem była instalacja po stronie serwera, tak więc pluginy wgrałem do plugins i dopisałem :

; Admin Base - Always one has to be activated


debug amxbans_core.amxx
debug amxbans_main.amxx
;admin.amxx ; admin base (required for any admin-related)
admin_sql.amxx ; admin base - SQL version (comment

reszta plików wgrana poprawnie.

W amxbans.cfg
amxbans_server_address "wpisałem IP:port"

// Wczytywanie adminów
// 0 z bazy SQL, 1 = z pliku users.ini, 2 = nie ładuje adminów
amxbans_use_admins_file 0


Na ustawieniu cvara na "0" nie wczytuje, z users.ini tak, mimo, że admin jest dodany na stronce i w pliku users.ini

modules.ini

mysql
;sqlite
fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx


Error logi (jedyne na jakie natrafiłem, daję z dzisiaj bo reszta się powtarza)

Spoiler

PO DOPISANIU PRZED OBA PLUGINY debug plugin.amxx
Spoiler

WERSJA GMAMXBANS 1.6.1 + poprawki

Czyta tego amxbansa jakby...
Spoiler

W razie pytań/sugestii proszę o wypowiadanie się - dam karmę.@@EDIT1: Nie wiem czy tylko ja mam problem na tym forum otworzyć spoilery, ale jeśli nie, to proszę dać znać.

Użytkownik Lichy12 edytował ten post 05.04.2013 10:08

  • +
  • -
  • 0

#2 Roller7

    Pomocny

  • Zbanowany

Reputacja: 9
Nowy

  • Postów:52
  • GG:
  • Imię:Radziu
  • Lokalizacja:Turek
Offline

Napisano 05.04.2013 10:17

Źle debug dopisany.
np. plugin.amxx debug - tak jak w przykładzie się dopisuje "debug"

Spoilery działają.

W modules.ini odblokuj na wszelki wypadek moduł "sqlite",.

#3 Lichy12

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:15
  • Lokalizacja:Sucha Beskidzka
Offline

Napisano 05.04.2013 10:22

Dziękuję za info -> karma poleciała niestety nadal po wejściu na serwer i próbie otwarcia "amxmodmenu" wyskakuje informacja "brak uprawnień"

w users.ini


"STEAM_0:1:39023318" "abcdefghijklmnopqrstu" "ce"
  • +
  • -
  • 0

#4 Brylant

    Zaawansowany

  • Użytkownik

Reputacja: 26
Życzliwy

  • Postów:111
  • GG:
  • Imię:Mateusz
  • Lokalizacja:Przemyśl
Offline

Napisano 05.04.2013 10:33

Zjadłeś
""
pomiędzy SteamID a flagami

Popraw na:

"STEAM_0:1:39023318" "" "abcdefghijklmnopqrstu" "ce"

I zobacz czy działa.
  • +
  • -
  • 1

"Nigdy nie rozmawiaj z idiotą. Najpierw sprowadzi Cię do swojego poziomu, a potem pokona doświadczeniem"


#5 Lichy12

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:15
  • Lokalizacja:Sucha Beskidzka
Offline

Napisano 05.04.2013 10:45

Cholera, takie podstawowe błędy ;) dziękuję za odpowiedź karma poleciała przy okazji skoro problem został rozwiązany i czyta z users.ini pojawił się następny mianowicie przy ustawieniu w amxbans.cfg czytania z sql nie czyta administratorów wyskakuje komunikat "brak uprawnień"
sql.cfg po stronie serwera
Spoiler

Przypomnę tylko, że podczas instalacji na stronie nie zmieniałem hosta (baza i strona na proserwer.pl)
w server.cfg na samym dole wpisałem "ip:serwera"
OSTATNIE LOGI
Spoiler




Skoro już ktoś wyraża chęć pomocy to opiszę drugi problem :przy pluginie VIP
http://amxx.pl/topic...-vip-plugin-34/

Posiadam wszystkie flagi na steam id, admina czyta, ale vipa już nie - po wpisaniu vips nie wyświetla mojego vipa do plugins ini dopisałem vip.amxx i umieściłem pliki w odpowiednie miejsca.

Użytkownik Lichy12 edytował ten post 05.04.2013 10:47

  • +
  • -
  • 0

#6 Roller7

    Pomocny

  • Zbanowany

Reputacja: 9
Nowy

  • Postów:52
  • GG:
  • Imię:Radziu
  • Lokalizacja:Turek
Offline

Napisano 05.04.2013 10:54

Cvary od vipa pamiętałes by dopisać ?

#7 Lichy12

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:15
  • Lokalizacja:Sucha Beskidzka
Offline

Napisano 05.04.2013 10:56

W amxx.cfg plugin vipa czyta, bo /vip /vips działają ale nie czyta vipów.

//VIP//
money_kill_bonus 500    // Ile kasy dostanie VIP za kill'a
money_hs_bonus 300     // Ile kasy dostanie Vip za HeadShot'a
amx_vip_hp 15            // Ile dostanie Vip HP za killa
amx_vip_hp_hs 30         // Ile dostanie HP Vip za headshota
amx_vip_max_hp 130 // Ile VIP może mieć max. hp
vip_active 0     // 0 = każdy może mieć awp, 1 = tylko vip
menu_active 1    // 0 = Nie ma menu na początku rundy z darmowymi M4+Dgl lub AK47+DGL, 1 = Jest to menu

@EDIT: Przypomnę, że problem z czytaniem adminów z sql nadal jest, users.ini jest okej, ale sql pomimo dodania ich na stronie nie działają.

Użytkownik Lichy12 edytował ten post 05.04.2013 11:02

  • +
  • -
  • 0

#8 Lichy12

    Początkujący

  • Autor tematu
  • Użytkownik

Reputacja: -2
Mniej niż zer0.

  • Postów:15
  • Lokalizacja:Sucha Beskidzka
Offline

Napisano 05.04.2013 12:33

Z góry przepraszam za double posta ale VIP już działa, został problem tylko z czytaniem adminów z sqla
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych