Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Darmowe VIPy - zbugowany VIP generator?


  • Zamknięty Temat jest zamknięty
56 odpowiedzi w tym temacie

#1 `Sernik

    `Profesjonalista !

  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 18:09

Witam,
mam problem który od 3 miesięcy nie daje mi spokoju i pomału już nie wytrzymuje...Wygenerowałem sobie VIPa w Generatorze z amxx.pl .wszystko pięknie działa, aż tu nagle widze, że na serwerze losowo wybrane osoby dostają VIPa. Problem był już drugiego dnia jednak omijałem to komendą amx_reloadadmins i kickiem danego gracza z serwera, jednak ostatnio nawet to nie pomaga...Plugin VIPa był edytowany ręcznie jednak mam 101% pewność, ze to nie miało wpływu na ten błąd gdyż występuje od zawsze.


Info:
-Mam GM Amxbans 1.5.1, a WEB chyba 1.6
-Błąd jest na serwerze Paintball
-.sma VIPa (daje z wklej.org gdyż wklejane przeze mnie kody są mało czytelne):

http://wklej.org/hash/1aa85b38c4b/

Już po prostu nie wyrobiłem i musiałem napisać na forum amxx, bo chyba tylko tu jest w stanie mi ktoś pomóc..Znalazłem gdzieś kiedyś tematy z tym samym błędem, ale była cisza i brak odpowiedzi rozwiązującej..tydzień później tematy zostały usunięte chyba..Trochę tego nie rozumiem, ale nie chce wyciągać błędnych wniosków..

Proszę o pomoc

Trzeba wiecej informacji mogę podać

Pozdrawiam!
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#2 Ciastkowy (:

    Życzliwy

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:24
  • Imię:Kamil
  • Lokalizacja:Jastrzębie-Zdrój
Offline

Napisano 31.03.2013 18:56

Nie pierwszy raz spotykam się właśnie z takim problemem VIPów zrobionych przez Generator z tego serwisu, więc z całą pewnością nie jest to wina tylko Twoich poprawek. Ja osobiście proponowałbym Ci napisać własny plugin VIPa według poradników (a jest ich multum) albo przerobić jakiś istniejący. Z całą pewnością wyszłoby Ci to na lepsze i może zaowocowało w przyszłosci.
  • +
  • -
  • 0

#3 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 31.03.2013 19:03

Wina kodu vipa oraz po części amxbansa. Zapewne flagi gracza nie są zerowane przy wychodzeniu, a w vipie jest forward "client_authorized", który wykonuje się wcześniej niż przypisanie flag dla gracza przez amxbans. Miałem już o tym gdzieś pisać, ale jakoś wyszło mi z głowy.

Wywal z kodu
public amxbans_admin_connect(id){
client_authorized(id);
}

i zamiast "client_authorized" daj "amxbans_admin_connect".
  • +
  • -
  • 2
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#4 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:15

@up
Nie rozumiem co i gdzie mam wstawić, mógłbym dokładniej gdzie mam wstawić "amxbans_admin_connect"..Bo chyba nie luzem do kodu..




Nie pierwszy raz spotykam się właśnie z takim problemem VIPów zrobionych przez Generator z tego serwisu, więc z całą pewnością nie jest to wina tylko Twoich poprawek. Ja osobiście proponowałbym Ci napisać własny plugin VIPa według poradników (a jest ich multum) albo przerobić jakiś istniejący. Z całą pewnością wyszłoby Ci to na lepsze i może zaowocowało w przyszłosci.


Samodzielne napisanie pluginu VIPa byłoby dla mnie istną mordęgą. Dość się już namęczyłem, a sądze że na pewno nie ma wszystkich poradników jakie bym potrzebował ;)

Użytkownik sernikkk edytował ten post 31.03.2013 19:18

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#5 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:19

usuń ten public co podał sebul i zamiast public client_authorized(id) daj amxbans_admin_connect(id) - Tak to ja interpretuje

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#6 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:21

tam nie ma public client_authorized tylko samo client_authorized
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#7 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:23

To zamień. Poprostu jest to internalna funkcja.

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#8 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:26

Wkleiłem, skompilowałem i Warning, że symbol nie jest używany..Inaczej to trzeba..Czekam aż sebul odpowie


new damage=read_data(2);

if(g_Vip[id]){
set_hudmessage(255, 0, 0, 0.45, 0.50, 2, 0.1, 4.0, 0.1, 0.1, -1);
ShowSyncHudMsg(id, g_Hudmsg, "%i^n", damage);
}
if(is_user_connected(attacker) && g_Vip[attacker]){
set_hudmessage(0, 100, 200, -1.0, 0.55, 2, 0.1, 4.0, 0.02, 0.02, -1);
ShowSyncHudMsg(attacker, g_Hudmsg, "%i^n", damage);
}
}
amxbans_admin_connect(id)

Użytkownik sernikkk edytował ten post 31.03.2013 19:27

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#9 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:29

Który symbol nie jest używany ?

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#10 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:32

No ten:

amxbans_admin_connect(id)

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#11 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:34

Daj cały log erroru.

Prawdopodobnie źle dałeś klamry, bądź ich brak.

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#12 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:38

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2006 ITB CompuPhase, AMX Mod X Team

vip.sma(231) : warning 203: symbol is never used: "amxbans_admin_connect"
Header size: 2052 bytes
Code size: 9328 bytes
Data size: 2904 bytes
Stack/heap size: 16384 bytes; max. usage is unknown, due to recursion
Total requirements: 30668 bytes

1 Warning.
Done.

klamry dałem tak:

amxbans_admin_connect(id){
}

Nie wiem jak je dodać...
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#13 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:41

Jeżeli to nie jet używane to możesz wywalić. Lepiej gdyby sebul się wypowiedział, bo mogę źle mówić

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#14 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:43

Ta linijka jest dodawana jak w Generatorze VIPa zaznacze "Integracja z (GM)Amxbans 1.6"


Chwila..Właśnie włączyłem myślenie... Może błąd wyskakuje dlatego, ze mam AMXBANS 1.5.1, a tylko WEB 1.6 ?
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#15 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 19:47

Nie mam pojęcia. Nie używałem i nie używam amxbans :P

Ale skoro masz 2 różne wersje, to możę zrobić 2 te same wersję i dopiero zobaczyć czy będzie występować błąd ?

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#16 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 19:52

Patrick, poczytaj o tym ile błędów jest z tymi wersjami...Zaleca się mieszankę.. Pisał o tym Szyfrant w jakimś poradniku.
  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#17 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 31.03.2013 20:33

OMG...
Wywal to co napisałem i po prostu podmień nazwę funkcji "client_authorized" na "amxbans_admin_connect".
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#18 GT Team

    Ten lepszy xD

  • Zbanowany

Reputacja: 321
Wszechpomocny

  • Postów:1435
  • GG:
  • Imię:Tomasz i Grzegorz
  • Lokalizacja:Wojkowice
Offline

Napisano 31.03.2013 20:34

Edit:

Czyli to samo co ja mu pisałem.

heheh

Użytkownik PaTrIcKx edytował ten post 31.03.2013 20:38

Nowa wersja Tower Defense 0.2 Alpha | Inne Mody -> Nowości

 


#19 `Sernik

    `Profesjonalista !

  • Autor tematu
  • Użytkownik

Reputacja: 36
Życzliwy

  • Postów:269
  • Imię:Ernest
  • Lokalizacja:Warszawa
Offline

Napisano 31.03.2013 21:33

Dobrze Teraz załapałem :)

zamieniłem skompilowało się i będę sprawdzać czy to nadal będzie występować..

Proszę o nie zamykanie tematu jeszcze przez tydzień odezwe się z rezultatami.

dzięki wszystkim, plusiczki

@EDIT

Odświeżam, problem wystąpił od razu.....Znowu osoba która grała jakis czas temu dostałą nagle VIPa..proszę o dalsze porady

Użytkownik sernikkk edytował ten post 31.03.2013 21:34

  • +
  • -
  • 0
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.67:27145
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.43:27015
b_350_20_FFAD41_E98100_000000_591F11.png 193.33.176.66:27035

#20 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.04.2013 02:32

Czyli trzeba edytować pliki amxbansa lub problem tkwi w "if(get_user_flags(id) & 524288 == 524288)", bo jak dobrze pamiętam kiedyś używałem podobnego warunku i chyba coś było z nim nie tak. Dobrze by było dokładnie przetestować tą opcję z posiadaniem wszystkich wskazanych flag.
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych