Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z połączeniem do DB


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Onwed

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:Ostrowiec
Offline

Napisano 21.05.2009 12:42

Witem chodzi oto że mam db na db4free.net, dane wpisuje dobrze;
postępuje zgodnie z tym poradnikiem Konfiguracia SQL'a do DM
i gdy wbijam na serva niema klasy a w logach:
L 05/21/2009 - 07:50:05: 05/21/2009 - 07:50:05 ### MAPA: cs_assault ### 
L 05/21/2009 - 07:50:23: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:23: Could not connect to SQL database.
L 05/21/2009 - 07:50:24: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:24: Could not connect to SQL database.
L 05/21/2009 - 07:50:30: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:30: Could not connect to SQL database.
L 05/21/2009 - 07:50:31: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:31: Could not connect to SQL database.
L 05/21/2009 - 07:50:33: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:33: Could not connect to SQL database.
L 05/21/2009 - 07:50:34: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 05/21/2009 - 07:50:34: Could not connect to SQL database.
L 05/21/2009 - 07:51:31: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
Gdy wpisze hosta z konosli z amx'a nie wbija.
To wyskakuje w logach to:
L 05/21/2009 - 07:51:31: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:31: Could not connect to SQL database.
L 05/21/2009 - 07:51:31: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:31: Could not connect to SQL database.
L 05/21/2009 - 07:51:33: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:33: Could not connect to SQL database.
L 05/21/2009 - 07:51:33: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:33: Could not connect to SQL database.
L 05/21/2009 - 07:51:34: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:34: Could not connect to SQL database.
L 05/21/2009 - 07:51:34: Error on Table query: Access denied for user 'owned'@'87.204.126.184' (using password: YES)
L 05/21/2009 - 07:51:34: Could not connect to SQL database.

AMX V: 1.8.1 build 38xx
Wersja diablo: próbowałem na 2 5.8a i 5.9l
Modules.ini:
;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
cstrike
csx
;hamsandwich

Może mi ktoś napisać co mam wpisać i gdzie gdy mam hostem db4free.net z userem Owned i hasłem ***** z cyfer
  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 21.05.2009 13:07

Onwed, mimo wszystko podales zle dane lub nie dosc dokladnie (czyt. zle dane).

Poza tym:
;engine
;fakemeta

Te moduly sa uzywane w diablo, wiec mozesz je odblokowac ;)

Co do:

mysql
sqlite

nie znam dokladnych specyfikacji amxx'a, ale zdecyduj sie na 1 (obojetnie, np. mysql).
  • +
  • -
  • 0

#3 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 21.05.2009 15:31

Kolejny temat z cyklu "jak podpiąć diablomoda pod baze danych"... W panelu administracji serwerem www (cPanel lub DirectAdmin) jest takie coś jak "Dostęp do bazy danych" czy to w DA czy w cP, wchodzisz tam i jako host dostępu dodajesz %, co powoduje że każde IP ma dostęp do bazy więc żadnych problemów z połączeniem nie ma... Druga sprawa do czego odwołuje się IP: 87.204.126.184? Nie jest to bynajmniej serwer WWW, ani serwer gier, prywatne IP?
diablo_sql_host "db4free.net"
diablo_sql_user "owned"
diablo_sql_pass "****"
diablo_sql_database "owned"
diablo_sql_table "diablo"
Oczywiście host jest zależny od wersji bazy danych w db4free.net, nowa ma port 3307, więc musisz wpisać wtedy: db4free.net:3307
  • +
  • -
  • 0

Dołączona grafika
IP: ts3.cserwerek.pl


#4 Onwed

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:Ostrowiec
Offline

Napisano 22.05.2009 10:55

Dane 100% dobre, 87. - moje prywatne IP serwer testowy na moim kompie, zanim wgram na prawdziwym. Ale to niema różnicy czy serverowe IP czy moje. Przy rejestracji podałem % więc to nie wina tego. Co do modules: też nic nie dały... na razie sprawa nie rozwiązana

Edit: Co do db4free.net Gdy się rejestrujesz 1 raz dostajesz bazę z portem 3307 a gdy 2 raz na ten sam e-mail to masz bazę z 3306 i 3307. A i z portem 3307 też próbowałem.
  • +
  • -
  • 0

#5 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 22.05.2009 11:04

Onwed, zdradzic ci tajemnice? Przy dobrych danych mozna nawiazac polaczenie :lol:

Czy usera masz z duzej litery, czy tak jak podal ci Portek?
  • +
  • -
  • 0

#6 Onwed

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:Ostrowiec
Offline

Napisano 22.05.2009 13:12

Próbowałem Owned , owned i OWNED i nic
  • +
  • -
  • 0

#7 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 22.05.2009 13:39

Onwed, jesli chcesz mozesz wyslac na PW dane i przetestuje je.
  • +
  • -
  • 0

#8 Onwed

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
  • Lokalizacja:Ostrowiec
Offline

Napisano 22.05.2009 13:55

Wysłane sprawdź i odpisz
  • +
  • -
  • 0

#9 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 22.05.2009 14:57

Problem zalatwiony.

Winny byl firewall, trzeba bylo odblokowac port 3306 dla bazy sql.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych