Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

błąd "set_user_rendering" oraz "get_pdata_cbase"Liczę na waszą pomoc, z góry dziękuję

cod nowy

  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 Miły

    Banned

  • Zbanowany

Reputacja: 4
Nowy

  • Postów:82
  • Lokalizacja:Heaven
Offline

Napisano 23.03.2013 18:38

Posiadam w logach błędy których nie potrafię naprawić, więc proszę was o pomoc :wstyd:



SILNIK COD MOD

L 03/23/2013 - 17:41:41: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/23/2013 - 17:41:41: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 03/23/2013 - 17:41:41: [AMXX] [0] QTM_CodMod.sma::CmdStart (line 317)
L 03/23/2013 - 17:41:41: [FUN] Invalid player 8
L 03/23/2013 - 17:41:41: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/23/2013 - 17:41:41: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 03/23/2013 - 17:41:41: [AMXX] [0] QTM_CodMod.sma::CmdStart (line 317)
L 03/23/2013 - 17:41:41: [FUN] Invalid player 8
L 03/23/2013 - 17:41:41: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/23/2013 - 17:41:41: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 03/23/2013 - 17:41:41: [AMXX] [0] QTM_CodMod.sma::CmdStart (line 317)
L 03/23/2013 - 17:41:41: [FUN] Invalid player 8
L 03/23/2013 - 17:41:41: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/23/2013 - 17:41:41: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 03/23/2013 - 17:41:41: [AMXX] [0] QTM_CodMod.sma::CmdStart (line 317)
L 03/23/2013 - 17:41:41: [FUN] Invalid player 8
L 03/23/2013 - 17:41:41: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 03/23/2013 - 17:41:41: [AMXX] Run time error 10: native error (native "set_user_rendering")
L 03/23/2013 - 17:41:41: [AMXX] [0] QTM_CodMod.sma::CmdStart (line 317)
L 03/23/2013 - 17:42:16: [HAMSANDWICH] Entity out of range (-1194784728)


KLASA INŻYNIER:

L 03/23/2013 - 17:42:16: [AMXX] Displaying debug trace (plugin "codclass_Inzynier.amxx")
L 03/23/2013 - 17:42:16: [AMXX] Run time error 10: native error (native "get_pdata_cbase")
L 03/23/2013 - 17:42:16: [AMXX] [0] codclass_Inzynier.sma::ham_ItemDeploy_Post (line 243)
L 03/23/2013 - 17:42:21: [HAMSANDWICH] Entity out of range (-1194784728)
L 03/23/2013 - 17:42:21: [AMXX] Displaying debug trace (plugin "codclass_Inzynier.amxx")
L 03/23/2013 - 17:42:21: [AMXX] Run time error 10: native error (native "get_pdata_cbase")
L 03/23/2013 - 17:42:21: [AMXX] [0] codclass_Inzynier.sma::ham_ItemDeploy_Post (line 243)
L 03/23/2013 - 17:42:29: [HAMSANDWICH] Entity out of range (-1194784728)
L 03/23/2013 - 17:42:29: [AMXX] Displaying debug trace (plugin "codclass_Inzynier.amxx")
L 03/23/2013 - 17:42:29: [AMXX] Run time error 10: native error (native "get_pdata_cbase")
L 03/23/2013 - 17:42:29: [AMXX] [0] codclass_Inzynier.sma::ham_ItemDeploy_Post (line 243)
L 03/23/2013 - 17:47:22: [HAMSANDWICH] Entity out of range (-403393553)
L 03/23/2013 - 17:47:22: [AMXX] Displaying debug trace (plugin "codclass_Inzynier.amxx")
L 03/23/2013 - 17:47:22: [AMXX] Run time error 10: native error (native "get_pdata_cbase")
L 03/23/2013 - 17:47:22: [AMXX] [0] codclass_Inzynier.sma::ham_ItemDeploy_Post (line 243)
L 03/23/2013 - 17:47:26: [HAMSANDWICH] Entity out of range (-1)
L 03/23/2013 - 17:47:26: [AMXX] Displaying debug trace (plugin "codclass_Inzynier.amxx")
L 03/23/2013 - 17:47:26: [AMXX] Run time error 10: native error (native "get_pdata_cbase")
L 03/23/2013 - 17:47:26: [AMXX] [0] codclass_Inzynier.sma::ham_ItemDeploy_Post (line 243)

Załączone pliki


Użytkownik Mysterious edytował ten post 23.03.2013 18:39

Darmowe Filmy Online: http://zalukaj.tv/polecony,1974765/ Warto za lukać, duży wybór ^D^ (Nie wymaga kupna Premium, by oglądać Filmy)

 


#2 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 23.03.2013 21:48

Silnik:
Przed set_user_rendering sprawdź czy gracz jest połączony.

Klasa:
Dodaj warunek przed get_pdata_cbase:
if(!is_valid_ent(ent))
return;
W ent daj nazwę rzeczy której dotyczy get_pdata_cbase
  • +
  • -
  • 0

#3 Miły

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 4
Nowy

  • Postów:82
  • Lokalizacja:Heaven
Offline

Napisano 23.03.2013 22:36

U lala... nie bardzo rozumiem co mam zrobić

Darmowe Filmy Online: http://zalukaj.tv/polecony,1974765/ Warto za lukać, duży wybór ^D^ (Nie wymaga kupna Premium, by oglądać Filmy)

 


#4 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 23.03.2013 22:40

Silnik:
Otwórz sma.
Znajdź linijkę gdzie jest błąd.
Powinno tam być set_user_rendering.
Wstaw przed to:
if(!is_user_connected(id))
return;
Skompiluj plik.
Wrzuć na serwer.

Analogicznie do tego napraw drugi plugin, tyle że wklej zamiast :
if(!is_user_connected(id))
return;
to:
if(!is_valid_ent(ent))
return;

  • +
  • -
  • 0

#5 Miły

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 4
Nowy

  • Postów:82
  • Lokalizacja:Heaven
Offline

Napisano 24.03.2013 11:54

Coś nie wychodzi za dobrze:

Welcome to the AMX Mod X 1.8.1-300 Compiler.
Copyright (c) 1997-2013 ITB CompuPhase, AMX Mod X Team

Warning: Function "CmdStart" should return a value on line 318
Error: Function uses both "return" and "return <value>" on line 322
Error: Function uses both "return" and "return <value>" on line 330

2 Errors.
Could not locate output file D:\Documents and Settings\Pulpit\Nowy folder (2)\QTM_CodMod.amx (compile failed).

Darmowe Filmy Online: http://zalukaj.tv/polecony,1974765/ Warto za lukać, duży wybór ^D^ (Nie wymaga kupna Premium, by oglądać Filmy)

 


#6 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 24.03.2013 17:30

To tam w silniku zamiast
if(!is_user_connected(id))
return;
daj:
if(!is_user_connected(id))
return FMRES_IGNORED;
Nie spojrzałem w kod i się pomyliłem.
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych