Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Klasa lub perk - buguje niewidzialność

cod nowy

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
7 odpowiedzi w tym temacie

#1 ente

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:wawa
Offline

Napisano 05.03.2013 22:07

Witam, chciałbym poprosić o pomoc. Mianowicie chodzi o moją klasę, jest to szpieg przerobiłem go tak aby miał strój wroga, niewidzialność 12 sek na prawym przycisku i podczas strzelania nadal jest niewidzialny.
Nie wiem czy to przez to ale ostatnio na serwerze nie działają perki związane z niewidzialnością, czy widzi tu ktoś jakiś błąd tutaj?
I jak ktoś go znalazł, prosiłbym o naprawienie i żeby już nie było problemów z perkami
Proszę nie zmieniać możliwości klasy :)
Pozdrawiam

EDIT :
Dodaję jeszcze 2 perki z niewidzialnością, które ostatnio wgrałem .

Prosiłbym i o ich sprawdzenie i edycję, jeśli to potrzebne.

Załączone pliki


Użytkownik ente edytował ten post 05.03.2013 22:21

  • +
  • -
  • 0

#2 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 06.03.2013 16:06

Lakeshit.
public client_PreThink ( id ) 
{ 
new button2 = get_user_button(id);

//USE Button actives forward\backward\left\right

if (ma_perk[id] && get_entity_flags(id) & FL_ONGROUND && (!(button2 & (IN_FORWARD+IN_BACK+IN_MOVELEFT+IN_MOVERIGHT)) && is_user_alive(id)))
{
set_rendering(id,kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 9);
}
else set_rendering(id,kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);

///////////////////////////////////////////////////

return PLUGIN_CONTINUE 
}
Zamień na
public client_PreThink ( id ) 
{ 
if(!ma_perk[id])
return PLUGIN_CONTINUE;

new button2 = get_user_button(id);

if(get_entity_flags(id) & FL_ONGROUND && (!(button2 & (IN_FORWARD+IN_BACK+IN_MOVELEFT+IN_MOVERIGHT)) && is_user_alive(id)))
{
set_rendering(id,kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 9);
}
else set_rendering(id,kRenderFxNone, 0, 0, 0, kRenderTransAlpha, 255);

return PLUGIN_CONTINUE 
}

  • +
  • -
  • 1

#3 ente

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:wawa
Offline

Napisano 06.03.2013 20:59

A mógłbyś coś zrobić z Partyzantem ? Bo mi miga HUD jak nim gram
  • +
  • -
  • 0

#4 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 07.03.2013 13:57

Skasuj u niego hud... Tyle.

Załączone pliki


  • +
  • -
  • 0

#5 ente

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:wawa
Offline

Napisano 07.03.2013 17:33

No tak, ale musi być wiadome ile czasu się ładuje niewidzialność, ile sekund zostało... Więc jak to usunę, to na ślepo...
  • +
  • -
  • 0

#6 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 07.03.2013 21:33

Zrobiłem, że w czasie działania masz lekką niebieską poświatę. HUD powinien nie migać.

Załączone pliki


  • +
  • -
  • 1

#7 ente

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:9
  • Lokalizacja:wawa
Offline

Napisano 08.03.2013 16:48

Przy kompilacji błąd mam
  • +
  • -
  • 0

#8 Vasto_Lorde

    Cham

  • Power User

Reputacja: 252
Wszechwidzący

  • Postów:620
  • GG:
  • Steam:steam
  • Imię:Maćko
  • Lokalizacja:Poznań
Offline

Napisano 08.03.2013 19:24

Proszę.

Załączone pliki


  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: cod nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych