Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

AMXBANS - problem nie łączy?


  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 Zgadnij

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 14.05.2008 16:27

WItam,

Mam problem z amxbans.


Access to a MySQL Database. (Version 4.1 and later is recommended)
Website with PHP (magic_quotes_gpc must be ON and short_open_tag = On)
Oba są (mysql 5)

Mam odblokowany moduł mysql

;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
;geoip
;sockets
;regex
nvault
cstrike
csx
xstats
netdb

plugins.ini

; Admin Base - Always one has to be activated
;admin.amxx    ; admin base (Loading admins from the file users.ini)
;admin_sql.amxx    ; SQL version (Loading admins from mysql DB)
admin_amxbans.amxx    ; AmxBans own SQL version of admin_sql
amxbans.amxx 

sql.cfg

amx_mysql_host  "87.121.25.3"
amx_mysql_user  "guess"
amx_mysql_pass  "passuord"
amx_mysql_db    "lolex"
amx_sql_table     "admins" 
amx_sql_type     "mysql"

amxbans.cfg (orginalne)

Bez errorlogów amxa, ale jest error php:


Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0

Addony serwera:

AMXX v1.8.0.3660, PTB v1.8b3, MM v1.19

Może ktoś pomóc :P
  • +
  • -
  • 0

#2 tosiek

    Zaawansowany

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:86
  • GG:
Offline

Napisano 14.05.2008 16:56

gdzie masz hosting?

baardzo często na darmowych są zablokowane zewnętrzne połączenia do mysql :)
  • +
  • -
  • 0

#3 Zgadnij

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 14.05.2008 16:59

http://no-1.pl/ , napisałem że są odbokowane magic_quotes_gpc i save php a na niepłatnych zablokowane. A zewnetrzne mysql ofc odblokowane to wiadome jest.
  • +
  • -
  • 0

#4 bartek124

    Profesjonalista

  • Użytkownik

Reputacja: 30
Życzliwy

  • Postów:188
  • Lokalizacja:Kołaczyce
Offline

Napisano 14.05.2008 18:13

Host zły podałeś.
  • +
  • -
  • 0

#5 Zgadnij

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 14.05.2008 18:57

Host na 100% dobry, zmieniłem na cele publikacji na forum. (w prawdzie bez sensu ale coż :D )
  • +
  • -
  • 0

#6 bartek124

    Profesjonalista

  • Użytkownik

Reputacja: 30
Życzliwy

  • Postów:188
  • Lokalizacja:Kołaczyce
Offline

Napisano 14.05.2008 19:01

A register_globals masz wlączone czy wyłączone? Komunikat cos się o tym pluje.
  • +
  • -
  • 0

#7 tosiek

    Zaawansowany

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:86
  • GG:
Offline

Napisano 14.05.2008 19:27

jesteś pewien że host obsługuje wersję php ? i ustaw odpwoiednią w panelu :)
  • +
  • -
  • 0

#8 Zgadnij

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 14.05.2008 20:21

http://no-1.pl/info.php
  • +
  • -
  • 0

#9 Morti

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:28
Offline

Napisano 15.05.2008 14:43

Witam , ja rowniez pracuje przy tym projekcie..

hosting niestety nie ma włączonego modułu register globals ,co uniemozliwia nam dalsze prace z projektem.

Czy znacie może jakiś hosting z obsługą tych i innych modułów gdzie by poszedł amxbans?
  • +
  • -
  • 0

#10 bartek124

    Profesjonalista

  • Użytkownik

Reputacja: 30
Życzliwy

  • Postów:188
  • Lokalizacja:Kołaczyce
Offline

Napisano 15.05.2008 17:17

Wszystkie z php4. W php5 register_globals jest wyłączone poniewaz stało się niebezpieczne.
$dane == $_GET['dane']. To jest złe ;)
  • +
  • -
  • 0

#11 Zgadnij

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:7
Offline

Napisano 15.05.2008 18:25

Ato to, hmmm jaka firma to zapewnia?
  • +
  • -
  • 0

#12 Seba

    Wszechobecny

  • Zbanowany

Reputacja: 198
Profesjonalista

  • Postów:424
  • Lokalizacja:Internet
Offline

Napisano 15.05.2008 18:54

W php5 register_globals jest wyłączone poniewaz stało się niebezpieczne.

bez problemu w php.ini to włączyć.

#13 bartek124

    Profesjonalista

  • Użytkownik

Reputacja: 30
Życzliwy

  • Postów:188
  • Lokalizacja:Kołaczyce
Offline

Napisano 15.05.2008 19:10

Tak, tylko powiedz który hostingodawca da Ci w tym grzebać? No chyba że amsz dedyka to rozumiem, róbta co chceta ale na wirtualu za 80zł/rok w życiu :).
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych