Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Scrollmsg - kilka warunkow... (if)dla zaawansowanych skrypterów


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 Fail

    Zaawansowany

  • Zbanowany

Reputacja: -15
Tragedia

  • Postów:134
  • Lokalizacja:z forum
Offline

Napisano 02.02.2013 10:14

http://wklej.to/DYwt1

Zrobiłem sobie cos takiego jak wyżej na wklejce (na podstawie scrollmsg) i mam problem xD
ustawilem taska co 20 sekund aby mi to wyswietlal chce aby w pozycjach danych pojawial sie inny wyraz i wyglada to tak
    if (g_xPos <= 0.60) {
    show_hudmessage(0, "Siema Siema")
    }

    if (g_xPos <= 0.50) {
    show_hudmessage(0, "Ziom Ziom")
    }
    
    if (g_xPos <= 0.40) {
    show_hudmessage(0, "Bazuka Bazuka")
    }
    
    if (g_xPos <= 0.30) {
    show_hudmessage(0, "Jea Jea")
    }

i w momencie gdy pojawia sie wyraz "Siema Siema" kolor jest dobry i tak pojawia sie i zanika na podstawie wartosci z set_hudmessage "0.05, 0.05" czyli jest taki sam jak w scrollmsg. Ale w momencie gdy pojawia sie wyraz "Ziom Ziom" kolor zmienia sie na inny (zółty) tak jakby te wartości "0.05, 0.05" juz nie dzialaly

proszę mi nie pisac ze w innym miejscu sie ustawia wartosc migania bo tak jest w scrollmsg i pierwszy wyraz "Siema Siema" dobrze dziala, ale gdy pojawia sie "Ziom Ziom" to traci wlasnie ten efekt. :D

Proszę żeby ktos naprawdę mądry sie wypowiedział i zaawansowany w tych sprawach bo juz probowalem na tysiąc sposobów :P gdy zrobie bez tych warunkow z jednym show_hudmessage jest okey, ale jak z kilkoma to tylko ten pierwszy prawdilowo dziala.

Panowie! Pomocy bo kilka godzin nad tym bledem spedzilem xD!


Najlepiej jest wgrac ten kod na serwer testowy lub na komputerze, odczekac 20 sekund od rozpoczecia rundy i jak zobaczycie pierwszy napis, potem drugi, zrozumiecie o co mi chodzi :P

#2 Fail

    Zaawansowany

  • Autor tematu
  • Zbanowany

Reputacja: -15
Tragedia

  • Postów:134
  • Lokalizacja:z forum
Offline

Napisano 02.02.2013 13:25

Edit: http://wklej.to/HfFKa

tak powinien wygladac caly kod, bo nie ten podalem w pierwszym poscie

#3 Onyke

    Godlike

  • Przyjaciel

Reputacja: 705
Guru

  • Postów:2178
Offline

Napisano 03.02.2013 11:13

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Temat zamknięty na prośbę użytkownika.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 1




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych