Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Serwer HLDS na DebianieFATAL ERROR (shutting down): File read failure


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
9 odpowiedzi w tym temacie

#1 kubiik10

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Chełmża
Offline

Napisano 03.01.2013 17:42

Witam, zaczalem ze tak powiem testowac VPS i chcialem postawic server tak na probe, jednak nie moge tego zrobic bo wywala błąd
FATAL ERROR (shutting down): File read failure
oto caly log:

root@qazwsxedc12:/etc/STEAMHLDS# ./hlds_run -game cstrike +maxplayers 20 +map de_storm -ip 5.231.15.243 -port 27015
Auto detecting CPU
Using Pentium II Optimised binary.
Auto-restarting the server on crash

Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(10)/version(5787)
scandir failed:/etc/STEAMHLDS/./platform/SAVE
Protocol version 48
Exe version 1.1.2.6/Stdio (cstrike)
Exe build: 11:30:00 Aug 28 2012 (5787)
STEAM Auth Server
Server IP address 5.231.15.243:27015
scandir failed:/etc/STEAMHLDS/./platform/SAVE
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit

couldn't exec listip.cfg
couldn't exec banned.cfg
scandir failed:/etc/STEAMHLDS/./platform/SAVE
FATAL ERROR (shutting down): File read failure

Jak moge sprawic ze bedzie dzialac? Zmienialem juz mapy, chmody dla folderow, nic to nie dalo.
  • +
  • -
  • 0

#2 JabLuszko

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:126
  • Imię:Michał
  • Lokalizacja:Warszawa
Offline

Napisano 03.01.2013 18:25

Odpal serwer z dodatkowymi parametrami: -dev -condebug i pokaż co masz w pliku qconsole.log.
Próbowałeś odpalić serwer na innej mapie niż de_storm? Powiedzmy na de_dust2? ;)

Użytkownik JabLuszko edytował ten post 03.01.2013 18:25

  • +
  • -
  • 0

#3 kubiik10

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Chełmża
Offline

Napisano 03.01.2013 20:40

Taki plik nie tworzy sie u mnie po tym poleceniu. Oto co zwraca terminal.
root@qazwsxedc12:/etc/STEAMHLDS# ./hlds_run -game cstrike +maxplayers 20 -ip 5.231.15.243 -port 27015 -dev -condebug
Auto detecting CPU
Using Pentium II Optimised binary.
Auto-restarting the server on crash
Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(10)/version(5787)
Console initialized.
Base networking initialized.
"sv_cheats" changed to "1"
Initializing deltas
Protocol version 48
Exe version 1.1.2.6/Stdio (cstrike)
Exe build: 11:30:00 Aug 28 2012 (5787)
40.0 Mb heap
STEAM Auth Server
execing valve.rc
execing language.cfg
execing autoexec.cfg
execing violence.cfg
Server IP address 5.231.15.243:27015
Adding:  cstrike/dlls/cs_i386.so
Dll loaded for mod Counter-Strike
execing server.cfg
"sv_aim" changed to "0"
"pausable" changed to "0"
"mp_timelimit" changed to "20"
"sv_cheats" changed to "0"
couldn't exec listip.cfg
couldn't exec banned.cfg
Spawn Server de_dust
Clearing memory
Using WAD File: halflife.wad
FATAL ERROR (shutting down): File read failure

  • +
  • -
  • 0

#4 JabLuszko

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:126
  • Imię:Michał
  • Lokalizacja:Warszawa
Offline

Napisano 03.01.2013 20:52

Prawidłowo winno być

Spawn Server de_dust
Clearing memory
Using WAD File: halflife.wad
Using WAD File: decals.wad
Using WAD File: cs_dust.wad
Texture load:	1.8ms
Building PAS...
Average leaves visible / audible / total: 139 / 403 / 1298
"sv_maxspeed" changed to "900"

Jak widać u Ciebie próbuje / załadował jednego wad-a, drugiego już nie daje rady.
Nie nagrzebałeś tam w uprawnieniach, nie wgrywałeś podmienionych wad-ów?

Swoją drogą spróbuj zaktualizować wszystkie pliki i sprawdzić czy są okej poprzez ./steam -command update -game cstrike -dir ~/TUTAJ_KATALOG -verify_all -retry
W sumie najważniejsze z tego to jest verify_all.
Jak wszystko będzie okej to niestety ja nie mam więcej pomysłów - może uderzasz w jakieś limity RAMu na VPSie czy liczby równocześnie otwartych plików z danego usera? Próbowałeś (testowo!) odpalić to z root-a, który nie powinien części limitów mieć?;)

Użytkownik JabLuszko edytował ten post 03.01.2013 20:53

  • +
  • -
  • 1

#5 kubiik10

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Chełmża
Offline

Napisano 03.01.2013 21:11

Ile ramu powinno wystarczyc zeby puscic pusty server?
  • +
  • -
  • 0

#6 Rodzyn

    Wszechwiedzący

  • Power User

Reputacja: 140
Zaawansowany

  • Postów:560
  • GG:
  • Imię:Dawid
  • Lokalizacja:Bielawa
Offline

Napisano 04.01.2013 20:24

5-6 ..
  • +
  • -
  • 1

#7 kubiik10

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Chełmża
Offline

Napisano 05.01.2013 04:04

Ok poradzilem sobie juz ze wszystkim, serwer ruszyl, ale mam kolejny problem. Zainstalowalem MetaModa, wrzucilem mu dProto ale okazuje sie ze nie chce odpalic. Dla testu dorzucilem podboty ktore tez nie dzialaja. Oto log :
meta list
Currently loaded plugins:
	  description	  stat pend  file			  vers	  src  load  unlod
[ 1] <podbot_mm_i386  badf load  podbot_mm_i386.s  v -	   ini   -	 -
[ 2] dproto_EF		fail  -	dproto_i386.so	v0.9.87   ini  Start Never
2 plugins, 0 running

Wygooglowalem to i jedyne na co trafilem to zeby posprawdzac sciezki w ini, ktore jednak wygladaja dobrze.
ma ktos jakies pomysly? dzięki za pomoc : )

Użytkownik kubiik10 edytował ten post 05.01.2013 04:16

  • +
  • -
  • 0

#8 JabLuszko

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:126
  • Imię:Michał
  • Lokalizacja:Warszawa
Offline

Napisano 05.01.2013 06:42

A podczas startu serwera nie masz żadnej informacji o błędzie w konsoli? Ona jest czasami wybitnie ukryta - przejrzyj cały log, nawet jak Ci się wydaje, że nic tam nie ma :)
Jeśli znajdziesz coś w stylu:

L 07/13/2011 - 21:18:18: [META] WARNING: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/xxxx/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory
L 07/13/2011 - 21:18:18: [META] WARNING: dll: Skipping plugin '<dproto_i386.so>'; couldn't query

to - dproto jest 32bitowe, masz 64bitowy serwer i trzeba doinstalować odpowiednie liby:
apt-get update && apt-get install aptitude && aptitude install libstdc++6 lib32stdc++6 ia32-libs

PS Podziel się rozwiązaniem poprzedniego problemu - może ktoś też się na niego natknie :-)
  • +
  • -
  • 1

#9 Rodzyn

    Wszechwiedzący

  • Power User

Reputacja: 140
Zaawansowany

  • Postów:560
  • GG:
  • Imię:Dawid
  • Lokalizacja:Bielawa
Offline

Napisano 05.01.2013 10:21

to ja może podam rozwiązanie poprzedniego problemu..
Według mnie problem tkwił w ustawieniach mapy tzn. że mapa była ustawiona w server.cfg i jeszcze na komendzie startowej - +map de_dust2

Rozwiązanie: usunąć ustawienia mapy czyli linijke "map de_dust" z server.cfg i wtedy trzeba pamiętać że musi być w komendzie startowej na końcu albo przed komendą autoupdate to +map nazwa_mapy(bez.bsp!!!)

Myślę że dobrze trafiłem co do problemu bo to najczęstszy problem dotyczący serwera CS na VPS :(
  • +
  • -
  • 0

#10 kubiik10

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:5
  • Lokalizacja:Chełmża
Offline

Napisano 05.01.2013 11:50

A podczas startu serwera nie masz żadnej informacji o błędzie w konsoli? Ona jest czasami wybitnie ukryta - przejrzyj cały log, nawet jak Ci się wydaje, że nic tam nie ma :)
Jeśli znajdziesz coś w stylu:



L 07/13/2011 - 21:18:18: [META] WARNING: dll: Failed query plugin '<dproto_i386.so>'; Couldn't open file '/home/xxxx/cstrike/addons/dproto/dproto_i386.so': libstdc++.so.6: cannot open shared object file: No such file or directory
L 07/13/2011 - 21:18:18: [META] WARNING: dll: Skipping plugin '<dproto_i386.so>'; couldn't query

to - dproto jest 32bitowe, masz 64bitowy serwer i trzeba doinstalować odpowiednie liby:
apt-get update && apt-get install aptitude && aptitude install libstdc++6 lib32stdc++6 ia32-libs

PS Podziel się rozwiązaniem poprzedniego problemu - może ktoś też się na niego natknie :D


Własnie chodzi o to ze serwer jest 32bitowy. Nie wiem wlasnie jak wydobyc taki log z konsoli, normalnie sie onu mnie nie pokazuje.

to ja może podam rozwiązanie poprzedniego problemu..
Według mnie problem tkwił w ustawieniach mapy tzn. że mapa była ustawiona w server.cfg i jeszcze na komendzie startowej - +map de_dust2


Rozwiązanie: usunąć ustawienia mapy czyli linijke "map de_dust" z server.cfg i wtedy trzeba pamiętać że musi być w komendzie startowej na końcu albo przed komendą autoupdate to +map nazwa_mapy(bez.bsp!!!)

Myślę że dobrze trafiłem co do problemu bo to najczęstszy problem dotyczący serwera CS na VPS :(



Szczerze powiedziawszy nie mam pojecia co bylo przyczyna, zroilem reinstall calego debiana, od nowa pobralem hlds i zaczelo smigac :)


EDIT : DProto sie odpalilo, pokopiowalem jeszcze raz dproto.cfg do cstrike i root folderu i ruszylo. Ma ktos moze pomysl co do podbotow? nie zalezy mi na nich az tak mocno, ale chcialbym zobaczyc jak sie zachowa serwer jak dodam duzo botow. Czy bedzie stable itp. Oto log:

Currently loaded plugins:
	  description	  stat pend  file			  vers	  src  load  unlod
 [ 1] <podbot_mm_i386  badf load  podbot_mm_i386.s  v -	   ini   -	 -
 [ 2] dproto_EF	    RUN   -    dproto_i386.so    v0.9.87   ini  Start Never
2 plugins, 1 running
 



Użytkownik kubiik10 edytował ten post 05.01.2013 11:55

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych