Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z Vip


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 marcinplewa1

    Pomocny

  • Użytkownik

Reputacja: -7
Mniej niż zer0.

  • Postów:48
  • Imię:Marcin
  • Lokalizacja:Nowy Targ
Offline

Napisano 22.12.2012 14:39

wygenerowałem sobie vipa i ustawiłem mu 5 rodzajów ekwipunku w menu. Wejdę na serwer wybiorę raz to a w następnej rundzie wyświetla się menu, ale jak włączę np numer 1 to nie działa dalej mam to menu i nie dodaje mi ekwipunku. Chciałbym, aby ekwipunek był na 1 runde a w następnej, żeby się wybierało od nowa .

Załączone pliki


  • +
  • -
  • 0

#2 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 22.12.2012 15:03

Z tego co widzę nie zastosowałeś tej łatki: http://amxx.pl/topic...100#entry492160

Znajdź:
if(menu_callback(id, menu, ++num){
zamień na:
if(menu_callback(id, menu, ++num)==ITEM_ENABLED){

  • +
  • -
  • 0

If you can dream it, you can do it.


#3 marcinplewa1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: -7
Mniej niż zer0.

  • Postów:48
  • Imię:Marcin
  • Lokalizacja:Nowy Targ
Offline

Napisano 22.12.2012 15:25

Teraz mi ie daje broni a menu znika i nie wyswietla sie co runde

Załączone pliki


Użytkownik marcinplewa1 edytował ten post 22.12.2012 15:30

  • +
  • -
  • 0

#4 speedkill

    Godlike

  • Przyjaciel

Reputacja: 1570
Godlike

  • Postów:2733
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Prudnik
Offline

Napisano 22.12.2012 16:21

Twoje menu będzie działać tylko w drugiej rundzie ;)

Całą funkcję:
public recharge(id)
podmień na:
public recharge(id){
	new wid=get_user_weapon(id);
	if(wid){
		new weaponname[32], weid;
		get_weaponname(wid, weaponname, 31);
		weid=find_ent_by_owner(-1, weaponname, id);
		if(weid){
			cs_set_weapon_ammo(weid, clips[wid]);
		}
	}
}

  • +
  • -
  • 0

If you can dream it, you can do it.


#5 Gość_21977_*

  • Gość

Reputacja: 0

Offline

Napisano 22.12.2012 16:23

Automatyczna wiadomość


Ten temat został przeniesiony z forum

AMX Mod XProblemy

do

AMX Mod XProblemy z pluginami

#6 marcinplewa1

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: -7
Mniej niż zer0.

  • Postów:48
  • Imię:Marcin
  • Lokalizacja:Nowy Targ
Offline

Napisano 22.12.2012 17:53

Błąd podczas kompilacji zrób ty i wyślij

Użytkownik marcinplewa1 edytował ten post 22.12.2012 18:12

  • +
  • -
  • -1




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych