Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Problem z kompilacją 6 klas.


  • Zamknięty Temat jest zamknięty
5 odpowiedzi w tym temacie

#1 Piotreq183

    Banned

  • Zbanowany

Reputacja: 14
Początkujący

  • Postów:43
  • GG:
  • Lokalizacja:Polska
Offline

Napisano 13.12.2012 17:41

Witam, mam problem z kompilacją 6 klas do COD mod'a. Są jakieś dziwne błędy typu: invalid function or declaration" np. w linijce if(!(get_user_flags(id) & ADMIN_LEVEL_H)). Jeśli ktoś wie co zrobić aby skompilować te kalsy,

proszę również o powiedzenie dlaczego są takie dosyć dziwne błędy :)

Załączone pliki


Użytkownik Piotreq183 edytował ten post 13.12.2012 17:44


#2 RvG4

    Banned

  • Zbanowany

Reputacja: 149
Zaawansowany

  • Postów:171
  • GG:
  • Imię:Rafał
  • Lokalizacja:PL
Offline

Napisano 13.12.2012 17:52

Masz komandosp:

Załączone pliki



#3 Piotreq183

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 14
Początkujący

  • Postów:43
  • GG:
  • Lokalizacja:Polska
Offline

Napisano 14.12.2012 14:54

Dzięki, działa ta jedna.

#4 JabLuszko

    Zaawansowany

  • Użytkownik

Reputacja: 45
Pomocny

  • Postów:126
  • Imię:Michał
  • Lokalizacja:Warszawa
Offline

Napisano 14.12.2012 15:11

codclass_obroncap.sma
Nie zamknąłeś funkcji ResetHUDx(brakuje klamry } na końcu funkcji)
Wpisałeś jakieś dziwne +5.0 w parametry cod_inflict_damage - samo 5.0, nie +5.0

codclass_saperp.sma
W ogóle nie masz żadnej klamry przy funkcji cod_class_enabled. Trzeba dopisać, obie - zarówno otwierającą { jak i kończącą }

codclass_snajperp.sma
To samo co wyżej...

codclass_terrorystap.sma
To samo co wyżej...

codclass_wsparcieogniowep.sma
To samo co wyżej...

Także we wszystkich pluginach masz jakaś dziwną definicję cod_register_class - dopisany ciąg znaków "premium" jako ostatni parametr - jeśli masz tak w silniku to jest okej, jeśli nie masz tak i sam coś dopisałeś to to usuń.

Trąba, a nie autor tych pluginów z Ciebie :X.

Użytkownik JabLuszko edytował ten post 14.12.2012 15:18

  • +
  • -
  • 1

#5 Piotreq183

    Banned

  • Autor tematu
  • Zbanowany

Reputacja: 14
Początkujący

  • Postów:43
  • GG:
  • Lokalizacja:Polska
Offline

Napisano 14.12.2012 19:45

Dzięki działa, a tą ostatnią uwagę mogłeś sobie, bo gdybym robił to na trzeźwo to nie było by takich problemów...

#6 Kawon

    Godlike

  • Przyjaciel

Reputacja: 884
Czempion

  • Postów:5165
  • Steam:steam
  • Imię:Paweł
  • Lokalizacja:Dzierzgoń
Offline

Napisano 15.12.2012 00:53

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, Dołączona grafika raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0

DarkGL to mój autorytet.





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych