Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
GmAMXBans

GmAmxBans 1.6(1) nie łączy się z serwerem

gmamxbans

  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
5 odpowiedzi w tym temacie

#1 Bartek25211

    Nowy

  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Lokalizacja:Polska
Offline

Napisano 09.05.2012 16:41

Witam, po moich wielokrotnych instalacjach doszedłem do błędu, nie wiem jak go naprawić:

Wersja GmAmxBans 1.6(1)
- Wersja AMXMODX 1.8.1

- Wersja serwera: dproto, steam, ns
-Logi
L 05/09/2012 - 17:25:10: [amxbans_main.amxx] [AMXBans] The server IP:PORT is: 31.186.83.177:27331
L 05/09/2012 - 17:25:11: [amxbans_main.amxx] [AMXBans] Connection failed!
L 05/09/2012 - 17:25:11: [amxbans_main.amxx] [AMXBans] Threaded Query Error, Place: 5
L 05/09/2012 - 17:25:11: [amxbans_main.amxx] [AMXBans] Message: Unknown MySQL server host 'db.hostpark.pl' (1) (2005)
L 05/09/2012 - 17:25:11: [amxbans_main.amxx] [AMXBans] Query statement:

-AmxBans.cfg
// Plik Konfiguracyjny AMXBans
echo [AMXBans] laduje plik amxbans.cfg
// Prefix bazy
// Nota: Prefiks wpisany w sql.cfg nie jest już używany przez AMXBans
amx_sql_prefix "amx"
//Używanie oznaczeń gracza na tym serwerze czy na wszystkich?
amxbans_flagged_all_server 1
// Wczytywanie adminów
// 0 z bazy SQL, 1 = z pliku users.ini, 2 = nie ładuje adminów
amxbans_use_admins_file 1
// AMXBans próbuje pobierać Ip automatycznie (Tak, widać ;/)
// Możesz ustawić inne iP -np. "<ip>:<port>"
amxbans_server_address "31.186.83.177:27331"

amxbans_use_newbancmd 0
// Tak naprawdę ten cvar jest niezle pomylony niby chodzi o czas a ustawia własny powód bana
// -1 aby wyłaczyć, 0 aby właczyć własny powód bana
amxbans_custom_statictime 0
// Wpisz jaka ma byc wyœwietlana nazwa serwera na stronie gdy gracz dostanie bana .
// np. amxbans_servernick "Mój za***isty serwer"
// Pozostaw puste aby czytało domyœlna nazwe hosta z server.cfg
amxbans_servernick ""
// Ustaw 1 / 2 / 3 aby włšczyć powiadomienia o debugach w logach.
// nie ustawiaj na 3 bo Ci konsole zaspamuje, ustaw 2 bedzie normal
amxbans_debug 2


-plugins.ini
admin.amxx			  ; admin base (required for any admin-related)
;admin_sql.amxx ; admin base - SQL version (comment admin.amxx)
amxbans_core.amxx ; amxbans
amxbans_main.amxx debug ; amxbans
; AMX Mod X plugins
; Admin Base - Always one has to be activated
admin.amxx ; admin base (required for any admin-related)
;admin_sql.amxx ; admin base - SQL version (comment admin.amxx)


-modules.ini
;;;
; To enable a module, remove the semi-colon (;) in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time. Use ;;
;; amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
mysql
;sqlite


-sql.cfg
amx_sql_host "db.hostpark.pl"
amx_sql_user "goldgami_amxbans"
amx_sql_pass "************"
amx_sql_db "goldgami_amxbans"
amx_sql_table "admins"
amx_sql_type "mysql"

  • +
  • -
  • 0

#2 Bullecik

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:51
  • GG:
  • Imię:Oskar
  • Lokalizacja:krzesło
Offline

Napisano 09.05.2012 17:56

W plugins.ini wyłącz także "admin.amxx"
Dodałeś % lub adres ip serwera do bazy danych by mógł się serwer z nią połączyć?
  • +
  • -
  • 0
Dołączona grafika
- Unikalne Game Mody [100%]
- Unikalny Zombie xp Mod [100%]
- Optymalizacja kodu wszystkich pluginów [100%]
Dołączona grafika
- Unikalny Cod MOD [100%]

#3 Bartek25211

    Nowy

  • Autor tematu
  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Lokalizacja:Polska
Offline

Napisano 09.05.2012 18:30

W plugins.ini wyłącz także "admin.amxx"
Dodałeś % lub adres ip serwera do bazy danych by mógł się serwer z nią połączyć?

Tak dodałem.
  • +
  • -
  • 0

#4 LokalnyHost

    Profesjonalista

  • Użytkownik

Reputacja: 39
Życzliwy

  • Postów:213
  • Imię:Bedoka
  • Lokalizacja:Opole
Offline

Napisano 09.05.2012 19:08

1. Chcesz zeby czytalo adminow z SQL czy z Users.ini ?
2. Jaki to hosting ?
3. Unknown MySQL server host 'db.hostpark.pl' - nie może znaleźć tego hosta, złego musiałeś podac w sql.cfg

Użytkownik LokalnyHost edytował ten post 09.05.2012 19:09

  • +
  • -
  • 0

#5 fejk

    Wszechpomocny

  • Zbanowany

Reputacja: 53
Pomocny

  • Postów:336
  • GG:
  • Lokalizacja:users.ini
Offline

Napisano 09.05.2012 19:15

- jeżeli stronę masz na xaa.pl to w hoscie dodajesz np.:

www.nazwastrony.xaa.pl

- odblokuj moduł sqlite

-
admin.amxx ; admin base (required for any admin-related)
;admin_sql.amxx ; admin base - SQL version (comment admin.amxx)
amxbans_core.amxx ; amxbans
amxbans_main.amxx debug ; amxbans

amxbans_core i main mają być nad admin.amxx

#6 Bartek25211

    Nowy

  • Autor tematu
  • Pijawka

Reputacja: 0
zer0.

  • Postów:3
  • Lokalizacja:Polska
Offline

Napisano 10.05.2012 13:56

Problemem było to, że firma hostingowa nie podała prawidłowego ip mysql, teraz mam jeszcze taki problem, że w zakładce serwery mój serwer jest niedostępny, od czego to może zależeć?
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: gmamxbans

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych