Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Plugin sypie bledami


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 VirusX

    Pomocny

  • Użytkownik

Reputacja: 75
Zaawansowany

  • Postów:48
  • Imię:Adam
  • Lokalizacja:Zabrze
Offline

Napisano 08.02.2012 21:09

Witam.

Mam plugin ktory sypie bledami do tego stopnia ze log z calego dnia wazy ponad 100mb...

http://amxx.pl/wklej...32837957612018/




L 02/04/2012 - 15:31:48: [AMXX] Run time error 4: index out of bounds
L 02/04/2012 - 15:31:48: [AMXX]  [0] nade_modes.sma::fw_think (line 2564)

Bylbym cholernie wdzieczny za pomoc, probowalem juz to latac warunkiem is user connected ale problem nadal wystepuje.
Z gory dziekuje za pomoc.
  • +
  • -
  • 0

#2 kwieciak

    Pomocny

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:56
  • GG:
  • Lokalizacja:Łwc
Offline

Napisano 08.02.2012 21:34

dopisz debug i bedzie dobrze xD
  • +
  • -
  • 0

#3 Nakupenda.

    Not yet YODA

  • Użytkownik

Reputacja: 136
Zaawansowany

  • Postów:451
  • Imię:Paweł
  • Lokalizacja:Warszawa
Offline

Napisano 08.02.2012 21:42

dopisz debug i bedzie dobrze


nic nie będzie dobrze, takie komentarze lepiej sobie wsadź.. wiesz gdzie.

kod jest cholernie skomplikowany, jedyne co ci mogę powiedzieć to na czym polega błąd - mamy tablice np. new array[33] a kod próbuje wykonać coś na array[34], czyli na zmiennej, której nie ma
  • +
  • -
  • 0

#4 VirusX

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 75
Zaawansowany

  • Postów:48
  • Imię:Adam
  • Lokalizacja:Zabrze
Offline

Napisano 09.02.2012 20:02

Chorera, ciezko zlokalizowac w ktorym miejscu wychodzi poza ta tablice.
Moze jeszcze ktokolwiek podpowie?
  • +
  • -
  • 0

#5 Kubaczek <3

    Zaawansowany

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:116
  • Steam:steam
  • Lokalizacja::)
Offline

Napisano 10.02.2012 23:18

else
{
if (cl_team[owner] != cl_team[target])
set_trip_grenade_mode(ent, TRIP_SHOULD_DETONATE)
}

na
else
{
if(1 <= cl_team[owner] <= MAX_PLAYERS && 1 <= cl_team[target] <= MAX_PLAYERS)
{
if (cl_team[owner] != cl_team[target])
set_trip_grenade_mode(ent, TRIP_SHOULD_DETONATE)
}
}


@EDiT Gdzie ciężko zlokalizować ? :blink: masz podaną linie 2564 a tam jest tylko 1 tablica, więc?

Użytkownik Kubaczek <3 edytował ten post 10.02.2012 23:20

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych