Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z pluginem Advanced File Replacer


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
Brak odpowiedzi do tego tematu

#1 psilocybe

    Toasty!

  • Power User

Reputacja: 246
Wszechwidzący

  • Postów:524
  • Steam:steam
  • Imię:Filip
  • Lokalizacja:PL
Offline

Napisano 29.01.2012 23:51

Witam, mam mały problem z pluginem: http://amxx.pl/topic...-file-replacer/

Otóż zainstalowałem plugin, poprawnie działa i zamienia wyświetlanie np. modeli noża które sobie zmieniłem, również działa podmiana dźwięków.

Problem pojawił się gdy zachciało mi się podmienić sprite'y. W opisie podane jest że parametr dla modeli i spriteów jest taki sam czyli "m" więc tak zrobiłem, niestety nie podmienia mi spritów.

Dokładnie chodzi mi o wyświetlanie zamiennego sprite'a muzzleflash.spr, czyli ognia przy wystrzale z broni. Podmieniłem wszystkie 5 sprite'ów odpowiedzialnych za to, więc powinno z każdej broni wyświetlać podmieniony sprite - niestety tak się nie dzieje. Oczywiście zero błędów w konsoli HLDS jak i w logach AMXX więc nie ma sensu ich wklejać.

Dodam że próbowałem z innym sprite'ami i również nie działa, ścieżki do plików są dobre, nazwy plików do podmiany także są takiej samej długości, po prostu zmieniłem jedną literkę. Plik AFR.ini wygląda następująco:

"sprites/muzzleflash1.spr" "sprites/muzzleflass1.spr" "m"
"sprites/muzzleflash2.spr" "sprites/muzzleflass2.spr" "m"
"sprites/muzzleflash3.spr" "sprites/muzzleflass3.spr" "m"
"sprites/muzzleflash4.spr" "sprites/muzzleflass4.spr" "m"


Jakieś pomysły co mogłem pominąć, skoro modele podmienia prawidłowo i dźwięki to czemu nie działają sprite'y ? Z góry dziękuję za pomoc.

@UP

Nikt nie bawił się w podmianę sprite'ów ? Panowie pomóżcie, skoro jest taka opcja w pluginie to chyba było to testowane i działa tak? :)

@UP2:

Spoko że ktokolwiek odpisał. Sam znalazłem rozwiązanie, a raczej odpowiedź dlaczego nie działa podmiana spriteów.

Sprite'y z efektem ognia przy wystrzale są to pliki po stronie klienta więc nie ma opcji podmiany ich. Troszkę się zawiodłem no ale cóż, może kiedyś ktoś napisze plugin który pozwoli na taką zabawę bez ingerowania w pliki klienta.

Temat do usunięcia/zamknięcia.
  • +
  • -
  • 0

Dołączona grafika

Dołączona grafika





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych