Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie leci Exp na dodatkowych klasachNie leci Exp na dodatkowych klasach


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 Ikciu

    Nowy

  • Zbanowany

Reputacja: 1
Nowy

  • Postów:9
  • Imię:Damian
  • Lokalizacja:Dęblin
Offline

Napisano 13.07.2011 08:58

Witam mam taki problem mam Diablo Moda z Edytowanego i jak wpisuje /klasa mam exp tylko na ludziach zalozylem nowa baze danych nadalem acreshost
co jest nie tak nie rozumiem
ss-y

Dołączona grafika

Dołączona grafika


Dołączona grafika


Logi

diablo log

L20110713 log


Badzo proszę o szybką pomoc

#2 Kavi76

    Profesjonalista

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:209
  • GG:
  • Imię:Paweł :)
  • Lokalizacja:CrL
Offline

Napisano 13.07.2011 09:35

na pewno w swoim .sma zmieniłeś
for(new i=1;i<9;i++)
lub
new lx[9]

I tu gdzie 9 liczba swoich klas ?

Ewentualnie wyszysć baze danych
  • +
  • -
  • 0

#3 Ikciu

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:9
  • Imię:Damian
  • Lokalizacja:Dęblin
Offline

Napisano 13.07.2011 09:38

Ewentualnie wyszysć baze danych


Baza danych wyczyszczona

Tak wyglada tak Linijka w sma :
{
for(new i=1;i<22;i++) lx[i]=player_class_lvl[id][i]
select_class(id,lx)
}


#4 Kavi76

    Profesjonalista

  • Użytkownik

Reputacja: 17
Początkujący

  • Postów:209
  • GG:
  • Imię:Paweł :)
  • Lokalizacja:CrL
Offline

Napisano 13.07.2011 09:43

Psłuchaj mnie:

Tego szukasz 2 razy (chyba), jak nie to 3 lub 4
new lx[9]

Tego szukasz 4 razy chyba że masz więcej lub mniej
for(new i=1;i<9;i++)

I wszystkie
new lx[9]
zmnieniasz na
new lx[22]
i tak samo z
for(new i=1;i<9;i++)

Użytkownik Kavi76 edytował ten post 13.07.2011 09:44

  • +
  • -
  • 0

#5 Ikciu

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:9
  • Imię:Damian
  • Lokalizacja:Dęblin
Offline

Napisano 13.07.2011 09:52

Bylo już zmienione nic nie pomoglo

#6 glut

    Godlike

  • Przyjaciel

Reputacja: 931
Master

  • Postów:2073
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Namysłów
Offline

Napisano 13.07.2011 11:12

INSERT IGNORE INTO *TABELA_DIABLO* (nick, ip, sid, klasa, lvl, exp) SELECT nick, ip, sid, *NUMER_NOWEJ_KLASY*, *LEVEL_NOWEJ_KLASY*, *EXP_NOWEJ_KLASY* FROM *TABELA_DIABLO* GROUP BY *RODZAJ_ZAPISU* HAVING MAX(klasa)<*NUMER_NOWEJ_KLASY*;

przykład:

INSERT IGNORE INTO dbmod_tablet (nick, ip, sid, klasa, lvl, exp) SELECT nick, ip, sid, 9, 1, 1 FROM dbmod_tablet GROUP BY nick HAVING MAX(klasa)<9;

zmień sobie dbmod_tablet na nazwę twojej tabeli w mysql i na samym końcu 9 zmieniaj na nr klasy :) i tak dodasz :D

Użytkownik glut1997 edytował ten post 13.07.2011 11:13

  • +
  • -
  • 1

Nie pomagam za darmo na PW/GG/Steam od tego jest forum

 

TP Game + RR

 

Znak rozpoznawczy :coto:


#7 Ikciu

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:9
  • Imię:Damian
  • Lokalizacja:Dęblin
Offline

Napisano 13.07.2011 16:19

07/13/2011 - 17:26:04: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:04: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:04: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:04: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:05: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:05: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:05: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:06: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:06: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:06: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:06: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
L 07/13/2011 - 17:26:06: [AMXX] Run time error 4 (plugin "Diablo.amxx") - debug not enabled!
L 07/13/2011 - 17:26:06: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).


taki mam BUG

Użytkownik Ikciu edytował ten post 13.07.2011 16:27


#8 Stachuu :D ??

    Wszechobecny

  • Użytkownik

Reputacja: 235
Wszechwidzący

  • Postów:476
  • GG:
  • Steam:steam
  • Imię:Dawid
  • Lokalizacja:Karsznice
Offline

Napisano 13.07.2011 16:28

poka
public create_klass(id)




@up dodaj "debug" za Diablo.amxx

tzn w plugins.ini

Diablo.amxx debug ma być

potem podeślij errory

Użytkownik Stachu123 edytował ten post 13.07.2011 16:29

  • +
  • -
  • 0

#9 Ikciu

    Nowy

  • Autor tematu
  • Zbanowany

Reputacja: 1
Nowy

  • Postów:9
  • Imię:Damian
  • Lokalizacja:Dęblin
Offline

Napisano 13.07.2011 18:48

glut juz mam thx




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych