Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
CoD Nowy

Błady w logach oraz czesty reset serwera

CoD Nowy

  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 matti9410

    Wszechpomocny

  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 17.06.2011 12:51

Bład w COD MODZIE który zapisuje lvl w SQL pobrany z tego forum
L 06/17/2011 - 13:39:20: [MySQL] Invalid column: -1
L 06/17/2011 - 13:39:20: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/17/2011 - 13:39:20: [AMXX] Run time error 10: native error (native "SQL_ReadResult")
L 06/17/2011 - 13:39:20: [AMXX]    [0] codsql321.sma::IgnoreHandle2 (line 951)

plik w zalaczniku (sma)
proszę o szybką naprawe.

Załączone pliki


  • +
  • -
  • 0

#2 BliBs_Pl

    Wszechpomocny

  • Użytkownik

Reputacja: 91
Zaawansowany

  • Postów:365
  • GG:
  • Steam:steam
  • Imię:Piotrek
  • Lokalizacja:Pisz
Offline

Napisano 20.06.2011 11:39

Nie wiem czy to pomoże ale spróbuj wpisać po QTM_CodMod.amxx w plugins-codmod.cfg debug żeby to wyglądało tak:
QTM_CodMod.amxx debug

  • +
  • -
  • 0

#3 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 20.06.2011 20:52

Nareszcie ktoś napisał ale powiem ci tyle że już mam dopisaną ten debug koło nazwy i mam nadal te beznadziejne errory.
  • +
  • -
  • 0

#4 Jak się nazwać

    Wszechmogący

  • Power User

Reputacja: 170
Profesjonalista

  • Postów:617
  • Imię:a
  • Lokalizacja:a
Offline

Napisano 20.06.2011 20:58

Najlepiej napisz do DarkGl on ma na sprzedaż porządnie zrobioną wersję SQL do coda

Użytkownik Jak się nazwać edytował ten post 20.06.2011 20:59

  • +
  • -
  • 0
Pisze na zamówienie statystyki pod nvault. GG: 15600964

#5 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 21.06.2011 10:20

Ta i zapłace z 60 zł + a tutaj mam za friko tylko mam drobny bład.
  • +
  • -
  • 0

#6 Nenczoks

    Banned

  • Zbanowany

Reputacja: 50
Pomocny

  • Postów:358
  • Lokalizacja:Warszawa
Offline

Napisano 21.06.2011 10:40

Nie wiem czy to pomoże ale spróbuj wpisać po QTM_CodMod.amxx w plugins-codmod.cfg debug żeby to wyglądało tak:

QTM_CodMod.amxx debug


Jak nie masz nic do powiedzenia, to może lepiej się nie wypowiadaj.
Już jak widać użył debug na końcu, skoro pokazuje linijkę w kodzie sma.
Ponadto i tak czy siak to nic nie da. Służy to tylko do informacji.

Google

Masz :) Warto czasem tak szukać.

Użytkownik Nenczoks edytował ten post 21.06.2011 10:40


#7 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 21.06.2011 11:03

Szukam i szukam w tych googlach co podałeś ale odpowiedzi nadal brak :(
  • +
  • -
  • 0

#8 JaVoR

    Pomocny

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:50
  • Imię:Bartek
  • Lokalizacja:InoWroCłaW
Offline

Napisano 21.06.2011 20:16

Jest jeden prosty sposób na naprawę serwera. Jest on radykalny ale na pewno zadziała. Reinstal serwera.


P.s
To jest tylko moja rada, jestem zielony jak trawa jeśli chodzi o amxx'a. Jak nic innego nie pomoże to posłuchaj rady JaVoR'ka xD...
  • +
  • -
  • 0

#9 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 21.06.2011 21:28

Potrzebuje konkretnej pomocy a nie takiej jak ty ta twoja odp mozna uznac za nabicie posta !
  • +
  • -
  • 0

#10 Na 5tyk

    Godlike

  • Użytkownik

Reputacja: 430
Wszechobecny

  • Postów:1712
  • GG:
  • Imię:Patryk
  • Lokalizacja:PL
Offline

Napisano 27.06.2011 16:35

native error (native "SQL_ReadResult")

Ta linijka informuje nas o błędzie. Błąd polega na natywie SQL_ReadResult
  • +
  • -
  • 0

#11 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 27.06.2011 17:27

Ja się na pluginach nie znam nawet nie wiem co to ten natyw :( mógłbyś ogarnąć możę w sma coś źle jest ?

Dodano 01 lipiec 2011 - 21:19:
Restartu serwera już niema jak coś była to inna przyczyna ale nadal mam te błędy w logach.
  • +
  • -
  • 0

#12 Dwdov

    Profesjonalista

  • Zbanowany

Reputacja: 59
Pomocny

  • Postów:172
  • Imię:Dawid
  • Lokalizacja:Jawor
Offline

Napisano 02.07.2011 08:00

Znajdź funkcje:

public IgnoreHandle2(FailState,Handle:query,Error[],Errcode,Data[],DataSize)

I zmień tam

formatex(pobrane, 3, "%i", Data[1])
SQL_ReadResult(query,SQL_FieldNameToNum(query, pobrane), szTemp, charsmax(szTemp))

na

formatex(pobrane, 3, "%i", Data[1])
if(SQL_FieldNameToNum(query, pobrane) < 0 )
return;
SQL_ReadResult(query,SQL_FieldNameToNum(query, pobrane), szTemp, charsmax(szTemp))

Logów powinno nie być, nie wiem tylko czy SQL będzie działało poprawnie : d

Użytkownik Dawedov edytował ten post 02.07.2011 08:01

Nie pomagam na PW, tylko na forum.


#13 matti9410

    Wszechpomocny

  • Autor tematu
  • Użytkownik

Reputacja: 8
Nowy

  • Postów:352
  • Imię:Mateusz
  • Lokalizacja:Kalisz
Offline

Napisano 13.07.2011 15:47

dziala thx
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: CoD Nowy

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych