Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

błędy przy pobieraniu plików z serwera oraz FDL


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Kendzior87

    Zaawansowany

  • Użytkownik

Reputacja: 5
Nowy

  • Postów:130
  • Lokalizacja:Matrix
Offline

Napisano 02.05.2011 18:27

Cześć,
Czy istnieje możliwość wymuszenia u użytkownika "cl_allowdownload 1"?
Co nie dodam jakiegoś modelu na serwerze to zaraz pojawiają się osoby co mają napaćkane w cfg i im nie pobiera.
Mam zrobiony fdl, poniżej dane konfiguracyjne serwera:

// Autocelowanie
sv_aim "0"
// Wpisywanie kodow inaczej chitow
sv_cheats "0"
// Szybkosc poruszania sie
sv_maxspeed "1600"
// Grawitacja
sv_gravity "800"
// Zezwolenie na HLTV
sv_proxies "1"
// Zezwolenie na pobieranie z serwera (dzwieki, mapy itd.)
sv_allowdownload "1"
// Zezwolenie na upload plikow (loga w grze)
sv_allowupload "1"
// Fast Download - Pobieranie plikow z zewnętrznego serwera
sv_downloadurl "http://xxxx.xxxxx.eu/xxxxxxxxx/"

Zastąpiłem prawdziwą składnie linku do ftpa x'ami.
  • +
  • -
  • 0

#2 Abes Mapper

    Repulsion Gel

  • Przyjaciel

Reputacja: 1998
Godlike

  • Postów:7356
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Sulejówek
Offline

Napisano 02.05.2011 18:55

To już nawet ludzie nie wiedzą że trzeba to wpisać bo inaczej im się nie pobiorą pliki?
Zamieść adnotacje na forum/stronie żeby to ustawić w konsoli
  • +
  • -
  • 1

#3 Kendzior87

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:130
  • Lokalizacja:Matrix
Offline

Napisano 02.05.2011 19:30

no niestety - szara rzeczywistość, tak czy inaczej dzięki za szybkie ino :) +
Czy istnieje możliwość przerobienia pluginu co wymusza np interp aby wymuszał cl_allowdownload 1 przy łączeniu? Byłoby to dla mnie baaardzo pomocne.

Użytkownik Kendzior87 edytował ten post 02.05.2011 19:32

  • +
  • -
  • 0

#4 Portek

    Kończymy zabawę, permanentna emerytura!

  • Przyjaciel

Reputacja: 976
Master

  • Postów:3007
  • GG:
  • Steam:steam
  • Imię:Michał
  • Lokalizacja:Częstochowa
Offline

Napisano 02.05.2011 19:59

Tylko co z tego że Ty im to wymusisz, jeśli cfg. będzie tylko do odczytu to każdorazowy restart CS'a = blokada pobierania.

Możesz spróbować tego:
#include <amxmodx>

public client_authorized(id)
{
client_cmd(id,"cl_allowdownload 1");
}


Ale na 99.9% i tak nie da to zamierzonego efektu.
  • +
  • -
  • 1

Dołączona grafika
IP: ts3.cserwerek.pl


#5 Kendzior87

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:130
  • Lokalizacja:Matrix
Offline

Napisano 02.05.2011 20:12

No cfg jest tylko do odczytu, ale jak taki plugin by tej osobie przy 1 połączeniu wymusił raz download to by pobrał co trzeba i po kłopocie. Przetestuje późnym wieczorem.
  • +
  • -
  • 0

#6 Muzzi

    Guru

  • Przyjaciel

Reputacja: 227
Wszechwidzący

  • Postów:772
  • Lokalizacja:Kraków
Offline

Napisano 02.05.2011 23:30

Portek nie lepiej tak ?


#include <amxmodx>

public client_connect(id)
{
client_cmd(id,"cl_allowdownload 1");
}

  • +
  • -
  • 1

#7 Kendzior87

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 5
Nowy

  • Postów:130
  • Lokalizacja:Matrix
Offline

Napisano 03.05.2011 08:54

[______]

sry za ten post co był w tym miejscu :D jak sam zobaczyłem co tu jest napisane to aż mnie zatkało że takie lupie pytanie zadałem :D dodałem tą komendę do cod'a i ekstra wymusza allowdownload :) bardzo wam dziękuję :)

testowane:
cl_allowdownload 0 -> skasowane modele z folderu csa -> upewnienie się że w config jest 0 -> odpalenie cs'a i połączenie z serwerem -> modele zostają elegancko pobrane, brak komunikatu "couldn't continue" wiadomo o co chodzi gdy brak modelu -> sprawdzam config, jest wartość 1 :D

+

Użytkownik Kendzior87 edytował ten post 03.05.2011 21:09

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych