Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Podmiana Modeli Broni


  • Zamknięty Temat jest zamknięty
2 odpowiedzi w tym temacie

#1 AmD

    aemde

  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 19.01.2011 15:33

Witam.


Robię sklepik chce dodać do niego Bronie z większym DMG i innym wyglądem.

Problem jest w tym że zamiast podmieniać jeden model podmienia wszystkie. (powiedzmy że mamy usp+knife wybieramy inny model AK i wszystkie bronie zamieniają się właśnie w AK)


Oto jak podmieniam bronie:

Tablice:

new AK_V_MODEL[64] = "models/cs_dreams/v_golden_ak47.mdl"
new AK_P_MODEL[64] = "models/cs_dreams/p_golden_ak47.mdl"

new DGL_V_MODEL[64] = "models/cs_dreams/v_golden_deagle.mdl"

new SCOUT_V_MODEL[64] = "models/cs_dreams/v_scout.mdl"

new AWP_V_MODEL[64] = "models/cs_dreams/v_awp.mdl"

new MP_V_MODEL[64] = "models/cs_dreams/v_dual_mp5.mdl"

new KNIFE_V_MODEL[64] = "models/cs_dreams/v_knife_new.mdl"



Forward+event

register_forward(FM_SetModel, "checkModel");
register_event("CurWeapon","CurWeapon","be")


CurWeapon:

public CurWeapon(id){
new WeaponNum = read_data(2)

checkModel(id, read_data(2))

}


checkModel:


public checkModel(id, weaponid)
{
switch (weaponid)
{
case CSW_AK47: {
if(goldenak[id])
set_pev(id, pev_viewmodel2, AK_V_MODEL)

else return PLUGIN_HANDLED
}
case CSW_DEAGLE: {
if(goldendgl[id])
set_pev(id, pev_viewmodel2, DGL_V_MODEL)

else return PLUGIN_HANDLED
}
case CSW_SCOUT: {
if(scoutdmg[id])
set_pev(id, pev_viewmodel2, AWP_V_MODEL)

else return PLUGIN_HANDLED
}
case CSW_AWP: {
if(awpmaster[id])
set_pev(id, pev_viewmodel2, AWP_V_MODEL)

else return PLUGIN_HANDLED
}
case CSW_MP5NAVY: {
if(mp5dmg[id])
set_pev(id, pev_viewmodel2, MP_V_MODEL)

else return PLUGIN_HANDLED
}
case CSW_KNIFE: {
if(knife[id])
set_pev(id, pev_viewmodel2, KNIFE_V_MODEL)

else return PLUGIN_HANDLED
}
}
return PLUGIN_HANDLED
}

co znów odwaliłem że nie działa?

Pozdrawiam!

Użytkownik AmD edytował ten post 19.01.2011 15:36

  • +
  • -
  • 0

#2 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6033
Godlike

  • Postów:10831
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 19.01.2011 16:00

register_forward(FM_SetModel, "checkModel");
to nie jest potrzebne
  • +
  • -
  • 0

#3 AmD

    aemde

  • Autor tematu
  • Użytkownik

Reputacja: 71
Pomocny

  • Postów:500
  • Steam:steam
  • Imię:Dariusz
  • Lokalizacja:Częstochowa
Offline

Napisano 19.01.2011 16:15

usunąłem i nadal to samo

a i jeszcze mam błąd
gdy chcę przejść z menu1 do menu2 wyskakuje log:

L 01/19/2011 - 16:10:37: Plugin called menu_display when item=MENU_EXIT
L 01/19/2011 - 16:10:37: [AMXX] Run time error 10 (plugin "MenuDR.amxx") (native "menu_display") - debug not enabled!
L 01/19/2011 - 16:10:37: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quote
Dodam że To są dwa inne pluginy

Dodano 20 styczeń 2011 - 17:27:
@ref?

Użytkownik DarkGL edytował ten post 19.01.2011 16:27

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych