Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z RS


  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 exexe

    Pomocny

  • Użytkownik

Reputacja: 22
Życzliwy

  • Postów:63
  • Lokalizacja::)
Offline

Napisano 10.01.2011 17:49

Witam, stworzyłem własnego rsa i jest problem.
Raz się dźwięki odtwarzają, raz nie, w logach znalazłem error i amxx kazał zrobić debuga, pod debugu wyskoczyło coś takiego:
L 01/10/2011 - 17:20:31: [AMXX] Displaying debug trace (plugin "roundsound.amxx")
L 01/10/2011 - 17:20:31: [AMXX] Run time error 4: index out of bounds 
L 01/10/2011 - 17:20:31: [AMXX]    [0] roundsound.sma::plugin_precache (line 38)
Linijka 38:
precache_sound(dzwieki_t[i]);
Fragment kodu:
new const dzwieki_ct[][] = {
	"sound/1-10.mp3",
	"sound/2-10.mp3",
	"sound/3-10.mp3",
	"sound/4-10.mp3",
	"sound/5-10.mp3"
}

new const dzwieki_t[][] = {
	"sound/6-10.mp3",
	"sound/7-10.mp3",
	"sound/8-10.mp3",
	"sound/9-10.mp3",
	"sound/10-10.mp3"
}

public plugin_precache()
{
	new i,u;
	
	for(i = 0; i < sizeof dzwieki_ct; i++)
	{
		precache_generic(dzwieki_ct[i]);
		precache_sound(dzwieki_ct[i]);
	}
	for(u = 0; u < sizeof dzwieki_t; u++)
	{
		precache_generic(dzwieki_t[u]);
		precache_sound(dzwieki_t[i]);
	}
}
Proszę o waszą pomoc, jeżeli jeszcze jakichś informacji potrzeba, proszę pisać.
Oczywiście za pomoc, będą plusy :)


Dodano 11 styczeń 2011 - 15:29:
Odświeżam, naprawdę nikt nie wie jak mi pomóc ?

Dodano 11 styczeń 2011 - 16:25:
Problem rozwiązany.
W kodzie jest literówka, której nie zauważyłem, można zamknąć.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych