Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Menu klas, exp


  • Zamknięty Temat jest zamknięty
10 odpowiedzi w tym temacie

#1 sebul

    Godlike

  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 28.09.2010 20:05

Wersja amxx'a: v1.8.1.3
werjsa diablo moda: 5.9l
zawartosc aktualnych logow:
error_20100928
L 09/28/2010 - 20:45:04: Start of error session.
L 09/28/2010 - 20:45:04: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20100928.log")
L 09/28/2010 - 20:45:04: [MySQL] Thread worker was unable to start.
L 09/28/2010 - 20:45:04: [AMXX] Displaying debug trace (plugin "dbmod_5.9l.amxx")
L 09/28/2010 - 20:45:04: [AMXX] Run time error 10: native error (native "SQL_ThreadQuery")
L 09/28/2010 - 20:45:04: [AMXX]    [0] dbmod_5.9l.sma::create_klass (line 668)
L 09/28/2010 - 20:45:04: [AMXX]    [1] dbmod_5.9l.sma::SelectHandle (line 759)

diablo.log
L 09/12/2010 - 02:06:16: Log file started (file "cstrike\addons\amxmodx\logs\diablo.log") (game "cstrike") (amx "1.8.1.3746")
L 09/12/2010 - 02:06:16: 09/12/2010 - 02:06:16 ### MAPA: de_aztec ### 
L 09/12/2010 - 21:45:47: 09/12/2010 - 21:45:47 ### MAPA: de_aztec ### 
L 09/12/2010 - 22:04:47: 09/12/2010 - 22:04:47 ### MAPA: de_aztec ### 
L 09/12/2010 - 22:49:40: 09/12/2010 - 22:49:40 ### MAPA: de_aztec ### 
L 09/12/2010 - 23:13:35: 09/12/2010 - 23:13:35 ### MAPA: de_aztec ### 
L 09/12/2010 - 23:20:45: 09/12/2010 - 23:20:45 ### MAPA: de_aztec ### 
L 09/12/2010 - 23:38:24: 09/12/2010 - 23:38:24 ### MAPA: de_aztec ### 
L 09/19/2010 - 23:41:46: 09/19/2010 - 23:41:46 ### MAPA: de_aztec ### 
L 09/20/2010 - 16:11:07: 09/20/2010 - 16:11:07 ### MAPA: de_aztec ### 
L 09/20/2010 - 16:12:11: 09/20/2010 - 16:12:11 ### MAPA: de_nuke ### 
L 09/26/2010 - 23:06:52: 09/26/2010 - 23:06:52 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:18:28: 09/26/2010 - 23:18:28 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:18:29: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:18:29: Could not connect to SQL database.
L 09/26/2010 - 23:19:15: 09/26/2010 - 23:19:15 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:19:17: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:19:17: Could not connect to SQL database.
L 09/26/2010 - 23:22:30: 09/26/2010 - 23:22:30 ### MAPA: cs_militia ### 
L 09/26/2010 - 23:27:06: 09/26/2010 - 23:27:06 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:27:27: 09/26/2010 - 23:27:27 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:48:04: 09/26/2010 - 23:48:04 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:52:35: 09/26/2010 - 23:52:35 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:52:46: 09/26/2010 - 23:52:46 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:53:16: 09/26/2010 - 23:53:16 ### MAPA: de_nuke ### 
L 09/27/2010 - 00:01:34: 09/27/2010 - 00:01:34 ### MAPA: de_aztec ### 
L 09/27/2010 - 00:07:55: 09/27/2010 - 00:07:55 ### MAPA: de_train ### 
L 09/27/2010 - 00:26:16: 09/27/2010 - 00:26:16 ### MAPA: de_nuke ### 
L 09/28/2010 - 19:39:11: 09/28/2010 - 19:39:11 ### MAPA: de_aztec ### 
L 09/28/2010 - 20:04:49: 09/28/2010 - 20:04:49 ### MAPA: de_aztec ### 
L 09/28/2010 - 20:12:05: 09/28/2010 - 20:12:05 ### MAPA: de_nuke ### 
L 09/28/2010 - 20:23:00: 09/28/2010 - 20:23:00 ### MAPA: de_nuke ### 
L 09/28/2010 - 20:25:56: 09/28/2010 - 20:25:56 ### MAPA: de_aztec ### 
L 09/28/2010 - 20:39:44: 09/28/2010 - 20:39:44 ### MAPA: de_nuke ### 
L 09/28/2010 - 20:40:21: 09/28/2010 - 20:40:21 ### MAPA: de_dust2 ### 
L 09/28/2010 - 20:45:08: 09/28/2010 - 20:45:08 ### MAPA: de_train ### 
L 09/28/2010 - 20:51:31: 09/28/2010 - 20:51:31 ### MAPA: de_dust ###
Oczywiście brać pod uwagę dzisiejsze logi, bo wcześniej to kombinowałem, edytowałem kod moda, itp.

modules.ini
;;;
; To enable a module, remove the semi-colon (<img src='http://amxx.pl/public/style_emoticons/<#EMO_DIR#>/wink.gif' class='bbc_emoticon' alt=';)' /> in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time.  Use      ;;
;;  amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
;sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here.              ;;
;; You can just list their names, without the _amxx ;;
;;  or file extension.                              ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded   ;;
;;  as needed.  You do not need to enable them here ;;
;;  unless you have problems.                       ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
;engine
;fakemeta
;geoip
;sockets
;regex
;nvault
cstrike
csx
;hamsandwich
;netdb

Na wstępie dodam, że moda testuje na hlds, ale podobno to w niczym nie przeszkadza.
Problem polega na tym, że nawet menu się nie pokazuje, więc nawet klasy nie można wybrać. Gdy wgrałem swoją edycję (może za dużo powiedziane, ale zmieniłem menu) to już menu się pokazywało, ale exp stał w miejscu. Problem raczej nie leży po stronie bazy, bo jak wrzucę diablo moda od kumpla (dał mi sam plik amxx, ale sma nie dostałem... ;/) w którym jest 16 klas i inne menu, to wszystko działa, itp. ale z różnych względów nie chce go używać. Ktoś wie co może być nie tak?

Dodano 29 wrzesień 2010 - 12:54:
Zapomniałem dodać jeszcze, że tabela w bazie się tworzy, ale pusta, bez wpisów, do tego jeszcze gdy następuje zmiana mapki, to serw się zacina, czasami po kilku minutach mapka się zmienia, ale częściej po prostu trzeba wyłączyć serwer i później z powrotem go włączyć.

Załączone pliki

  • Załączony plik  diablo.rar   564 bajtów  40 Ilość pobrań

  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#2 MaDaFaKa

    Zaawansowany

  • Zbanowany

Reputacja: 59
Pomocny

  • Postów:96
  • Imię:Damian
  • Lokalizacja:Warszawa
Offline

Napisano 29.09.2010 15:21

Jaki hosting i gdzie masz bazę danych?

#3 sebul

    Godlike

  • Autor tematu
  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 29.09.2010 15:27

Hosting:

Na wstępie dodam, że moda testuje na hlds, ale podobno to w niczym nie przeszkadza.


Baza: proserwer.pl
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#4 MaDaFaKa

    Zaawansowany

  • Zbanowany

Reputacja: 59
Pomocny

  • Postów:96
  • Imię:Damian
  • Lokalizacja:Warszawa
Offline

Napisano 29.09.2010 15:32

Daj swoje menu z klasami od Diablo Moda, bo na pewno wina tkwi w nim.

#5 sebul

    Godlike

  • Autor tematu
  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 29.09.2010 15:35

Przecież napisałem, że przy wgraniu zwykłego diablo moda, menu się nie pokazuje, a jak wgram już z tym moim menu, to menu w grze się pokazuje, ale exp stoi w miejscu, czyli mam ciągle 0 lvl.

Dodano 29 wrzesień 2010 - 16:39:
No, ale skoro chciałeś, to dodaje to co sam "usmażyłem".

Załączone pliki


  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#6 eRBeKa#

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 01.10.2010 12:59

Jaki hosting i gdzie masz bazę danych?


O jaki hosting ci człowieku chodzi nie znasz się na diablo to się nie udzielaj w logach jak byk pisze

L 09/26/2010 - 23:18:29: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:18:29: Could not connect to SQL database.
L 09/26/2010 - 23:19:15: 09/26/2010 - 23:19:15 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:19:17: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:19:17: Could not connect to SQL database.

źle ustawiłeś bazę MySQL w amxx.cfg nie podałeś lokalnego hostu
a i dla pewności ;sqlite usum ; i skonfiguruj porwanie cvary i powinno śmigać
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#7 sebul

    Godlike

  • Autor tematu
  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.10.2010 13:03

w logach jak byk pisze

L 09/26/2010 - 23:18:29: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:18:29: Could not connect to SQL database.
L 09/26/2010 - 23:19:15: 09/26/2010 - 23:19:15 ### MAPA: de_aztec ### 
L 09/26/2010 - 23:19:17: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:19:17: Could not connect to SQL database.

źle ustawiłeś bazę MySQL w amxx.cfg nie podałeś lokalnego hostu
a i dla pewności ;sqlite usum ; i skonfiguruj porwanie cvary i powinno śmigać


Odpowiem cytatem...

Oczywiście brać pod uwagę dzisiejsze logi, bo wcześniej to kombinowałem, edytowałem kod moda, itp.


  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#8 eRBeKa#

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 01.10.2010 14:14

L 09/26/2010 - 23:18:29: Error on Table query: Can't connect to MySQL server on 'localhost' (10061)
L 09/26/2010 - 23:18:29: Could not connect to SQL database.


Pokaz amxx.cfg znasz angielski chyba pisze ze baza źle skonfigurowana
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#9 sebul

    Godlike

  • Autor tematu
  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.10.2010 14:23

Nie chcę być nie miły, ale czy Ty znasz polski? Ale już masz te cvary z amxx.cfg...
diablo_sql_host "91.121.97.29"
diablo_sql_user "p57681_djbeee"
diablo_sql_pass "***"
diablo_sql_database "p57681_dbmod"
diablo_sql_table "dbmod_tableq"
diablo_sql_save "0"
I może przeczytaj jeszcze raz to

Problem polega na tym, że nawet menu się nie pokazuje, więc nawet klasy nie można wybrać. Gdy wgrałem swoją edycję (może za dużo powiedziane, ale zmieniłem menu) to już menu się pokazywało, ale exp stał w miejscu. Problem raczej nie leży po stronie bazy, bo jak wrzucę diablo moda od kumpla (dał mi sam plik amxx, ale sma nie dostałem... ;/) w którym jest 16 klas i inne menu, to wszystko działa, itp.


I parę linijek wyżej

Oczywiście brać pod uwagę dzisiejsze logi, bo wcześniej to kombinowałem, edytowałem kod moda, itp.


Użytkownik sebul edytował ten post 01.10.2010 14:24

  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu

#10 eRBeKa#

    Pomocny

  • Użytkownik

Reputacja: 7
Nowy

  • Postów:72
  • Lokalizacja:Poznań
Offline

Napisano 01.10.2010 17:28

diablo_sql_host "91.121.97.29"
Zmień na nazwę strony np urbk.xaa.pl a nie pokazuje ci się menu klas bo nie utworzyła się tabela bo jest problem z localhost chyba oczywiste
  • +
  • -
  • 0
Jestem jaki jestem, i dobrze mi z tym :)
Just-Frags.PL - Prawdziwa pasja nie zna granic!!

#11 sebul

    Godlike

  • Autor tematu
  • Junior Admin

Reputacja: 2016
Godlike

  • Postów:5411
  • Steam:steam
  • Imię:Sebastian
  • Lokalizacja:Ostrołęka
Offline

Napisano 01.10.2010 19:08

Tabela się utworzyła, a to IP zmieniałem już kilka razy na nazwę strony i to nic nie pomagało, bo z bazą się łączy normalnie, tabela się tworzy, ale wpisów brak, znaczy w tej normalnej wersji i w tej edytowanej, bo jak wgram tą od kumpla, to wszystko normalnie działa. Oczywiście tabelę czyściłem przy zmianie moda.
  • +
  • -
  • 0
Posiadam TBM (inaczej PTB), które działa dużo lepiej niż zwykłe PTB, nawet na modach z lvlami. Zainteresowany? Proszę bardzo
Generator tabeli expa - aż do 103600 poziomu




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych