Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Cod mod lvl się nie zapisuje HELP


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1 Ekoludek

    Zaawansowany

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Olsztyn
Offline

Napisano 13.06.2010 12:54

Siemka mam taki problem dopisałem do nazwy QTM_codmod.amxx debug i wszystko fajnie działało aż tu nagle przestało zapisywać lvl po zmianie mapy co mam zrobić??

Oto error logi




L 06/12/2010 - 22:02:39: Start of error session.
L 06/12/2010 - 22:02:39: Info (map "cs_assault") (file "addons/amxmodx/logs/error_20100612.log")
L 06/12/2010 - 22:02:39: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:39: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:39: [AMXX] Run time error 10: native error (native "entity_set_int")
L 06/12/2010 - 22:02:39: [AMXX] [0] engine_stocks.inc::set_rendering (line 141)
L 06/12/2010 - 22:02:39: [AMXX] [1] QTM_CodMod.sma::UsunPrzedmiot (line 1371)
L 06/12/2010 - 22:02:39: [AMXX] [2] QTM_CodMod.sma::client_connect (line 684)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:42: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:42: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:42: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:42: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/12/2010 - 22:02:43: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/12/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/12/2010 - 22:02:43: [ENGINE] Invalid entity 15
L 06/12/2010 - 22:02:43: [AMXX] Displaying
  • +
  • -
  • 0

#2 Ojciec Dyrektor

    papa smerf.

  • Przyjaciel

Reputacja: 476
Wszechobecny

  • Postów:3035
  • Imię:Paweł
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 13.06.2010 13:06

0 - 22:02:43: [SILNIK] jednostka Nieprawidłowy 15
L 12/06/2010 - 22:02:43: [AMXX] Wyświetlanie debug trace (plugin "QTM_CodMod.amxx")
L 12/06/2010 - 22:02:43: [AMXX] Błąd Run 10: błąd ojczystym (native "entity_get_int")
L 12/06/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma:: PokazInformacje (linia 1499)
L 12/06/2010 - 22:02:43: [SILNIK] jednostka Nieprawidłowy 15
L 12/06/2010 - 22:02:43: [AMXX] Wyświetlanie debug trace (plugin "QTM_CodMod.amxx")
L 12/06/2010 - 22:02:43: [AMXX] Błąd Run 10: błąd ojczystym (native "entity_get_int")
L 12/06/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma:: PokazInformacje (linia 1499)
L 12/06/2010 - 22:02:43: [SILNIK] jednostka Nieprawidłowy 15
L 12/06/2010 - 22:02:43: [AMXX] Wyświetlanie debug trace (plugin "QTM_CodMod.amxx")
L 12/06/2010 - 22:02:43: [AMXX] Błąd Run 10: błąd ojczystym (native "entity_get_int")
L 12/06/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma:: PokazInformacje (linia 1499)
L 12/06/2010 - 22:02:43: [SILNIK] jednostka Nieprawidłowy 15
L 12/06/2010 - 22:02:43: [AMXX] Wyświetlanie debug trace (plugin "QTM_CodMod.amxx")
L 12/06/2010 - 22:02:43: [AMXX] Błąd Run 10: błąd ojczystym (native "entity_get_int")
L 12/06/2010 - 22:02:43: [AMXX] [0] QTM_CodMod.sma:: PokazInformacje (linia 1499)
L 12/06/2010 - 22:02:43: [SILNIK] jednostka Nieprawidłowy 15
L 12/06/2010 - 22:02:43: [AMXX] Wyświetlanie



boże, przerobiłeś .sma, i nie skompilowałeś do .amxx ..
  • +
  • -
  • 0

#3 Ekoludek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Olsztyn
Offline

Napisano 13.06.2010 13:34

No jak bym nie skomplikował to by na serwie nie działało nie?? myślisz trochę?? i czemu pisało Done jak komplikowałem?
  • +
  • -
  • 0

#4 Ojciec Dyrektor

    papa smerf.

  • Przyjaciel

Reputacja: 476
Wszechobecny

  • Postów:3035
  • Imię:Paweł
  • Lokalizacja:Rabka-Zdrój
Offline

Napisano 13.06.2010 13:38

skompilowałeś z błędami..
  • +
  • -
  • 0

#5 Ekoludek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Olsztyn
Offline

Napisano 13.06.2010 13:55

Niby jak jak z błędami się nie da...., i wszystko fajnie działało aż dziś do 12
  • +
  • -
  • 0

#6 QTM. Peyote

    Wszechpomocny

  • Użytkownik

Reputacja: 997
Master

  • Postów:330
  • GG:
  • Steam:steam
  • Imię:Mateusz
  • Lokalizacja:Polska
Offline

Napisano 13.06.2010 14:10

W funkcji PokazInformacje znajdź:
if(!is_user_alive(id))
i zmień na:
if(!is_user_alive(id) && is_user_connected(id))

Użytkownik QTM. Peyote edytował ten post 13.06.2010 14:12

  • +
  • -
  • 0

#7 Ekoludek

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:87
  • Lokalizacja:Olsztyn
Offline

Napisano 13.06.2010 14:17

Zrobiłem tak jak napisałeś, serwer znów padł i mam takie logi



L 06/13/2010 - 15:26:56: Start of error session.
L 06/13/2010 - 15:26:56: Info (map "de_dust2") (file "addons/amxmodx/logs/error_20100613.log")
L 06/13/2010 - 15:26:56: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:56: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/13/2010 - 15:26:56: [AMXX] Run time error 10: native error (native "entity_set_int")
L 06/13/2010 - 15:26:56: [AMXX] [0] engine_stocks.inc::set_rendering (line 141)
L 06/13/2010 - 15:26:56: [AMXX] [1] QTM_CodMod.sma::UsunPrzedmiot (line 1371)
L 06/13/2010 - 15:26:56: [AMXX] [2] QTM_CodMod.sma::client_connect (line 684)
L 06/13/2010 - 15:26:59: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:59: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/13/2010 - 15:26:59: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/13/2010 - 15:26:59: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/13/2010 - 15:26:59: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:59: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/13/2010 - 15:26:59: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/13/2010 - 15:26:59: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/13/2010 - 15:26:59: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:59: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/13/2010 - 15:26:59: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/13/2010 - 15:26:59: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/13/2010 - 15:26:59: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:59: [AMXX] Displaying debug trace (plugin "QTM_CodMod.amxx")
L 06/13/2010 - 15:26:59: [AMXX] Run time error 10: native error (native "entity_get_int")
L 06/13/2010 - 15:26:59: [AMXX] [0] QTM_CodMod.sma::PokazInformacje (line 1499)
L 06/13/2010 - 15:26:59: [ENGINE] Invalid entity 15
L 06/13/2010 - 15:26:59: [AMXX] Displayin

Użytkownik AmXuLic edytował ten post 13.06.2010 16:35

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych