Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Błąd z bazą danych


  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 Kluchaha

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:37
  • Lokalizacja:Kraków
Offline

Napisano 08.04.2010 17:53

Witam.
Mam problem z połączeniem się z bazą MySQL. Czytałem że jest możliwe że moja baza automatycznie ustawia sobie host 127.0.0.1 przez co robi się pętla .
Wersja AMX jakiej używam to 1.8.1. Tutaj macie logi jakie cały czas mi się pokazują :
L 04/09/2010 - 02:37:16: 04/09/2010 - 02:37:16 ### MAPA: de_dust2_mini ###
L 04/09/2010 - 02:37:23: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:37:23: Could not connect to SQL database.
L 04/09/2010 - 02:37:27: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:37:27: Could not connect to SQL database.
L 04/09/2010 - 02:37:27: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:37:27: Could not connect to SQL database.
L 04/09/2010 - 02:39:19: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:39:19: Could not connect to SQL database.
L 04/09/2010 - 02:39:22: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:39:22: Could not connect to SQL database.
L 04/09/2010 - 02:39:22: Error on Table query: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)
L 04/09/2010 - 02:39:22: Could not connect to SQL database.

Bardzo bym prosił o odpowiedź wraz z wyjaśnieniem jak wykonać dane czynności.
  • +
  • -
  • 0

#2 Tomi

    Wszechwidzący

  • Zbanowany

Reputacja: 8
Nowy

  • Postów:271
Offline

Napisano 08.04.2010 17:55

Odblokowales Mysql w Modules.ini?

#3 Kluchaha

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:37
  • Lokalizacja:Kraków
Offline

Napisano 08.04.2010 18:07

tak, odblokowałem


modules.ini :
;;;
; To enable a module, remove the semi-colon (;) in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time. Use ;;
;; amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here. ;;
;; You can just list their names, without the _amxx ;;
;; or file extension. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded ;;
;; as needed. You do not need to enable them here ;;
;; unless you have problems. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
hamsandwich
  • +
  • -
  • 0

#4 false

    Wszechmogący

  • Użytkownik

Reputacja: 53
Pomocny

  • Postów:652
  • Lokalizacja:z Polski
Offline

Napisano 08.04.2010 21:38

tak, odblokowałem


modules.ini :
;;;
; To enable a module, remove the semi-colon (;) in front of its name.
; If it's not here, simply add it its name, one per line.
; You don't need to write the _amxx part or the file extension.
;;;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; SQL Modules usually need to be enabled manually ;;
;; You can have any number on at a time. Use ;;
;; amx_sql_type in sql.cfg to specify the default ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

mysql
sqlite

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; Put third party modules below here. ;;
;; You can just list their names, without the _amxx ;;
;; or file extension. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;



;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; These modules will be auto-detected and loaded ;;
;; as needed. You do not need to enable them here ;;
;; unless you have problems. ;;
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

fun
engine
fakemeta
geoip
sockets
regex
nvault
cstrike
csx
hamsandwich


Pokaz sql cfg
  • +
  • -
  • 0

#5 Vertricus

    Godlike

  • Przyjaciel

Reputacja: 426
Wszechobecny

  • Postów:1549
  • Lokalizacja:.
Offline

Napisano 08.04.2010 21:56

Cvary z diablo do amxx.cfg
w tym wypadku nie ustawione bo do localnego próbuje się podpiąć a się nie da tzn. go nie ma:>
Masz bazę wykupioną gdzies?
  • +
  • -
  • 0

#6 Kluchaha

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:37
  • Lokalizacja:Kraków
Offline

Napisano 09.04.2010 06:58

Bazę danych mam wykupioną na niceshoot.pl i baza danych może nawiązać połączenie z kimś z zewnątrz ( dodałem "%" do hosta" )


sql.cfg :

amx_sql_host "195.2.255.175"
amx_sql_user "karolk955_wypasi"
amx_sql_pass "moje hasło ;-)"
amx_sql_db "karolk955_wypasi"
amx_sql_table "dbmod"
amx_sql_type "mysql"
  • +
  • -
  • 0

#7 Vertricus

    Godlike

  • Przyjaciel

Reputacja: 426
Wszechobecny

  • Postów:1549
  • Lokalizacja:.
Offline

Napisano 09.04.2010 07:23

Cvary do konfiguracji są inne ;>
To nie cvary typu amx_sql_host :>
Zapraszam do tematu z którego ściągałeś diablomod'a :>
  • +
  • -
  • 0

#8 Tomi

    Wszechwidzący

  • Zbanowany

Reputacja: 8
Nowy

  • Postów:271
Offline

Napisano 09.04.2010 07:46

diablo_sql_host "195.2.255.175"
diablo_sql_user "karolk955_wypasi"
diablo_sql_pass "HASLO"
diablo_sql_database "karolk955_wypasi"
diablo_sql_table "dbmod"
:)
to 1/3 co masz dodac do amxx.cfg




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych