Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Problem z pluginem


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 skuziak

    Życzliwy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:37
  • Lokalizacja:Stolica
Offline

Napisano 13.03.2010 18:52

Chce mieć plugin że gdy zabije gracza przez HS to odegra się jeden z 3 dźwięków, problem w tym że plugin nie działa. Jakieś rady ?

/* Plugin generated by AMXX-Studio */

#include <amxmodx>
#include <cstrike>
//#include <csx>

#define PLUGIN "HS"
#define VERSION "1.0"
#define AUTHOR "Skuziak"

public plugin_init() 
{
	register_plugin(PLUGIN, VERSION, AUTHOR)
}


new g_Wav[][] = 
{
	"misc/hs",
	"misc/hs2",
	"mics/hs3"
};

public client_death(killer,victim,weapon,hitplace,TK) 
{
	
	if(!killer || !victim || TK)
		return;
	
	if(hitplace == HIT_HEAD)
	{
		client_cmd(0,"spk %s",g_Wav[random(sizeof g_Wav)]);
	}
}

public plugin_precache() 
{
	precache_sound("misc/hs.wav");
	precache_sound("misc/hs1.wav");
	precache_sound("misc/hs2.wav");
}

  • +
  • -
  • 0

#2 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 13.03.2010 23:13

Wpisz sobie w konsoli gry:

spk mics/hs3

jak dobra sciezka do pliku to bedzie dzwiek i plug jest winny, jak nie ma dzwieku... to dodaj .wav na koniec? :F
  • +
  • -
  • 0

#3 skuziak

    Życzliwy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:37
  • Lokalizacja:Stolica
Offline

Napisano 14.03.2010 14:05

Nie działa :(
Nie odtwarza mi dźwięku
  • +
  • -
  • 0

#4 andrew8666

    Pomocny

  • Użytkownik

Reputacja: 9
Nowy

  • Postów:57
  • Lokalizacja:Opolskie
Offline

Napisano 16.03.2010 08:17

To wybrałeś pliki .wav w "zbyt dużej" jakości, poszukaj było jak to "pogorszyć" :P
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych