Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Prościutki Plugin


  • Zamknięty Temat jest zamknięty
8 odpowiedzi w tym temacie

#1 .minD

    Wszechobecny

  • Użytkownik

Reputacja: 58
Pomocny

  • Postów:451
  • Lokalizacja:Łódź
Offline

Napisano 29.12.2009 21:04

Witam
Proszę aby ktoś mi przerobił ten plugin żeby /respawn wpisywał się TYLKO MARTWYM ( jeżeli sie nie da to martwym i żywym)

#include <amxmodx>

new param[1];
public plugin_init() {
register_plugin("New Plug-In", "1.0", "PortuS")
}

public client_putinserver(id) {
param[0] = id;
set_task(10.0,"pisz",id,param,1)
}
public pisz(param[1]){
new id = param[0];
client_cmd(id, "say /respawn")
}


Użytkownik TomCraft edytował ten post 29.12.2009 21:07

  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 29.12.2009 21:11

zamiast:

client_cmd(id, "say /respawn")

daj:
if (is_user_alive(id))
		client_cmd(id, "say /respawn")

  • +
  • -
  • 1

#3 .minD

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 58
Pomocny

  • Postów:451
  • Lokalizacja:Łódź
Offline

Napisano 29.12.2009 21:29

nie działa

chcę żeby tylko MARTWI to wpisywali OD RAZU po podłaczeniu się pod serwa i wybraniu drużyny :)
  • +
  • -
  • 0

#4 Miczu

    Godlike

  • Przyjaciel

Reputacja: 646
Wszechmogący

  • Postów:2862
Offline

Napisano 29.12.2009 21:30

zamiast:

daj:

if (is_user_alive(id))
		client_cmd(id, "say /respawn")


Ja bym zanygowal is_user_alive :F

if (!is_user_alive(id))
		client_cmd(id, "say /respawn")

  • +
  • -
  • 0

#5 .minD

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 58
Pomocny

  • Postów:451
  • Lokalizacja:Łódź
Offline

Napisano 29.12.2009 21:37

omg

skrypterzy a prostego pluga nie rozkminią
zachwile przetestuje
:)


@edit

podłączam się pod serwa w połowie rundy i nic mi nie pisze w /say x(

Użytkownik TomCraft edytował ten post 29.12.2009 21:44

  • +
  • -
  • 0

#6 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 29.12.2009 21:44

omg

skrypterzy a prostego pluga nie rozkminią
zachwile przetestuje
:)

omg, ale ty masz problemy...
chciałem ci na szybko to dać i przeoczyłem wykrzyknika, normalnie koniec świata ;>
  • +
  • -
  • 1

#7 DarkGL

    Nie oddam ciasteczka !

  • Administrator

Reputacja: 6032
Godlike

  • Postów:10825
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 29.12.2009 21:45

dostałeś odemnie pw odrazu jak pavulon zamknął tamten temat :>
  • +
  • -
  • 1

#8 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 29.12.2009 21:48

komuś "new param[1];" wyleciało z funkcji ^D^

Trzymaj ten kod:
#include <amxmodx>

public plugin_init()
register_plugin("New Plug-In", "1.0", "PortuS")

public client_putinserver(id)
set_task(10.0,"pisz",id)

public pisz(id)
if (!is_user_alive(id))
client_cmd(id, "say /respawn")

  • +
  • -
  • 1

#9 .minD

    Wszechobecny

  • Autor tematu
  • Użytkownik

Reputacja: 58
Pomocny

  • Postów:451
  • Lokalizacja:Łódź
Offline

Napisano 29.12.2009 21:55

cóź, każdy jest tylko człowiekiem i każdy popełnia błędy

Open, nie ogarniam jeszcze stylu forum i nie zauwazyłem że mam wiadomosć ( teraz to się nazywa komunikator ^^)

zachwile przetestuje

@pavulon

teraz w ogóle nie działa ^D^

Użytkownik TomCraft edytował ten post 29.12.2009 22:08

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych