Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Dziwny problem z roundsound'em w mp3


  • Zamknięty Temat jest zamknięty
11 odpowiedzi w tym temacie

#1 Spolar

    Nowy

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 13.12.2009 23:40

Witam!

Mam dosyć dziwny problem z zrobieniem roundsounda na serwerze - mianowicie przy wykorzystaniu pluginu:

alt_end_round_sounds.amxx - nikomu na serwerze nie grała muzyka oprócz mnie (mi grała z zupełnie innego serwera)

sound_mp3.amxx - w oryginale wszystko działało póki nie zaszła potrzeba zmiany muzyczek... po zmianie nazw przekompilowałem plugin i wrzuciłem na serwer... niestety gra tylko 1 utwór - fioletowi6.mp3




#include <amxmodx> 

new const sounds_ct[][] = {"sound/misc/fioletowi1.mp3","sound/misc/fioletowi2.mp3","sound/misc/fioletowi3.mp3"} 

new const sounds_terro[][] = {"sound/misc/fioletowi4.mp3","sound/misc/fioletowi5.mp3","sound/misc/fioletowi6.mp3"} 

public plugin_init() 
{ 
  register_plugin("RoundSoundy","1","Sal") 
  register_event("SendAudio", "ct", "a", "2&%!MRAD_ctwin") 
  register_event("SendAudio", "terro", "a", "2&%!MRAD_terwin") 
} 

public plugin_precache() 
{ 
  new i 
  for(i = 0; i < sizeof sounds_ct; i++) 
  precache_generic(sounds_ct[i]) 

  new u 
  for(u = 0; u < sizeof sounds_terro; u++) 
  precache_generic(sounds_terro[u]) 
} 

public ct() 
{ 
  client_cmd(0,"stopsound") 

  client_cmd(0, "mp3 stop") 

  client_cmd(0, "mp3 play %s", sounds_ct[random_num(0, charsmax(sounds_ct))] ) 
} 

public terro() 
{ 
  client_cmd(0,"stopsound") 

  client_cmd(0, "mp3 stop") 

  client_cmd(0, "mp3 play %s", sounds_terro[random_num(0, charsmax(sounds_terro))] ) 
}

Nie wiem czy w przypadku roundsounda w mp3 mają znaczenie parametry muzyki tak jak jest to przy wav?

Oto parametry moich muzyczek:

fioletowi1.mp3 stereo 128 kb/s 44kHz
fioletowi2.mp3 stereo 128 kb/s 44kHz
fioletowi3.mp3 stereo 128 kb/s 44kHz
fioletowi4.mp3 stereo 128 kb/s 44kHz
fioletowi5.mp3 stereo 128 kb/s 44kHz
fioletowi6.mp3 stereo 64 kb/s 24kHz

Wygląda na to że jednak mają rolę parametry - jeśli mi to ktoś potwierdzi to przekonwenteruje utworki :^D ..a jeśli nie to bardzo proszę o podanie mi działającego pluginu do roundsounda w mp3 :blaga: a pięknie by było gdyby komuś się chciało zaaplikować moje nazwy muzyczek do niego :lol:
  • +
  • -
  • 0

#2 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 13.12.2009 23:56

Wygląda na to że jednak mają rolę parametry

No co ty nie powiesz xD

Bystry jesteś skoro zauważyłeś że działa tylko ta piosenka z innymi parametrami ;)
A nie wpadłeś też na to żeby samemu sprawdzić czy po konwersji i inne zadziałają ?
Było by o wiele szybciej.
  • +
  • -
  • 0

#3 ReKsiu

    Zaawansowany

  • Użytkownik

Reputacja: 18
Początkujący

  • Postów:85
Offline

Napisano 14.12.2009 14:32

Dołączam się do tematu.
Może ktoś podać dokładne dane jakie mają mieć pliki .mp3?
Chodzi mi o dokładnie wszystkie dane. Często szukam i nie ma napisane np czy ma być Const Bit rate ile?
Albo inne. Może ktoś dać poprawne dane?
  • +
  • -
  • 0

#4 Spolar

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 14.12.2009 14:46

Pavolon - no widzi kolega na innych forach rożnie piszą.. zacytuje

.mp3 moze byc jakiekolwiek



Stad moje może trochę głupie pytanie...
  • +
  • -
  • 0

#5 evl

    Początkujący

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:15
  • Lokalizacja:TG
Offline

Napisano 14.12.2009 14:51

Autorze tematu, ja się Ciebie pytam. Co ty w ogóle robisz???!!!
Na forum jest end round sounds plugin który po prostu wrzucasz a piosenki edytujesz w folderze configs w pliku roundsound...

Dam Ci linka bo nie wiem czy jesteś leniem :P
KLIK

PS. Dałem linka bo Ty jak chcesz zmienić muzyke to edytujesz cały plugin, a po co? Można to zrobić zmieniając jeden plik cfg.

A dołączam się do kolegi wyżej.
.MP3 może być jakiekolwiek !

  • +
  • -
  • 0

#6 Spolar

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 14.12.2009 15:16

Pavulon - niestety konwersja muzyczek nie pomogła...

evl - plugin jest mi dobrze znany... :) już próbowałem go wykorzystać bez rezultatu.. spróbuję jeszcze raz :>


Edit:
Niestety kolejna próba nieudana... nadal odtwarza się 1 ten sam utwór :/
  • +
  • -
  • 0

#7 Wez

    Pomocny

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:50
  • GG:
Offline

Napisano 15.12.2009 16:01

Wyślij mi muzykę która chcesz na serwerze, zrobię Ci to w alt_end_round_sounds.
  • +
  • -
  • 0

#8 Spolar

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 15.12.2009 17:39

Dzwięki poszły na PW :D

Co prawda nei wydaje mi się żebym robił coś źle no ale :)

Tak wygląda mój roundsound.ini

; CT Sounds
"sound/misc/fiolet1.mp3" "CT"
"sound/misc/fiolet2.mp3" "CT"
"sound/misc/fiolet3.mp3" "CT"

; T Sounds
"sound/misc/fiolet4.mp3" "T"
"sound/misc/fiolet5.mp3" "T"
"sound/misc/fiolet6.mp3" "T"

Wypróbowałem kolejny plugin... (link)

Konsola wypluwa ze załadował poprawnie 6 dźwięków... - gra 1 :)

Potne jeszcze raz dźwięki tym razem MP3 Kinfe'em :)

Edit:
Zrobiłem nowe dzwięki Mp3Knifem i zapożyczyłem parę z innego soundpack'a :) - grają tylko te z innego soundpacka'a po mouch ani słychu ani dychu... wymiękam... : : :
  • +
  • -
  • 0

#9 evl

    Początkujący

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:15
  • Lokalizacja:TG
Offline

Napisano 15.12.2009 19:02

Boże, chłopie. Bierzesz pewnie jakieś zmutowane piosenki i próbujesz je wrzucić. Wrzuć sobie na początek muze z cstrike. Ja używam Alternative End Round Sounds i wszystko działa bez zarzutu, bez błędów. Ten plugin nigdy mnie nie zawiódł, a to że ty zrobiłeś coś źle to nie moja wina. Bierzesz jakieś tandetne pluginy, a najlepszy jest właśnie Alternative End Round Sounds. Pomyślałeś może żeby wrzucić te piosenki naprzykład do folderu "fiolet" w misc i nazwać każdą piosenkę na przykład CT1, CT2, TT1, TT2 ? Albo że masz jakieś stare amxx (zmutowane ^^)

Pozdrawiam, życze miłego bawienia się tandetnymi pluginami 100 lat...
Wiesz co ja zrobiłem ostatnio? Nie działała mi połowa pluginów, tzn. tak samo z roundsoundem itp.
I tak, ja miałem amxx 1.7 coś tam. Ściągnąłem gotową paczke amxx i powyrzucałem te all pluginy (tylko sobie 2 zostawiłem) i powrzucałem te wszystkie które mi nie działały. I nagle olśnienie, działa :) Więc postanowiłem że all wrzuce do tego amxx i dam to serwer. Działa wyśmienicie...


Sorry za błędy i "debilstwa" napisane innym językiem w tym poście :D
Spróbuj tak jak ja, może akurat zadziała!!
  • +
  • -
  • 0

#10 Spolar

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 15.12.2009 20:02

Chłopie! :]

Dźwięki normalnie mi grają w winzgrozie? Dziwne prawda? - jak na zmutowane... :lol:

AMXX - 1.81 czysty z tego forum... i raczej przeinstalowywać nie mam zamiaru :(

Dziwne też jest, że tylko piosenki pocięte przeze mnie nie działają :)

Czekam na konstruktywną wypowiedź :wstyd:

PS
Pluginu "AERS" używałem nie raz a taka sytuacja zdarza mi się po raz pierwszy
  • +
  • -
  • 0

#11 Wez

    Pomocny

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:50
  • GG:
Offline

Napisano 16.12.2009 15:25

Sorki ze tak późno ale teraz znalazłem chwile czasu :>
podam ci szybka instalacje :

configs wrzuć do addons/amxmodx/
data to samo
plugins to samo 
scripting to samo
sound do cstrike/

w plugins.ini dopisz :

alt_end_round_sounds.amxx

w amxx.cfg dopisz na samym dole:

ers_enabled 1 
ers_player_toggle 1  
erc_time_ads 120   
erc_random_precache 3

i zobacz czy masz te komendy:

sv_allowdownload "1"
sv_allowupload "1"


Mi na serw działa to w 100 %% jak to wrzucisz daj resa serw i pokarz co masz w logach :>

Załączone pliki


  • +
  • -
  • 0

#12 Spolar

    Nowy

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:6
  • Lokalizacja:sie biora dzieci
Offline

Napisano 16.12.2009 16:06

Serwer wypluł wszystko poprawnie :]

L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] ---
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowitt2.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowitt1.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowitt.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] [ Loading 3 Ts Sounds ]
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] ---
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowict2.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowict1.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] - sound/misc/fioletowict.mp3
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] [ Loading 3 CTs Sounds ]
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] ---
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] Wczytywanie pliku: "addons/amxmodx/config/roundsound.ini"
L 12/16/2009 - 15:52:37: [alt_end_round_sounds.amxx] ---

Plugin funkcjonuje:

Scoring will not start until both teams have players
[ERS] Say /roundsound to enable or disable the end round sounds for you.

Lecz nadal gra jeden dźwięk zapożyczony z innej paczki :(

W związku z czym poproszę program do przycinania muzyczek - nadający się pod roundsoundy :blaga:

[ Dodano: 16-12-2009, 17:06 ]
Temat do zamknięcia


Pomógł mi poradnik znaleziony u konkurencji http://www.cscenter.pl/scripting_help/17416-poradnik_jak_zrobic_roundsound.html

Pomógł powędrowały :]
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych