Skocz do zawartości

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie działają dodane modele


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
12 odpowiedzi w tym temacie

#1 Vanilla

    Zaawansowany

  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 03.02.2021 10:15

Cześć mam problem, po dodaniu modeli vipa przez wiele pluginów, modele nie działały - na początku rundy wyświetlał sie tylko na 1 sekunde, a później pojawiał sie domyślny. Jest wgrane cs_player_models_api lecz w konsoli pojawia sie to:

 

 

 

L 02/03/2021 - 10:10:27: [AMXX] Run time error 10: native error (native "cs_set_user_model")
 

 

Być może to jest z tym związane. Ktoś wie jak to naprawić? :(


  • +
  • -
  • 0

#2 Misiu.

    Kochanek DarkGL

  • Użytkownik

Reputacja: 107
Zaawansowany

  • Postów:439
  • GG:
  • Steam:steam
  • Imię:Adrian
  • Lokalizacja:Zgorzelec
Offline

Napisano 03.02.2021 10:56

dopisz debug do pluginu i pokaż szczegółowe logi


  • +
  • -
  • 0

PoGrywamy.pl - Pograj Razem Z Nami

 

Tatusiek serwerów:

[ONLY DD2 #2] 1shot2kill.pl

[ONLY DD2] PoGrywamy.pl

Przyjmuje płatne zlecenia!


#3 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 03.02.2021 10:58

W jaki sposób sie sprawdza logi?


  • +
  • -
  • 0

#4 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 03.02.2021 21:12

Widze błąd, ale mam problem z kompilacją

 

// C:\Users\User\Desktop\compiler\skinmafioza.sma(63) : warning 217: loose indentation

      new CsTeams:userTeam = cs_get_user_team(id);

 

 

 

 

// C:\Users\User\Desktop\compiler\skinmafioza.sma(97) : error 001: expected token: "}", but found "-end of file-"
 

 
                }
 
        }
 
        {return HAM_IGNORED;
}

 


  • +
  • -
  • 0

#5 Alelluja

    Miszcz jotbe

  • Power User

Reputacja: 456
Wszechobecny

  • Postów:928
  • GG:
Offline

Napisano 04.02.2021 02:28

Nie za dziwnie wygląda ta klamra otwierająca? 

{return HAM_IGNORED;

  • +
  • -
  • 0

Moje Pluginy | Paczki:
------> http://amxx.pl/topic...od/#entry687942 <------ 500 Postów 27.05.2015
------> http://amxx.pl/topic...monety-lombard/<------
------> http://amxx.pl/topic...-na-ammo-packi/<------


#6 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 04.02.2021 07:58

Po usunięciu klamry pojawia sie ten błąd: 

 

// C:\Users\User\Desktop\compiler\skinmafioza.sma(98) : error 054: unmatched closing brace


  • +
  • -
  • 0

#7 Misiu.

    Kochanek DarkGL

  • Użytkownik

Reputacja: 107
Zaawansowany

  • Postów:439
  • GG:
  • Steam:steam
  • Imię:Adrian
  • Lokalizacja:Zgorzelec
Offline

Napisano 04.02.2021 08:48

Pokaż całe .sma


  • +
  • -
  • 0

PoGrywamy.pl - Pograj Razem Z Nami

 

Tatusiek serwerów:

[ONLY DD2 #2] 1shot2kill.pl

[ONLY DD2] PoGrywamy.pl

Przyjmuje płatne zlecenia!


#8 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 04.02.2021 09:08

#include <amxmodx>
 
#include <cstrike>
 
#include <cs_player_models_api>
 
#include <hamsandwich>
 
 
 
new const gNazwaPluginu[] = "JailBreak - Modele";
 
new const gWersjaPluginu[] = "1";
 
new const gAutorPluginu[] = "noFear";
 
 
 
new const gModelAdminCT[] = "jb_mafiozoct";
 
new const gModelAdminCTPobieranie[] = "models/player/jailbreak_mafiozoct/jb_mafiozoct.mdl";
 
new const gModelAdminTT[] = "jb_mafiozott";
 
new const gModelAdminTTPobieranie[] = "models/player/jailbreak_mafiozott/jb_mafiozott.mdl";
 
 
 
public plugin_init()
 
{
 
        register_plugin(gNazwaPluginu, gWersjaPluginu, gAutorPluginu);
 
        
 
        RegisterHam(Ham_Spawn, "player", "fwSpawn", 1); 
 
}
 
 
 
public plugin_precache()
 
{
 
        precache_model(gModelAdminCTPobieranie);
 
        precache_model(gModelAdminTTPobieranie);
 
}
 
 
 
public Spawn(id)
{
if (!is_user_alive(id))
 
                return HAM_IGNORED;
 
        
 
        new CsTeams:userTeam = cs_get_user_team(id);
 
        
 
        if(get_user_flags(id) & ADMIN_LEVEL_G)
 
        {       
 
                if (userTeam == CS_TEAM_T)
 
                {
 
                        cs_set_player_model(id, gModelAdminTT);
 
                }
 
                else if(userTeam == CS_TEAM_CT)
 
                {
 
                        cs_set_player_model(id, gModelAdminCT);
 
                }
 
                else
 
                {
 
                        cs_reset_player_model(id);
 
                }
 
        }
 
        return HAM_IGNORED;
}

  • +
  • -
  • 0

#9 Misiu.

    Kochanek DarkGL

  • Użytkownik

Reputacja: 107
Zaawansowany

  • Postów:439
  • GG:
  • Steam:steam
  • Imię:Adrian
  • Lokalizacja:Zgorzelec
Offline

Napisano 04.02.2021 10:22

Pobierz i skompiluj ten plik, nie przeklejaj zawartości

 

Załączony plik  modele.sma   1,18 KB  4 Ilość pobrań
  modele.amxx


  • +
  • -
  • 0

PoGrywamy.pl - Pograj Razem Z Nami

 

Tatusiek serwerów:

[ONLY DD2 #2] 1shot2kill.pl

[ONLY DD2] PoGrywamy.pl

Przyjmuje płatne zlecenia!


#10 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 04.02.2021 13:50

Niestety nie działa, w konsoli:

 

 

L 02/04/2021 - 13:46:06: [AMXX] Run time error 10: native error (native "set_user_rendering"
L 02/04/2021 - 13:46:07: [CSTRIKE] Model can not be empty
L 02/04/2021 - 13:46:07: [AMXX] Run time error 10: native error (native "cs_set_user_model")
 
W amxx plugins plugin działa

  • +
  • -
  • 0

#11 Misiu.

    Kochanek DarkGL

  • Użytkownik

Reputacja: 107
Zaawansowany

  • Postów:439
  • GG:
  • Steam:steam
  • Imię:Adrian
  • Lokalizacja:Zgorzelec
Offline

Napisano 04.02.2021 14:31

Błędy nie pochodzą od tego pluginu, nie ma w nim nawet takich natywów.

 


  • +
  • -
  • 0

PoGrywamy.pl - Pograj Razem Z Nami

 

Tatusiek serwerów:

[ONLY DD2 #2] 1shot2kill.pl

[ONLY DD2] PoGrywamy.pl

Przyjmuje płatne zlecenia!


#12 Vanilla

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 1
Nowy

  • Postów:90
Offline

Napisano 04.02.2021 15:06

Czy domyslne modele mogą jakos podwazac dodane modele? Gdyz na poczatku rundy model wyswietla sie na sekunde i znika


  • +
  • -
  • 0

#13 Alelluja

    Miszcz jotbe

  • Power User

Reputacja: 456
Wszechobecny

  • Postów:928
  • GG:
Offline

Napisano 04.02.2021 15:31

Ja na JB mam ustawianie modeli ustawione w Silniku dzięki czemu nie ma problemu z tym co napisałeś na górze.

 

W funkcji Odrodzenie(id)

 

Zrób to po prostu ifami i powinno wszystko działać.


  • +
  • -
  • 0

Moje Pluginy | Paczki:
------> http://amxx.pl/topic...od/#entry687942 <------ 500 Postów 27.05.2015
------> http://amxx.pl/topic...monety-lombard/<------
------> http://amxx.pl/topic...-na-ammo-packi/<------





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych


Coinsy CSGOAtse Za SMS, PSC , Przelew - CoinSell.pl