Skocz do zawartości

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[ROZWIĄZANE] Niedziałający VIPVIP z generatora mi nie dziala

vip problem

  • Zamknięty Temat jest zamknięty
12 odpowiedzi w tym temacie

#1 Assorri

    Pomocny

  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 01.04.2020 19:47

Zrobiłem VIPa z kompilatora, wyczytałem dodatkowo, że jeśli ma działać ten VIP to musze wywalić z pliku SMA :

g_VIP[id]=true;

g_VIP[id]=false;

bool : g_VIP[33]

 

i za "g_VIP" wrzucić to "(get_user_flags(id) & FLAGA_VIP)"

 

Skiny VIPa mi odczytuje, a reszty już nie

 

Załączam plik .sma


  • +
  • -
  • 0

#2 esej

    Profesjonalista

  • Użytkownik

Reputacja: 55
Pomocny

  • Postów:195
  • Steam:steam
  • Imię:Daniel
  • Lokalizacja:Warszawa
Offline

Napisano 01.04.2020 20:20

no pliku sma nie dołączyłeś i nie rozumiem tego co napisałeś więc może przeczytaj i spróbuj jeszcze raz wytłumaczyć. 


  • +
  • -
  • 0

#3 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 01.04.2020 20:57

Zrobiłem VIPa z kompilatora, wyczytałem dodatkowo, że jeśli ma działać ten VIP to musze wywalić z pliku SMA :

g_VIP[id]=true;

g_VIP[id]=false;

bool : g_VIP[33]

 

i za "g_VIP" wrzucić to "(get_user_flags(id) & FLAGA_VIP)"

 

Skiny VIPa mi odczytuje, a reszty już nie

 

Załączam plik .sma

 

No zrobiłem VIPa z generatora* i jak wgrałem na serwer to nie chce działać, reszta jest chyba zrozumiala ;P

Załączone pliki


Użytkownik Assorri edytował ten post 01.04.2020 20:59

  • +
  • -
  • 0

#4 Devastator

    Zaawansowany

  • Użytkownik

Reputacja: 50
Pomocny

  • Postów:100
  • GG:
  • Imię:Mateusz
  • Lokalizacja:Rzeszow
Offline

Napisano 01.04.2020 23:48

if"(get_user_flags(id) & FLAGA_VIP){               co to jest?

Po 1 nie masz zdefiniowanej FLAGA_VIP, a po drugie początek jakiś cudzysłów,

Na początku pliku dodaj 

#define FLAGA_VIP ADMIN_LEVEL_H

I pozamieniaj te cudzysłowy na to

if(get_user_flags(id) & FLAGA_VIP){

Użytkownik Devastator edytował ten post 01.04.2020 23:50

  • +
  • -
  • 1

#5 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 02.04.2020 09:10

 
VIP Ultimate       12.3.0.2    benio101 & speed  vip.amxx         paused   
 
Nie działa nadal ;/ Mam wersje AMXa 1.8.3 i skompilowałem kompilatorem 1.8.3 i nadal nie działa

  • +
  • -
  • 0

#6 Rivit

    Godlike

  • Support Team

Reputacja: 1 278
Godlike

  • Postów:4 294
Offline

Napisano 02.04.2020 10:35

wiecej info. Zobacz w error logi. Zobacz co sie wypisuje w konsoli serwera jak startuje (szukaj tam wlasnie wpisow o vipie).

Bo taka informacja mało mówi :/


  • +
  • -
  • 0

Na PW pomagam tylko odpłatnie. Przyjmuje zlecenia.

Wypociny: https://github.com/r...98/AMXX_plugins


#7 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 02.04.2020 11:53

Problem tkwi w tym, że żadne errory sie nie pokazują, tylko przez konsole widzę że plugin "paused"


  • +
  • -
  • 0

#8 dredek

    Wszechobecny

  • Użytkownik

Reputacja: 162
Profesjonalista

  • Postów:475
  • GG:
  • Imię:Dawid
  • Lokalizacja:OLK
Offline

Napisano 02.04.2020 11:57

Wejdź cstrike/addons/amxmodx/configs/pausecfg.ini i zobacz czy nie masz tam dodanego pluginu od vipa, jesli masz to wywal go, zmień mapę i zobacz.


  • +
  • -
  • 0

#9 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 02.04.2020 13:34

Wejdź cstrike/addons/amxmodx/configs/pausecfg.ini i zobacz czy nie masz tam dodanego pluginu od vipa, jesli masz to wywal go, zmień mapę i zobacz.

Nie dziala nadal ;/


  • +
  • -
  • 0

#10 Rivit

    Godlike

  • Support Team

Reputacja: 1 278
Godlike

  • Postów:4 294
Offline

Napisano 02.04.2020 13:40

w konsoli musza byc logi dotyczące vipa. musisz dobrze sprawdzic.

bez tego nie jestesmy w stanie pomoc niestety


  • +
  • -
  • 0

Na PW pomagam tylko odpłatnie. Przyjmuje zlecenia.

Wypociny: https://github.com/r...98/AMXX_plugins


#11 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 02.04.2020 19:42

w konsoli musza byc logi dotyczące vipa. musisz dobrze sprawdzic.

bez tego nie jestesmy w stanie pomoc niestety

Tylko że nic się nie pojawia o VIPie ani SVIPie (SVIP mi działa ale nie mam plikow SMA ;P)


  • +
  • -
  • 0

#12 Assorri

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 0
zer0.

  • Postów:46
  • Imię:Dawid
Offline

Napisano 03.04.2020 23:45

/close


  • +
  • -
  • 0

#13 DarkGL

    Nie oddam ciasteczka !

  • Właściciel

Reputacja: 6 513
Godlike

  • Postów:11 875
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 04.04.2020 11:58

Wiadomość wygenerowana automatycznie


Ten temat został zamknięty przez moderatora.

Powód: Pomoc udzielona

Jeśli się z tym nie zgadzasz, report.png raportuj ten post, a moderator lub administrator rozpatrzy go ponownie.


Z pozdrowieniami,
Zespół AMXX.PL
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: vip, problem

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych


Coinsy CSGOAtse Za SMS, PSC , Przelew - CoinSell.pl