Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Błąd przy kompilacji


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
4 odpowiedzi w tym temacie

#1 Anonymuss

    Pomocny

  • Użytkownik

Reputacja: 11
Początkujący

  • Postów:72
  • Imię:Anonimowy
  • Lokalizacja:Polska
Offline

Napisano 31.01.2018 11:48

O co chodzi z tym błędem? Pierwsza linijka dodany inc. amxmodx dobrze i kod też wygląda jak powinien:

 

// C:\Kompilator\Skiny_Kos_AWP.sma<1> : error 10: invalid function or declaration

 


  • +
  • -
  • 0

#2 Puchate

    Wszechobecny

  • Użytkownik

Reputacja: 203
Profesjonalista

  • Postów:433
  • Lokalizacja:Polska
Offline

Napisano 31.01.2018 13:01

Bez kodu nikt Ci nie pomoże ;)


  • +
  • -
  • 0

#3 Anonymuss

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 11
Początkujący

  • Postów:72
  • Imię:Anonimowy
  • Lokalizacja:Polska
Offline

Napisano 31.01.2018 13:11

Bez kodu nikt Ci nie pomoże ;)

Prosz

Załączone pliki


  • +
  • -
  • 0

#4 Hose

    Życzliwy

  • Użytkownik

Reputacja: 3
Nowy

  • Postów:23
  • GG:
  • Steam:steam
  • Imię:Kamil
  • Lokalizacja:Piaseczno
Offline

Napisano 31.01.2018 20:16

Błod w "#include <amxmodx>"

 

Po poprawieniu wpisu wyskakuje taki error lecz kompiluje
 
Warning: Symbol is assigned a value that is never used: "Weapon" on line 273
 
Czyli plugin nie ma uzytej wartosci "Weapon" Trzeba ja dopisac 
Lub usunac:
 
"public CurWeapon(id)
{
if(!is_user_alive(id))
return PLUGIN_HANDLED;
 
new Weapon = read_data(2)
// Set Knife Model
SetKnife(id, knife_model[id])
SetAWP(id, awp_model[id])
 
return PLUGIN_HANDLED   
 
}
 
 

 

 

Załączone pliki


  • +
  • -
  • 0

logo2.png8.gif


#5 _McHappy

    Wszechobecny

  • Użytkownik

Reputacja: 207
Profesjonalista

  • Postów:454
  • GG:
  • Imię:Radek
  • Lokalizacja:Tak
Offline

Napisano 31.01.2018 21:35

O co chodzi z tym błędem? Pierwsza linijka dodany inc. amxmodx dobrze i kod też wygląda jak powinien:

// C:\Kompilator\Skiny_Kos_AWP.sma<1> : error 10: invalid function or declaration


Niepoprawne kodowanie pliku źródłowego (*.sma).
W graficznym interfejsie edytora nic szczególnego nie widać, jednak na początku kodu znajdują się dodatkowe znaki, których kompilator nie rozumie (mam na myśli znacznik BOM).

Problem można naprawić zmieniając kodowanie pliku *.sma na UTF-8 bez BOM ( więcej w tej kwestii dowiesz się tu: http://bloggimasz.bl...otepad.html?m=1 ).


Użytkownik _McHappy edytował ten post 31.01.2018 21:49

  • +
  • -
  • 0
b_350_20_19FF07_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_00FF00_000000_FFFFFF.png




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych