Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Nie mogę dodać serwera do ulubionych - w status pokazuje IP lokalne


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
3 odpowiedzi w tym temacie

#1 Makale

    Wszechwidzący

  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:233
  • Lokalizacja:Płock
Offline

Napisano 24.11.2017 21:19

Witajcie. Mam na swojej maszynie postawionej gdzieś w świecie debianka i postawiony serwerek CS'a. Klient oryginał STEAM. Z serwerem mogę się połączyć wpisując: connect IP + PORT natomiast nie mogę dodać serwera do ulubionych. Do GameTrackera serwer dodaje się bez problemu. Ponadto gdy wejdę na serwer i wpiszę w konsole status dostaję takie informacje:

] status
hostname:  [Nazwa moda] amxx.pl
version :  48/1.1.2.7/Stdio 6153 insecure (secure mode enabled, disconnected from Steam3)(u) (10)
tcp/ip  :  127.0.1.1:27015
map     :  de_dust2 at: 0 x, 0 y, 0 z
players :  1 active (20 max)

#      name userid uniqueid frag time ping loss adr
# 1 "Makale" 1 STEAM_0:0:24290935   0 12:49   58    0
1 users

I jak widać w linii tcp/ip: jest podany adres pętli zwrtonej a nie serwera.

Moja komenda startowa: 

./hlds_run -game cstrike +port 27015 +maxplayers 20 -sys_ticrate 500 -pingboost 3 +exec server.cfg +map de_dust2

Na niej serwer odpala i działa prawidłowo.

Gdy do komendy dodam parametr +ip w ten sposób:

./hlds_run -game cstrike +port 27015 +ip 89.231.65.50 +maxplayers 20 -sys_ticrate 500 -pingboost 3 +exec server.cfg +map de_dust2

Dostaję taki błąd:

Auto-restarting the server on crash

Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/home/makale/.steam/sdk32/steamclient.so
with error:
/home/makale/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 13:12:29 Aug 29 2013 (6153)
STEAM Auth Server
couldn't exec banned.cfg
couldn't exec listip.cfg
WARNING: UDP_OpenSocket: port: 27015  bind: Cannot assign requested address
FATAL ERROR (shutting down): Couldn't allocate dedicated server IP port 27015.


Ręce mi opadły :( Proszę o wszelkie wskazówki.

 

 

EDIT: No port nie może być zajęty bo jak na porcie 27015 uruchomię serwer tylko bez parametry +ip to serwer odpali. Dodam +ip i serwer już nie odpala.

 

EDIT 2: Oczywiście IP 89.231.65.50 to IP zewnętrzne sieci przez które mogę się połączyć z serwerem z dowolnego miejsca na świecie. IP wewnętrzne w sieci to będzie o ile pamiętam: 192.168.0.20 i porty na routerach są przekierowane.

 

EDIT3: podając w linii startowej +ip 0.0.0.0 to serwer odpali, działa, mogę na niego wejść, nadal nie mogę go dodać do ulubionych i po wpisaniu status tcp/ip: 0.0.0.0:27015; dodając do +ip 192.168.0.20 to samo. serwer odpali, mogę wejść ale dodac do ulubionych nie mogę a w status pokaze sie tcp/ip: 192.168.0.20:27015


Użytkownik Makale edytował ten post 24.11.2017 21:36

  • +
  • -
  • 0

Poszukuję: serwerów do sieci, grafika do sieci oraz kilku stron WWW (prywatnych), adminów na serwery, itp.

Szukasz zajęcia na wolne chwile ? Pisz !

b_350_20_5A6C3E_383F2D_D2E1B5_2E3226.png

Zapraszam !


#2 XMMO.eu

    Nowy

  • Pijawka

Reputacja: 2
Nowy

  • Postów:3
  • Imię:Mateusz
Offline

Napisano 03.12.2017 17:42

Witaj spróbuj tego polecenia :) :

./hlds_run -game cstrike -ip 89.231.65.50 +port 27015  +maxplayers 20 -sys_ticrate 500 -pingboost 3 +exec server.cfg +map de_dust2

  • +
  • -
  • 1

#3 Makale

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 12
Początkujący

  • Postów:233
  • Lokalizacja:Płock
Offline

Napisano 09.12.2017 19:04

@UP

Dzięki tej komendzie serwer odpala prawidłowo lecz w konsoli dalej mam:

tcp/ip  :  127.0.1.1:27015

, a serwera nadal nie mogę dodać do uluboinych. Na GameTracker się dodaje bez problemu.


  • +
  • -
  • 0

Poszukuję: serwerów do sieci, grafika do sieci oraz kilku stron WWW (prywatnych), adminów na serwery, itp.

Szukasz zajęcia na wolne chwile ? Pisz !

b_350_20_5A6C3E_383F2D_D2E1B5_2E3226.png

Zapraszam !


#4 _McHappy

    Wszechpomocny

  • Użytkownik

Reputacja: 181
Profesjonalista

  • Postów:399
  • Imię:Radek
  • Lokalizacja:Tak
Offline

Napisano 09.12.2017 20:21

Musisz upewnić się, że Twój ISP nie blokuje portów wymaganych do prawidłowego działania serwera.

Innymi słowy, nie wystarczy, że przekierujesz porty w domowym routerze - Twój ISP również powinien udostępniać usługę przekierowania portów. Jest to globalny problem sieci typu osiedlowego itp.


Użytkownik _McHappy edytował ten post 09.12.2017 20:22

  • +
  • -
  • 0
b_350_20_19FF07_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_FFFFFF_000000_FFFFFF.png
b_350_20_FFFFFF_00FF00_000000_FFFFFF.png




Użytkownicy przeglądający ten temat: 1

0 użytkowników, 1 gości, 0 anonimowych