Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

[KOSZ] problem z show_ip.amxx


  • Zamknięty Temat jest zamknięty
3 odpowiedzi w tym temacie

#1 zGraferz

    Wszechwidzący

  • Użytkownik

Reputacja: 2
Nowy

  • Postów:282
  • Imię:Filip
Offline

Napisano 11.04.2015 07:34

Po wpisaniu debug zaraz za show_ip.amxx w logach erroru pokazuje mi następujące linijki

L 04/11/2015 - 08:23:54: Invalid CVAR pointer
L 04/11/2015 - 08:23:54: [AMXX] Displaying debug trace (plugin "show_ip.amxx")
L 04/11/2015 - 08:23:54: [AMXX] Run time error 10: native error (native "get_pcvar_num")
L 04/11/2015 - 08:23:54: [AMXX]    [0] show_ip_2860766.sma::client_connect (line 79)
L 04/11/2015 - 08:23:58: Invalid CVAR pointer
L 04/11/2015 - 08:23:58: [AMXX] Displaying debug trace (plugin "show_ip.amxx")
L 04/11/2015 - 08:23:58: [AMXX] Run time error 10: native error (native "get_pcvar_num")
L 04/11/2015 - 08:23:58: [AMXX]    [0] show_ip_2860766.sma::client_connect (line 79)

Czy przeszkodzą one w czymś i jak je można naprawić?


  • +
  • -
  • 0

#2 donaciak

    Godlike

  • Power User

Reputacja: 892
Czempion

  • Postów:2066
  • Steam:steam
  • Imię:Dawid
  • Lokalizacja:Kotlarka
Offline

Napisano 11.04.2015 09:06

Problem jest taki, że w funkcji client_connect natyw get_pcvar_num pobiera wartość cvara, lecz uchwyt tego cvara jest nieprawidłowy.  Jeżeli nie rozumiesz a chcesz aby Ci pomóc, podaj *.sma.

 

 

P.S. Mogą one przeszkodzić w poprawnym działaniu serwera.


  • +
  • -
  • 0

#3 zGraferz

    Wszechwidzący

  • Autor tematu
  • Użytkownik

Reputacja: 2
Nowy

  • Postów:282
  • Imię:Filip
Offline

Napisano 12.04.2015 09:57

Niestety rozumiem tylko połowicznie. Byłbym strasznie wdzięczny za pomoc. Tu jest .sma

Przejrzałem linijki funkcji, ale niestety nie dałem rady sam tego wykminić

 

Spoiler

  • +
  • -
  • 0

#4 MAGNET

    SourceLearned ;)

  • Moderator

Reputacja: 625
Wszechmogący

  • Postów:1510
  • GG:
  • Imię:Olek
  • Lokalizacja:Dalekoo
Offline

Napisano 12.04.2015 15:42

Nazywaj tematy zgodnie z ich treścią.
Napisz ponownie temat nazywając go tak, aby każdy wiedział o co chodzi.

Jednoznacznie określ problematykę tematu, wyróżniając go spośród reszty.
Nie dodawaj zbędnych informacji, znaków, ani emotikon w nazwie tematu.

Ten temat w ciągu 24 godzin zostanie przeniesiony do kosza.
  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych