Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.

  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie
Modyfikacja

edycja plugiana :)

Modyfikacja

  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 Arct

    Zaawansowany

  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 13.09.2009 13:59

Witam :)

mam kolejny problem z pluginem :(
powinien działać lecz dzieje sie inaczej :(

1) Chce dodać muzyczkę w mp3 na zakończenie rundy
np. wygrywa CT ma osobna i TT tak samo

Wgrałem taki plug lecz pojawia sie taki komunikat

Error - Inexistent File: "sound/misc/ctwin1.mp3"
Error - Inexistent File: "sound/misc/ctwin2.mp3"
Error - Inexistent File: "sound/misc/ctwin3.mp3"
Error - Inexistent File: "sound/misc/ttwin1.mp3"
Error - Inexistent File: "sound/misc/ttwin2.mp3"
Error - Inexistent File: "sound/misc/ttwin3.mp3"

pliki sa sciągane lecz nie wlaczaja sie

mam taki pliczek sma


#include <amxmodx>

public plugin_init()
{
  register_plugin("RoundSound","1.0","PaintLancer")
  register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
  register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
  new rand = random_num(0,2)

  client_cmd(0,"stopsound")

  switch(rand)
  {
   case 0: client_cmd(0, mp3 play "sound/misc/ttwin1")
   case 1: client_cmd(0, mp3 play "sound/misc/ttwin2")
   case 2: client_cmd(0, mp3 play "sound/misc/ttwin3")
  }

  return PLUGIN_CONTINUE
}

public ct_win()
{
  new rand = random_num(0,2)

  client_cmd(0,"stopsound")

  switch(rand)
  {
  case 0:  client_cmd(0, mp3 play "sound/misc/ctwin1")
  case 1:  client_cmd(0, mp3 play "sound/misc/ctwin2")
  case 2:  client_cmd(0, mp3 play "sound/misc/ctwin3")
  }

  return PLUGIN_CONTINUE
}

public plugin_precache()
{
  precache_generic("sound/misc/ctwin1.mp3")
  precache_generic("sound/misc/ctwin2.mp3")
  precache_generic("sound/misc/ctwin3.mp3")
  precache_generic("sound/misc/ttwin1.mp3")
  precache_generic("sound/misc/ttwin2.mp3")
  precache_generic("sound/misc/ttwin3.mp3")
  

  return PLUGIN_CONTINUE
}

2) Ten problem dotyczy odtwarzania muzyki przy łączeniu sie na server

tak samo jak w pierwszym przypadku pliki sa sciągane lecz nie odtwarza ich
(oczywiscie nazwe umieszam w "loadingsongs.ini"
np. hol1.mp3 hol2.mp3)

#include <amxmodx>
#include <amxmisc>

#define MAX_SONGS	50

public plugin_init() { 
	register_plugin("loading with music","2.0","eFrigid") 
	return PLUGIN_CONTINUE 
} 

new configsdir[200]
new configfile[200]
new song[MAX_SONGS][64]
new songdir[MAX_SONGS][64]
new bool:precached[MAX_SONGS]

public plugin_precache()
	{
	get_configsdir(configsdir,199)
	format(configfile,199,"%s/loadingsongs.ini",configsdir)
	new trash
	for(new i=0;i<MAX_SONGS;i++)
		{
		precached[i]=false
		read_file(configfile,i,song[i],63,trash)
		if(!equali(song[i][4],""))
			{
			precached[i]=true
			format(songdir[i],63,"sound/misc/%s",song[i])
			precache_sound(songdir[i])
		}
	}
}

public client_connect(id) { 
	new size = file_size(configfile,1)
	new rsong = random_num(1,size)
	new cursong[64], a
	read_file(configfile,rsong,cursong,63,a)
	client_cmd(id,"mp3 play sound/misc/%s",cursong)
	
	return PLUGIN_CONTINUE 
} 

proszę o pomoc
Oba typy formatow muzyki to MP3 ( i zdaje sie ze ppluginy takze sa do tego formatu)
lecz niestety nie dzialaja !

czekam na odp.

Pozdrawiam
  • +
  • -
  • 0

#2 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 13.09.2009 14:35

1. prawie dobrze, ale jak masz
case 0:  client_cmd(0, mp3 play "sound/misc/ctwin1")
to ma byc
case 0:  client_cmd(0, "mp3 play sound/misc/ctwin1.mp3")

  • +
  • -
  • 0

#3 mikus

    Ekipa PGC

  • Użytkownik

Reputacja: 72
Pomocny

  • Postów:406
  • GG:
  • Steam:steam
  • Lokalizacja:Wola
Offline

Napisano 13.09.2009 14:36

Zobacz to
#include <amxmodx>

public plugin_init()
{
  register_plugin("RoundSound","1.0","PaintLancer")
  register_event("SendAudio", "t_win", "a", "2&%!MRAD_terwin")
  register_event("SendAudio", "ct_win", "a", "2&%!MRAD_ctwin")
}

public t_win()
{
  new rand = random_num(0,2)

  client_cmd(0,"stopsound")

  switch(rand)
  {
   case 0: client_cmd(0, mp3 play "sound/misc/ttwin1.mp3")
   case 1: client_cmd(0, mp3 play "sound/misc/ttwin2.mp3")
   case 2: client_cmd(0, mp3 play "sound/misc/ttwin3.mp3")
  }

  return PLUGIN_CONTINUE
}

public ct_win()
{
  new rand = random_num(0,2)

  client_cmd(0,"stopsound")

  switch(rand)
  {
  case 0:  client_cmd(0, mp3 play "sound/misc/ctwin1.mp3")
  case 1:  client_cmd(0, mp3 play "sound/misc/ctwin2.mp3")
  case 2:  client_cmd(0, mp3 play "sound/misc/ctwin3.mp3")
  }

  return PLUGIN_CONTINUE
}

public plugin_precache()
{
  precache_generic("sound/misc/ctwin1.mp3")
  precache_generic("sound/misc/ctwin2.mp3")
  precache_generic("sound/misc/ctwin3.mp3")
  precache_generic("sound/misc/ttwin1.mp3")
  precache_generic("sound/misc/ttwin2.mp3")
  precache_generic("sound/misc/ttwin3.mp3")
 

  return PLUGIN_CONTINUE
}

  • +
  • -
  • 0

#4 Arct

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 14.09.2009 10:37

naven - dziki juz dziala :P (daje +) |
------------------------------------------
lecz mam problem jeszcze z tym drugim pliczkiem aby muzyka byla przy wchodzeniu na server troche poprawilem plik taki komunikat

wtedy mialem
Error - Inexistent File: "sound/misc/ttwin3.mp3"

ale po edytowaniu sciezki dostepu z
"sound/misc/ttwin3.mp3"
na
"misc/ttwin3.mp3"

pokazuje sie cos takiego

Missing RIFF/WAVE chunks
  • +
  • -
  • 0

#5 naven

    Hero

  • Power User

Reputacja: 200
Profesjonalista

  • Postów:1088
  • GG:
  • Imię:Adam
  • Lokalizacja:Cieszyn
Offline

Napisano 14.09.2009 15:01

Też tak mam, to nie wpływa na działanie pluginu. Nawet nie wiem czy tu chodzi o tą funkcję
  • +
  • -
  • 0

#6 Arct

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 15.09.2009 08:38

Też tak mam, to nie wpływa na działanie pluginu.


W tym problem ze plug nie dziala
w orginalnym sma (pierwszy post) po dodaniu muzyki ona sie sciaga lecz nie jest odtwarzana

jakby byl ten komunikat i chodzil to juz byly by postepy :P
  • +
  • -
  • 0

#7 mgr inż. Pavulon

    C35H60Br2N2O4

  • Przyjaciel

Reputacja: 1725
Godlike

  • Postów:6881
  • Steam:steam
  • Imię:Konrad
  • Lokalizacja:Koniecpol
Offline

Napisano 15.09.2009 09:40

format(songdir[i],63,"sound/misc/%s",song[i])
precache_sound(songdir[i])

w precache_sound ścieżkę podaje się bez sound/ na początku, ale:

client_cmd(id,"mp3 play sound/misc/%s",cursong)

w mp3 play sound/ już być musi.

Jeżeli chcesz aby w jednej i drugiej funkcji ścieżka była taka sama to skorzystaj z precache_generic zamiast _sound
  • +
  • -
  • 0

#8 Arct

    Zaawansowany

  • Autor tematu
  • Użytkownik

Reputacja: 10
Początkujący

  • Postów:104
  • Lokalizacja:Szczecin
Offline

Napisano 16.09.2009 08:04

ok dalem "precache_generic"
i sciezke dostempu sound/misc/%s
i teraz dziala hehe :)

dobra 2 problemy rozwiazane punkty przyznane topic do zamkniecia :)
  • +
  • -
  • 0





Również z jednym lub większą ilością słów kluczowych: Modyfikacja

Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych