Skocz do zawartości

  • Zaloguj korzystając z Facebooka Zaloguj korzystając z Twittera Zaloguj przez Steam Zaloguj poprzez Google      Logowanie »   
  • Rejestracja

Witamy w Nieoficjalnym polskim support'cie AMX Mod X

Witamy w Nieoficjalnym polskim support'cie AMX Mod X, jak w większości społeczności internetowych musisz się zarejestrować aby móc odpowiadać lub zakładać nowe tematy, ale nie bój się to jest prosty proces w którym wymagamy minimalnych informacji.
  • Rozpoczynaj nowe tematy i odpowiedaj na inne
  • Zapisz się do tematów i for, aby otrzymywać automatyczne uaktualnienia
  • Dodawaj wydarzenia do kalendarza społecznościowego
  • Stwórz swój własny profil i zdobywaj nowych znajomych
  • Zdobywaj nowe doświadczenia

Dołączona grafika Dołączona grafika

Guest Message by DevFuse
 

Zdjęcie

Serwer nie ładuje amxmodx


  • Nie możesz napisać tematu
  • Zaloguj się, aby dodać odpowiedź
6 odpowiedzi w tym temacie

#1 aragog

    Pomocny

  • Użytkownik

Reputacja: 16
Początkujący

  • Postów:58
  • Imię:Łukasz
  • Lokalizacja:Malopolska
Offline

Napisano 01.06.2014 19:01

POstawiłem se serwer do nauki na linuxie ale mam problem gdyż nie działa mi amxmodx po wpisaniu meta list pokazuje mi

meta list
Currently loaded plugins:
      description      stat pend  file              vers      src  load  unlod
 [ 1] dproto_EF        RUN   -    dproto_i386.so    v0.9.364  ini  Start Never
 [ 2] AMX Mod X        open  -    amxmodx_mm_i386.  v1.8.2-d  ini  Start ANY
2 plugins, 1 running

Całość konsoli po uruchomieniu serwera

Console initialized.
Using breakpad crash handler
Setting breakpad minidump AppID = 10
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Console initialized.
Base networking initialized.
"sv_cheats" changed to "1"
Initializing deltas
Protocol version 48
Exe version 1.1.2.7/Stdio (cstrike)
Exe build: 17:45:07 Apr 25 2013 (6027)
40.0 Mb heap
STEAM Auth Server
execing valve.rc
execing language.cfg
execing autoexec.cfg
execing violence.cfg
Server IP address XXXXXXXXXXXXXXXXX

Adding:  cstrike/addons/metamod/dlls/metamod.so

   Metamod version 1.20-am  Copyright (c) 2001-2006 Will Day <willday@metamod.org>
   Metamod comes with ABSOLUTELY NO WARRANTY; for details type `meta gpl'.
   This is free software, and you are welcome to redistribute it
   under certain conditions; type `meta gpl' for details.

Version 0.9.364 Linux
[DPROTO]: Loading config './dproto.cfg'
[DPROTO]:  LoggingMode = 2
[DPROTO]: Config sucessfully loaded.
[DPROTO]: Done.
Dll loaded for mod Counter-Strike
Spawn Server de_dust2
Clearing memory
Using WAD File: halflife.wad
Using WAD File: decals.wad
Using WAD File: cs_dust.wad
Texture load:    7.1ms
Building PAS...
Average leaves visible / audible / total: 133 / 395 / 1202
"sv_maxspeed" changed to "900"
Cvar_Set: variable room_type not found

GAME SKILL LEVEL:1
Cvar_Set: variable cl_himodels not found
"pausable" changed to "0"
Cvar_Set: variable v_dark not found
0 entities inhibited
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
dlopen failed trying to load:
/root/.steam/sdk32/steamclient.so
with error:
/root/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
PF_MessageEnd_I:  Unknown User Msg 127
"sv_accelerate" changed to "5"
"sv_stopspeed" changed to "75"
17 player server started
Executing map change config file

execing server.cfg
"sv_aim" changed to "0"
"sv_maxspeed" changed to "320"
"mp_timelimit" changed to "20"
"sv_cheats" changed to "0"
couldn't exec listip.cfg
couldn't exec banned.cfg
Sys_InitializeGameDLL called twice, skipping second call
execing server.cfg
couldn't exec listip.cfg
couldn't exec banned.cfg


  • +
  • -
  • 0

#2 Jadek

    Wszechwidzący

  • Użytkownik

Reputacja: 80
Zaawansowany

  • Postów:288
  • GG:
  • Imię:Daniel
  • Lokalizacja:Polska
Offline

Napisano 01.06.2014 19:02

Wejdź w cstrike/addons/metamod/plugins.ini Tam dopisz linijkę:

linux addons/amxmodx/dlls/amxmodx_mm_i386.so

  • +
  • -
  • 0

#3 aragog

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 16
Początkujący

  • Postów:58
  • Imię:Łukasz
  • Lokalizacja:Malopolska
Offline

Napisano 01.06.2014 20:27

Jak myślisz czy gdybym tego nie miał po wpisaniu meta list pokazało by mi to?

[ 2] AMX Mod X        open  -    amxmodx_mm_i386.  v1.8.2-d  ini  Start ANY

Czekam na inne propozycje co może być nie tak.


  • +
  • -
  • 0

#4 Jadek

    Wszechwidzący

  • Użytkownik

Reputacja: 80
Zaawansowany

  • Postów:288
  • GG:
  • Imię:Daniel
  • Lokalizacja:Polska
Offline

Napisano 01.06.2014 21:18

Przepraszam nie zauważyłem tego.


  • +
  • -
  • 0

#5 TyrTrek

    Wszechpomocny

  • Zbanowany

Reputacja: 28
Życzliwy

  • Postów:383
  • Lokalizacja:Poland
Offline

Napisano 01.06.2014 21:42

Jak myślisz czy gdybym tego nie miał po wpisaniu meta list pokazało by mi to?

[ 2] AMX Mod X        open  -    amxmodx_mm_i386.  v1.8.2-d  ini  Start ANY

Czekam na inne propozycje co może być nie tak.

amxmod ci nie dziala czy pluginy różne ? bo widać ze masz tylko 2 moduły odblokowane , resztę odblokowujesz w folderze configs pliku modules.ini czy coś takiego i ; usuwasz 


JEŚLI POMOGŁEM DAJ +


#6 DarkGL

    Nie oddam ciasteczka !

  • Właściciel

Reputacja: 6056
Godlike

  • Postów:10910
  • GG:
  • Steam:steam
  • Imię:Rafał
  • Lokalizacja:Warszawa
Offline

Napisano 02.06.2014 03:12

wersja amxxa i metamoda oraz csa ?


  • +
  • -
  • 0

#7 aragog

    Pomocny

  • Autor tematu
  • Użytkownik

Reputacja: 16
Początkujący

  • Postów:58
  • Imię:Łukasz
  • Lokalizacja:Malopolska
Offline

Napisano 02.06.2014 12:33

AMX Mod X - v1.8.2-d
dproto - v0.9.364

metamod - Metamod v1.20-am  2013-02-14 (5:13)

binarki - 48/1.1.2.7/Stdio 6027 secure

 

serwer po zmianie komendy startowej niby ładuje amxx'a ale po wejściu na serwer crashuje

Metamod v1.20-am  2013-02-14 (5:13)L 06/02/2014 - 07:33:54: [DPROTO]: Client 0 - Set AuthIdType 1 [Native]; pClient = 0xb38f5f08
L 06/02/2014 - 07:33:54: "eutwf<1><STEAM_0:0:47132722><>" connected, address "83.10.247.44:25730"
L 06/02/2014 - 07:33:55: "eutwf<1><STEAM_0:0:47132722><>" STEAM USERID validated
L 06/02/2014 - 07:33:57: "eutwf<1><STEAM_0:0:47132722><>" entered the game
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20140602073357_1.dmp
success = yes
response:  CrashID=bp-df069253-8916-41ba-8db9-004142140602
Segmentation fault

  • +
  • -
  • 0




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych